aboutsummaryrefslogtreecommitdiff
path: root/math/octave/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2018-05-07 00:34:29 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2018-05-07 00:34:29 +0000
commit86c94f6daf3afbda738b63d661f998375b9c8318 (patch)
tree5a5b69cd3373e8922e26db076347c9d2c6bf3bda /math/octave/Makefile
parentbc03a4d33ce93ea1996a43f3b44386344e09a6f9 (diff)
Notes
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 3fd98c91fa21..edf3ea81c6f3 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -3,7 +3,7 @@
PORTNAME= octave
PORTVERSION= ${OCTAVE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math java
MASTER_SITES= GNU
@@ -33,7 +33,7 @@ LIB_DEPENDS= libGraphicsMagick.so:graphics/GraphicsMagick \
libumfpack.so:math/suitesparse \
libglpk.so:math/glpk \
libgl2ps.so:print/gl2ps \
- libqscintilla2_qt4.so:devel/qscintilla2 \
+ libqscintilla2_qt5.so:devel/qscintilla2-qt5 \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libdrm.so:graphics/libdrm \
@@ -48,7 +48,8 @@ USE_TEX= dvipsk:build formats:build
GNU_CONFIGURE= yes
USE_JAVA= yes
JAVA_VERSION= 1.7+
-USE_QT4= corelib gui network opengl moc_build qmake_build rcc_build uic_build linguist_build help help-tools
+USE_QT5= core gui help network opengl \
+ qmake_build buildtools_build linguist_build
USE_XORG= x11 xext xfixes xft
USE_GL= gl glu
@@ -71,7 +72,7 @@ CONFIGURE_ARGS= --host=${GNU_HOST} \
--enable-shared \
--disable-jit \
--disable-openmp \
- --with-qt=4 \
+ --with-qt=5 \
--with-OSMesa-includedir=${LOCALBASE}/include/GL \
--with-OSMesa-libdir=${LOCALBASE}/lib