aboutsummaryrefslogtreecommitdiff
path: root/math/octave/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-12-05 02:58:07 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-12-05 02:58:07 +0000
commit7aedc5ee6d75dd279042310c5190d7cae413cc57 (patch)
tree9d80a523eb9811e9736e9ab336aa7600c74e2f6a /math/octave/Makefile
parent9572f6878debf289daf21e0c60ed327ba694c4fd (diff)
downloadports-7aedc5ee6d75dd279042310c5190d7cae413cc57.tar.gz
ports-7aedc5ee6d75dd279042310c5190d7cae413cc57.zip
Notes
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 835beaa4d40c..f0e8c59870d1 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -24,10 +24,6 @@ USE_PERL5_BUILD=yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-BROKEN= "Does not build on amd64 (Shared libraries must be compiled with -fPIC)"
-.endif
-
.if ${PORTOBJFORMAT} == "elf"
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
.else
@@ -40,9 +36,14 @@ BLAS_LIBS= "-L${LOCALBASE}/lib -lf77blas -lcblas -latlas"
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --host=${GNU_HOST} \
- --with-fftw --with-blas=${BLAS_LIBS} --with-lapack=-lalapack \
- --enable-shared
+CONIGURE_ARGS= --host=${GNU_HOST} \
+ --with-fftw --with-blas=${BLAS_LIBS} --with-lapack=-lalapack
+.if ${ARCH} == "amd64"
+CONFIGURE_ARGS+= --disable-shared
+.else
+CONFIGURE_ARGS+= --enable-shared
+.endif
+
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \