aboutsummaryrefslogtreecommitdiff
path: root/math/octave
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2023-03-09 02:17:52 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2023-03-09 02:17:52 +0000
commitd4f3d79c367cdbcac8927e2a730a98982a10e50e (patch)
treeb786dde3d16f478bf0ff3dfb6da1cce5aa3af897 /math/octave
parent89db86003595725638977f09c2435f5f60ec0835 (diff)
downloadports-d4f3d79c367cdbcac8927e2a730a98982a10e50e.tar.gz
ports-d4f3d79c367cdbcac8927e2a730a98982a10e50e.zip
Diffstat (limited to 'math/octave')
-rw-r--r--math/octave/Makefile4
-rw-r--r--math/octave/distinfo6
-rw-r--r--math/octave/files/patch-build-aux_get-source-mtime.sh11
-rw-r--r--math/octave/files/patch-build-aux_mk-pkg-add.sh11
-rw-r--r--math/octave/files/patch-liboctave_util_oct-sparse.h36
-rw-r--r--math/octave/files/patch-scripts_pkg_private_configure__make.m11
-rw-r--r--math/octave/pkg-plist110
7 files changed, 95 insertions, 94 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 4490f50a0912..6a8f4d69eb57 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -1,6 +1,5 @@
PORTNAME= octave
PORTVERSION= ${OCTAVE_VERSION}
-PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= GNU
@@ -13,7 +12,8 @@ LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:devel/gperf \
${LOCALBASE}/bin/makeinfo:print/texinfo \
gnuplot:math/gnuplot \
- gsed:textproc/gsed
+ gsed:textproc/gsed \
+ ${LOCALBASE}/include/rapidjson/rapidjson.h:devel/rapidjson
RUN_DEPENDS= ${LOCALBASE}/bin/makeinfo:print/texinfo \
gnuplot:math/gnuplot \
gsed:textproc/gsed
diff --git a/math/octave/distinfo b/math/octave/distinfo
index 2d1f84014fc0..35da24153816 100644
--- a/math/octave/distinfo
+++ b/math/octave/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1667671914
-SHA256 (octave-7.3.0.tar.xz) = a508ee6aebccfa68967c9e7e0a08793c4ca8e4ddace723aabdb8f71ad34d57f1
-SIZE (octave-7.3.0.tar.xz) = 26215288
+TIMESTAMP = 1678317449
+SHA256 (octave-8.1.0.tar.xz) = 9bbe1963e650dfc45da704ac0d9824c378b28f66e483bf6dda232cdd50d09102
+SIZE (octave-8.1.0.tar.xz) = 26957620
diff --git a/math/octave/files/patch-build-aux_get-source-mtime.sh b/math/octave/files/patch-build-aux_get-source-mtime.sh
new file mode 100644
index 000000000000..5194ba7f5d50
--- /dev/null
+++ b/math/octave/files/patch-build-aux_get-source-mtime.sh
@@ -0,0 +1,11 @@
+--- build-aux/get-source-mtime.sh.orig 2023-03-09 00:21:26 UTC
++++ build-aux/get-source-mtime.sh
+@@ -34,7 +34,7 @@
+ set -e
+
+ PERL=${PERL:-perl}
+-SED=${SED:-sed}
++SED=gsed
+
+ if [ $# -ne 1 ]; then
+ echo "usage: get-source-mtime.sh SRCDIR" 1>&2
diff --git a/math/octave/files/patch-build-aux_mk-pkg-add.sh b/math/octave/files/patch-build-aux_mk-pkg-add.sh
new file mode 100644
index 000000000000..59c7718b9894
--- /dev/null
+++ b/math/octave/files/patch-build-aux_mk-pkg-add.sh
@@ -0,0 +1,11 @@
+--- build-aux/mk-pkg-add.sh.orig 2023-03-09 00:21:26 UTC
++++ build-aux/mk-pkg-add.sh
+@@ -31,7 +31,7 @@ export LC_ALL
+
+ set -e
+
+-SED=${SED:-sed}
++SED=gsed
+
+ srcdir="$1"
+ shift
diff --git a/math/octave/files/patch-liboctave_util_oct-sparse.h b/math/octave/files/patch-liboctave_util_oct-sparse.h
deleted file mode 100644
index 34a9b5005f75..000000000000
--- a/math/octave/files/patch-liboctave_util_oct-sparse.h
+++ /dev/null
@@ -1,36 +0,0 @@
---- liboctave/util/oct-sparse.h.orig 2022-11-02 18:19:56 UTC
-+++ liboctave/util/oct-sparse.h
-@@ -89,16 +89,27 @@
- # include <SuiteSparseQR.hpp>
- #endif
-
--// Cope with new SuiteSparse versions
-+// Cope with API differences between SuiteSparse versions
-
- #if defined (SUITESPARSE_VERSION)
--# if (SUITESPARSE_VERSION >= SUITESPARSE_VER_CODE (4, 3))
-+# if (SUITESPARSE_VERSION >= SUITESPARSE_VER_CODE (7, 0))
- # define SUITESPARSE_NAME(name) SuiteSparse_ ## name
--# define SUITESPARSE_ASSIGN_FPTR(f_name, f_var, f_assign) (SuiteSparse_config.f_name = f_assign)
--# define SUITESPARSE_ASSIGN_FPTR2(f_name, f_var, f_assign) (SuiteSparse_config.f_name = SUITESPARSE_NAME (f_assign))
-+# define SUITESPARSE_SET_FCN(name) SuiteSparse_config_ ## name ## _set
-+# define SUITESPARSE_ASSIGN_FPTR(f_name, f_var, f_assign) \
-+ SUITESPARSE_SET_FCN(f_name) (f_assign)
-+# define SUITESPARSE_ASSIGN_FPTR2(f_name, f_var, f_assign) \
-+ SUITESPARSE_SET_FCN(f_name) (SUITESPARSE_NAME (f_assign))
-+# elif (SUITESPARSE_VERSION >= SUITESPARSE_VER_CODE (4, 3))
-+# define SUITESPARSE_NAME(name) SuiteSparse_ ## name
-+# define SUITESPARSE_ASSIGN_FPTR(f_name, f_var, f_assign) \
-+ (SuiteSparse_config.f_name = f_assign)
-+# define SUITESPARSE_ASSIGN_FPTR2(f_name, f_var, f_assign) \
-+ (SuiteSparse_config.f_name = SUITESPARSE_NAME (f_assign))
- # else
--# define SUITESPARSE_ASSIGN_FPTR(f_name, f_var, f_assign) (f_var = f_assign)
--# define SUITESPARSE_ASSIGN_FPTR2(f_name, f_var, f_assign) (f_var = CHOLMOD_NAME (f_assign))
-+# define SUITESPARSE_ASSIGN_FPTR(f_name, f_var, f_assign) \
-+ (f_var = f_assign)
-+# define SUITESPARSE_ASSIGN_FPTR2(f_name, f_var, f_assign) \
-+ (f_var = CHOLMOD_NAME (f_assign))
- # endif
- #endif
-
diff --git a/math/octave/files/patch-scripts_pkg_private_configure__make.m b/math/octave/files/patch-scripts_pkg_private_configure__make.m
deleted file mode 100644
index 92084c4f3b91..000000000000
--- a/math/octave/files/patch-scripts_pkg_private_configure__make.m
+++ /dev/null
@@ -1,11 +0,0 @@
---- scripts/pkg/private/configure_make.m.orig 2022-11-02 18:19:56 UTC
-+++ scripts/pkg/private/configure_make.m
-@@ -110,7 +110,7 @@ function configure_make (desc, packdir, verbose)
- endif
-
- if (exist (fullfile (src, "Makefile"), "file"))
-- [status, output] = shell (sprintf ("%s make --jobs %i --directory '%s'",
-+ [status, output] = shell (sprintf ("%s gmake --jobs %i --directory '%s'",
- scenv, jobs, src), verbose);
- if (status != 0)
- disp (output);
diff --git a/math/octave/pkg-plist b/math/octave/pkg-plist
index 5a1a85dd96bd..603756dfda8c 100644
--- a/math/octave/pkg-plist
+++ b/math/octave/pkg-plist
@@ -6,7 +6,9 @@ bin/octave-cli
bin/octave-cli-%%OCTAVE_VERSION%%
bin/octave-config
bin/octave-config-%%OCTAVE_VERSION%%
+include/octave-%%OCTAVE_VERSION%%/octave/Array-base.cc
include/octave-%%OCTAVE_VERSION%%/octave/Array-fwd.h
+include/octave-%%OCTAVE_VERSION%%/octave/Array-oct.cc
include/octave-%%OCTAVE_VERSION%%/octave/Array-util.h
include/octave-%%OCTAVE_VERSION%%/octave/Array.cc
include/octave-%%OCTAVE_VERSION%%/octave/Array.h
@@ -167,7 +169,6 @@ include/octave-%%OCTAVE_VERSION%%/octave/lo-amos-proto.h
include/octave-%%OCTAVE_VERSION%%/octave/lo-arpack-proto.h
include/octave-%%OCTAVE_VERSION%%/octave/lo-array-errwarn.h
include/octave-%%OCTAVE_VERSION%%/octave/lo-blas-proto.h
-include/octave-%%OCTAVE_VERSION%%/octave/lo-cutils.h
include/octave-%%OCTAVE_VERSION%%/octave/lo-error.h
include/octave-%%OCTAVE_VERSION%%/octave/lo-hash.h
include/octave-%%OCTAVE_VERSION%%/octave/lo-ieee.h
@@ -535,6 +536,7 @@ include/octave-%%OCTAVE_VERSION%%/octave/oct-atomic.h
include/octave-%%OCTAVE_VERSION%%/octave/oct-base64.h
include/octave-%%OCTAVE_VERSION%%/octave/oct-binmap.h
include/octave-%%OCTAVE_VERSION%%/octave/oct-cmplx.h
+include/octave-%%OCTAVE_VERSION%%/octave/oct-conf-post-public.h
include/octave-%%OCTAVE_VERSION%%/octave/oct-convn.h
include/octave-%%OCTAVE_VERSION%%/octave/oct-env.h
include/octave-%%OCTAVE_VERSION%%/octave/oct-errno.h
@@ -764,14 +766,14 @@ include/octave-%%OCTAVE_VERSION%%/octave/xdiv.h
include/octave-%%OCTAVE_VERSION%%/octave/xnorm.h
include/octave-%%OCTAVE_VERSION%%/octave/xpow.h
lib/octave/%%OCTAVE_VERSION%%/liboctave.so
-lib/octave/%%OCTAVE_VERSION%%/liboctave.so.9
-lib/octave/%%OCTAVE_VERSION%%/liboctave.so.9.0.0
-%%QT5%%lib/octave/%%OCTAVE_VERSION%%/liboctgui.so
-%%QT5%%lib/octave/%%OCTAVE_VERSION%%/liboctgui.so.8
-%%QT5%%lib/octave/%%OCTAVE_VERSION%%/liboctgui.so.8.0.0
+lib/octave/%%OCTAVE_VERSION%%/liboctave.so.10
+lib/octave/%%OCTAVE_VERSION%%/liboctave.so.10.0.0
+lib/octave/%%OCTAVE_VERSION%%/liboctgui.so
+lib/octave/%%OCTAVE_VERSION%%/liboctgui.so.9
+lib/octave/%%OCTAVE_VERSION%%/liboctgui.so.9.0.0
lib/octave/%%OCTAVE_VERSION%%/liboctinterp.so
-lib/octave/%%OCTAVE_VERSION%%/liboctinterp.so.10
-lib/octave/%%OCTAVE_VERSION%%/liboctinterp.so.10.0.0
+lib/octave/%%OCTAVE_VERSION%%/liboctinterp.so.11
+lib/octave/%%OCTAVE_VERSION%%/liboctinterp.so.11.0.0
lib/octave/%%OCTAVE_VERSION%%/oct/%%GNU_HOST%%/PKG_ADD
lib/octave/%%OCTAVE_VERSION%%/oct/%%GNU_HOST%%/__delaunayn__.oct
lib/octave/%%OCTAVE_VERSION%%/oct/%%GNU_HOST%%/__fltk_uigetfile__.oct
@@ -787,12 +789,12 @@ lib/octave/%%OCTAVE_VERSION%%/oct/%%GNU_HOST%%/fftw.oct
lib/octave/%%OCTAVE_VERSION%%/oct/%%GNU_HOST%%/gzip.oct
libdata/pkgconfig/octave.pc
libdata/pkgconfig/octinterp.pc
-%%QT5%%libexec/octave/%%OCTAVE_VERSION%%/exec/%%GNU_HOST%%/octave-gui
-%%QT5%%libexec/octave/%%OCTAVE_VERSION%%/exec/%%GNU_HOST%%/octave-svgconvert
-%%PORTDOCS%%man/man1/mkoctfile.1.gz
-%%PORTDOCS%%man/man1/octave-cli.1.gz
-%%PORTDOCS%%man/man1/octave-config.1.gz
-%%PORTDOCS%%man/man1/octave.1.gz
+libexec/octave/%%OCTAVE_VERSION%%/exec/%%GNU_HOST%%/octave-gui
+libexec/octave/%%OCTAVE_VERSION%%/exec/%%GNU_HOST%%/octave-svgconvert
+man/man1/mkoctfile.1.gz
+man/man1/octave-cli.1.gz
+man/man1/octave-config.1.gz
+man/man1/octave.1.gz
share/applications/org.octave.Octave.desktop
%%PORTDOCS%%%%DOCSDIR%%/liboctave.ps
%%PORTDOCS%%%%DOCSDIR%%/octave.ps
@@ -810,6 +812,7 @@ share/icons/hicolor/48x48/apps/octave.png
share/icons/hicolor/512x512/apps/octave.png
share/icons/hicolor/64x64/apps/octave.png
share/icons/hicolor/scalable/apps/octave.svg
+share/info/dir
share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/data/penny.mat
%%DATADIR%%/%%OCTAVE_VERSION%%/data/west0479.mat
@@ -1147,6 +1150,11 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/fcn-handle/shared-ctx.tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/fcn-handle/shared_ctx.m
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/fcn-handle/static-method.tst
+%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/file-encoding/.oct-config
+%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/file-encoding/CP1251/.oct-config
+%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/file-encoding/CP1251/test_CP1251.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/file-encoding/file-encoding.tst
+%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/file-encoding/test_CP1252.m
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/for.tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/func.tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/fixed/global.tst
@@ -1300,6 +1308,7 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/corefcn/ordqz.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/corefcn/ordschur.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/corefcn/pinv.cc-tst
+%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/corefcn/pow2.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/corefcn/pr-output.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/corefcn/psi.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/corefcn/qr.cc-tst
@@ -1343,7 +1352,6 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/dldfcn/convhulln.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/dldfcn/fftw.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/dldfcn/gzip.cc-tst
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/octave-value/ov-base.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/octave-value/ov-bool-mat.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/octave-value/ov-cell.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/octave-value/ov-class.cc-tst
@@ -1369,7 +1377,7 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/parse-tree/pt-fcn-handle.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/parse-tree/pt-idx.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/libinterp/parse-tree/pt-tm-const.cc-tst
-%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/liboctave/array/Array.cc-tst
+%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/liboctave/array/Array-base.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/liboctave/array/CMatrix.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/liboctave/array/CSparse.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/liboctave/array/Sparse.cc-tst
@@ -1379,6 +1387,10 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/liboctave/array/fMatrix.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/liboctave/array/idx-vector.cc-tst
%%DATADIR%%/%%OCTAVE_VERSION%%/etc/tests/liboctave/util/oct-inttypes.cc-tst
+%%DATADIR%%/%%OCTAVE_VERSION%%/fonts/FreeMono.otf
+%%DATADIR%%/%%OCTAVE_VERSION%%/fonts/FreeMonoBold.otf
+%%DATADIR%%/%%OCTAVE_VERSION%%/fonts/FreeMonoBoldOblique.otf
+%%DATADIR%%/%%OCTAVE_VERSION%%/fonts/FreeMonoOblique.otf
%%DATADIR%%/%%OCTAVE_VERSION%%/fonts/FreeSans.otf
%%DATADIR%%/%%OCTAVE_VERSION%%/fonts/FreeSansBold.otf
%%DATADIR%%/%%OCTAVE_VERSION%%/fonts/FreeSansBoldOblique.otf
@@ -1387,25 +1399,26 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/imagelib/octave-logo.ico
%%DATADIR%%/%%OCTAVE_VERSION%%/imagelib/octave-logo.svg
%%DATADIR%%/%%OCTAVE_VERSION%%/imagelib/octave-sombrero.png
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/be_BY.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/ca_ES.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/de_DE.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/en_US.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/es_ES.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/eu_ES.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/fr_FR.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/hu_HU.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/it_IT.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/ja_JP.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/lt_LT.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/nl_NL.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/pt_BR.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/pt_PT.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/ru_RU.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/tr_TR.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/uk_UA.qm
-%%QT5%%%%DATADIR%%/%%OCTAVE_VERSION%%/locale/zh_CN.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/be_BY.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/ca_ES.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/de_DE.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/en_US.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/es_ES.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/eu_ES.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/fr_FR.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/hu_HU.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/it_IT.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/ja_JP.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/lt_LT.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/nl_NL.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/pt_BR.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/pt_PT.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/ru_RU.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/tr_TR.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/uk_UA.qm
+%%DATADIR%%/%%OCTAVE_VERSION%%/locale/zh_CN.qm
%%DATADIR%%/%%OCTAVE_VERSION%%/m/+containers/Map.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/+matlab/+lang/MemoizedFunction.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/+matlab/+lang/makeUniqueStrings.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/+matlab/+lang/makeValidName.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/+matlab/+net/base64decode.m
@@ -1464,7 +1477,8 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/m/deprecated/disable_diagonal_matrix.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/deprecated/disable_permutation_matrix.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/deprecated/disable_range.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/m/deprecated/runtests.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/deprecated/shift.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/deprecated/sparse_auto_mutate.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/elfun/.oct-config
%%DATADIR%%/%%OCTAVE_VERSION%%/m/elfun/acosd.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/elfun/acot.m
@@ -1534,6 +1548,8 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/logspace.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/nextpow2.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/num2str.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/pagectranspose.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/pagetranspose.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/pol2cart.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/polyarea.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/postpad.m
@@ -1552,7 +1568,6 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/rng.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/rot90.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/rotdim.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/shift.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/shiftdim.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/sortrows.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/general/sph2cart.m
@@ -1607,6 +1622,7 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/m/gui/uibuttongroup.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/gui/uicontextmenu.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/gui/uicontrol.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/gui/uifigure.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/gui/uigetdir.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/gui/uigetfile.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/gui/uimenu.m
@@ -1717,16 +1733,24 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/m/java/javaclasspath.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/java/javamem.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/java/javarmpath.m
-%%JAVA%%%%DATADIR%%/%%OCTAVE_VERSION%%/m/java/octave.jar
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/java/octave.jar
%%DATADIR%%/%%OCTAVE_VERSION%%/m/java/usejava.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/.oct-config
%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/argnames.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/cat.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/char.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/disp.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/exist.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/feval.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/formula.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/horzcat.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/inline.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/nargin.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/nargout.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/subsref.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/symvar.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/vectorize.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/@inline/vertcat.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/__vectorize__.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/findstr.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/legacy/flipdim.m
@@ -1781,6 +1805,7 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/bunzip2.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/cast.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/citation.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/clearAllMemoizedCaches.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/clearvars.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/compare_versions.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/computer.m
@@ -1812,6 +1837,7 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/loadobj.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/ls.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/ls_command.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/memoize.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/memory.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/menu.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/methods.m
@@ -1850,6 +1876,7 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/pack.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/parseparams.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/perl.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/private/__memoize__.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/private/__publish_html_output__.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/private/__publish_latex_output__.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/private/__w2mpth__.m
@@ -1865,7 +1892,6 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/swapbytes.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/symvar.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/tar.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/tempdir.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/unix.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/unpack.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/miscellaneous/untar.m
@@ -2334,7 +2360,6 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/m/specfun/nchoosek.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/specfun/nthroot.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/specfun/perms.m
-%%DATADIR%%/%%OCTAVE_VERSION%%/m/specfun/pow2.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/specfun/primes.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/specfun/reallog.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/specfun/realpow.m
@@ -2387,6 +2412,7 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/%%OCTAVE_VERSION%%/m/statistics/movstd.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/statistics/movsum.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/statistics/movvar.m
+%%DATADIR%%/%%OCTAVE_VERSION%%/m/statistics/normalize.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/statistics/prctile.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/statistics/quantile.m
%%DATADIR%%/%%OCTAVE_VERSION%%/m/statistics/range.m
@@ -2475,9 +2501,9 @@ share/metainfo/org.octave.Octave.appdata.xml
%%DATADIR%%/site/m/startup/octaverc
@dir lib/octave/%%OCTAVE_VERSION%%/site/oct/%%GNU_HOST%%
@dir lib/octave/site/oct/%%GNU_HOST%%
-@dir lib/octave/site/oct/api-v57/%%GNU_HOST%%
+@dir lib/octave/site/oct/api-v58/%%GNU_HOST%%
@dir libexec/octave/%%OCTAVE_VERSION%%/site/exec/%%GNU_HOST%%
-@dir libexec/octave/api-v57/site/exec/%%GNU_HOST%%
+@dir libexec/octave/api-v58/site/exec/%%GNU_HOST%%
@dir libexec/octave/site/exec/%%GNU_HOST%%
@dir %%DATADIR%%/%%OCTAVE_VERSION%%/site/m
-@dir %%DATADIR%%/site/api-v57/m
+@dir %%DATADIR%%/site/api-v58/m