aboutsummaryrefslogtreecommitdiff
path: root/math/octomap
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-11-20 07:10:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-11-20 07:10:02 +0000
commit0364bc62ac42c8cd03f28062e567a1ee22f7df7d (patch)
tree3d0f2092bcef6ba74dbadcf00eb4d3d23dfa106f /math/octomap
parent4e2a7cb6da6f19ebd0fa7926323c77236bed3238 (diff)
downloadports-0364bc62ac42c8cd03f28062e567a1ee22f7df7d.tar.gz
ports-0364bc62ac42c8cd03f28062e567a1ee22f7df7d.zip
Notes
Diffstat (limited to 'math/octomap')
-rw-r--r--math/octomap/Makefile28
-rw-r--r--math/octomap/distinfo3
-rw-r--r--math/octomap/files/patch-dynamicEDT3D_src_CMakeLists.txt37
-rw-r--r--math/octomap/files/patch-octomap_src_CMakeLists.txt33
-rw-r--r--math/octomap/files/patch-octomap_src_math_CMakeLists.txt24
-rw-r--r--math/octomap/files/patch-octovis_CMakeLists__src.txt37
-rw-r--r--math/octomap/pkg-descr24
-rw-r--r--math/octomap/pkg-plist67
8 files changed, 253 insertions, 0 deletions
diff --git a/math/octomap/Makefile b/math/octomap/Makefile
new file mode 100644
index 000000000000..195abf394749
--- /dev/null
+++ b/math/octomap/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= octomap
+DISTVERSIONPREFIX= v
+DISTVERSION= v1.6.5-158
+DISTVERSIONSUFFIX= -g23cb13f
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Efficient probabilistic 3D mapping framework based on octrees
+
+LICENSE= BSD3CLAUSE GPLv2
+LICENSE_COMB= dual
+LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/octomap/LICENSE.txt
+LICENSE_FILE_GPLv2= ${WRKSRC}/octovis/LICENSE.txt
+
+BUILD_DEPENDS= libQGLViewer>0:graphics/libQGLViewer # otherwise it doesn't build, see https://github.com/OctoMap/octomap/issues/225
+
+USES= cmake:outsource localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= OctoMap
+USE_LDCONFIG= yes
+
+# Viewer is broken: https://github.com/OctoMap/octomap/issues/224, and libQGLViewer detection is broken: https://github.com/OctoMap/octomap/issues/225
+#CMAKE_ON= OCTOVIS_QT5
+CMAKE_ARGS= -DQGLVIEWER_BASE_DIR:PATH=${LOCALBASE}/include/QGLViewer #-DQGLViewer_LIBRARY_DIR_OTHER:PATH=${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/math/octomap/distinfo b/math/octomap/distinfo
new file mode 100644
index 000000000000..a5b37a93a86d
--- /dev/null
+++ b/math/octomap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542694534
+SHA256 (OctoMap-octomap-vv1.6.5-158-g23cb13f_GH0.tar.gz) = ff6f654b492b672b1a7ec39ccba4e29e1bdf215c318e388a22a3c78ab2fa34c7
+SIZE (OctoMap-octomap-vv1.6.5-158-g23cb13f_GH0.tar.gz) = 1682523
diff --git a/math/octomap/files/patch-dynamicEDT3D_src_CMakeLists.txt b/math/octomap/files/patch-dynamicEDT3D_src_CMakeLists.txt
new file mode 100644
index 000000000000..b1d079bf3ab1
--- /dev/null
+++ b/math/octomap/files/patch-dynamicEDT3D_src_CMakeLists.txt
@@ -0,0 +1,37 @@
+--- dynamicEDT3D/src/CMakeLists.txt.orig 2018-11-20 06:37:53 UTC
++++ dynamicEDT3D/src/CMakeLists.txt
+@@ -9,28 +9,28 @@ set_target_properties(dynamicedt3d PROPE
+ )
+ target_link_libraries(dynamicedt3d ${OCTOMAP_LIBRARIES})
+
+-add_library(dynamicedt3d-static STATIC ${dynamicEDT3D_SRCS})
+-target_link_libraries(dynamicedt3d-static ${OCTOMAP_LIBRARIES})
++#add_library(dynamicedt3d-static STATIC ${dynamicEDT3D_SRCS})
++#target_link_libraries(dynamicedt3d-static ${OCTOMAP_LIBRARIES})
+
+-SET_TARGET_PROPERTIES(dynamicedt3d-static PROPERTIES OUTPUT_NAME "dynamicedt3d")
++#SET_TARGET_PROPERTIES(dynamicedt3d-static PROPERTIES OUTPUT_NAME "dynamicedt3d")
+
+ if(NOT EXISTS "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/dynamicEDT3D")
+ file(MAKE_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/dynamicEDT3D")
+ endif()
+
+-export(TARGETS dynamicedt3d dynamicedt3d-static
++export(TARGETS dynamicedt3d
+ FILE "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/dynamicEDT3D/dynamicEDT3DTargets.cmake")
+
+ # directly depend on the octomap library target when building the
+ # complete distribution, so it it recompiled as needed
+ if (CMAKE_PROJECT_NAME STREQUAL "octomap-distribution")
+- ADD_DEPENDENCIES(dynamicedt3d-static octomap-static)
++ #ADD_DEPENDENCIES(dynamicedt3d-static octomap-static)
+ ADD_DEPENDENCIES(dynamicedt3d octomap)
+ endif()
+
+ ADD_SUBDIRECTORY(examples)
+
+-install(TARGETS dynamicedt3d dynamicedt3d-static
++install(TARGETS dynamicedt3d
+ EXPORT dynamicEDT3DTargets
+ INCLUDES DESTINATION include
+ ${INSTALL_TARGETS_DEFAULT_ARGS}
diff --git a/math/octomap/files/patch-octomap_src_CMakeLists.txt b/math/octomap/files/patch-octomap_src_CMakeLists.txt
new file mode 100644
index 000000000000..c28fe82274dc
--- /dev/null
+++ b/math/octomap/files/patch-octomap_src_CMakeLists.txt
@@ -0,0 +1,33 @@
+--- octomap/src/CMakeLists.txt.orig 2018-11-20 06:33:58 UTC
++++ octomap/src/CMakeLists.txt
+@@ -16,9 +16,9 @@ set_target_properties( octomap PROPERTIE
+ VERSION ${OCTOMAP_VERSION}
+ SOVERSION ${OCTOMAP_SOVERSION}
+ )
+-ADD_LIBRARY( octomap-static STATIC ${octomap_SRCS})
+-SET_TARGET_PROPERTIES(octomap-static PROPERTIES OUTPUT_NAME "octomap")
+-add_dependencies(octomap-static octomath-static)
++#ADD_LIBRARY( octomap-static STATIC ${octomap_SRCS})
++#SET_TARGET_PROPERTIES(octomap-static PROPERTIES OUTPUT_NAME "octomap")
++#add_dependencies(octomap-static octomath-static)
+
+ TARGET_LINK_LIBRARIES(octomap octomath)
+
+@@ -26,7 +26,7 @@ if(NOT EXISTS "${CMAKE_LIBRARY_OUTPUT_DI
+ file(MAKE_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/octomap")
+ endif()
+
+-export(TARGETS octomap octomap-static
++export(TARGETS octomap
+ APPEND FILE "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/octomap/octomap-targets.cmake")
+
+ ADD_SUBDIRECTORY( testing )
+@@ -67,7 +67,7 @@ TARGET_LINK_LIBRARIES(intersection_examp
+ ADD_EXECUTABLE(octree2pointcloud octree2pointcloud.cpp)
+ TARGET_LINK_LIBRARIES(octree2pointcloud octomap)
+
+-install(TARGETS octomap octomap-static
++install(TARGETS octomap
+ EXPORT octomap-targets
+ INCLUDES DESTINATION include
+ ${INSTALL_TARGETS_DEFAULT_ARGS}
diff --git a/math/octomap/files/patch-octomap_src_math_CMakeLists.txt b/math/octomap/files/patch-octomap_src_math_CMakeLists.txt
new file mode 100644
index 000000000000..ef05b4b2c385
--- /dev/null
+++ b/math/octomap/files/patch-octomap_src_math_CMakeLists.txt
@@ -0,0 +1,24 @@
+--- octomap/src/math/CMakeLists.txt.orig 2018-11-20 06:36:08 UTC
++++ octomap/src/math/CMakeLists.txt
+@@ -14,17 +14,17 @@ SET_TARGET_PROPERTIES( octomath PROPERTI
+ )
+ # INSTALL_NAME_DIR seems to be necessary for MacOS X
+
+-ADD_LIBRARY( octomath-static STATIC ${octomath_SRCS})
+-SET_TARGET_PROPERTIES(octomath-static PROPERTIES OUTPUT_NAME "octomath")
++#ADD_LIBRARY( octomath-static STATIC ${octomath_SRCS})
++#SET_TARGET_PROPERTIES(octomath-static PROPERTIES OUTPUT_NAME "octomath")
+
+ if(NOT EXISTS "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/octomap")
+ file(MAKE_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/octomap")
+ endif()
+
+-export(TARGETS octomath octomath-static
++export(TARGETS octomath
+ APPEND FILE "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/octomap/octomap-targets.cmake")
+
+-install(TARGETS octomath octomath-static
++install(TARGETS octomath
+ EXPORT octomap-targets
+ INCLUDES DESTINATION include
+ ${INSTALL_TARGETS_DEFAULT_ARGS}
diff --git a/math/octomap/files/patch-octovis_CMakeLists__src.txt b/math/octomap/files/patch-octovis_CMakeLists__src.txt
new file mode 100644
index 000000000000..2f45d787664f
--- /dev/null
+++ b/math/octomap/files/patch-octovis_CMakeLists__src.txt
@@ -0,0 +1,37 @@
+--- octovis/CMakeLists_src.txt.orig 2018-11-20 06:29:27 UTC
++++ octovis/CMakeLists_src.txt
+@@ -99,9 +99,9 @@ include_directories(${CMAKE_CURRENT_BINA
+
+
+ # Library target
+-add_library(octovis-static STATIC ${viewerlib_SRCS})
+-target_link_libraries(octovis-static)
+-set_target_properties(octovis-static PROPERTIES OUTPUT_NAME octovis)
++#add_library(octovis-static STATIC ${viewerlib_SRCS})
++#target_link_libraries(octovis-static)
++#set_target_properties(octovis-static PROPERTIES OUTPUT_NAME octovis)
+
+ add_library(octovis-shared SHARED ${viewerlib_SRCS})
+ target_link_libraries(octovis-shared
+@@ -119,7 +119,7 @@ set_target_properties(octovis-shared PRO
+ # directly depend on the octomap library target when building the
+ # complete distribution, so it is recompiled as needed
+ if (CMAKE_PROJECT_NAME STREQUAL "octomap-distribution")
+- ADD_DEPENDENCIES(octovis-static octomap-static)
++ #ADD_DEPENDENCIES(octovis-static octomap-static)
+ ADD_DEPENDENCIES(octovis-shared octomap)
+ endif()
+
+@@ -146,10 +146,10 @@ if(NOT EXISTS "${CMAKE_LIBRARY_OUTPUT_DI
+ file(MAKE_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/octovis")
+ endif()
+
+-export(TARGETS octovis octovis-static octovis-shared
++export(TARGETS octovis octovis-shared
+ FILE "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/octovis/octovis-targets.cmake")
+
+-install(TARGETS octovis octovis-static octovis-shared
++install(TARGETS octovis octovis-shared
+ EXPORT octovis-targets
+ INCLUDES DESTINATION include
+ ${INSTALL_TARGETS_DEFAULT_ARGS}
diff --git a/math/octomap/pkg-descr b/math/octomap/pkg-descr
new file mode 100644
index 000000000000..ce3d27f3adb0
--- /dev/null
+++ b/math/octomap/pkg-descr
@@ -0,0 +1,24 @@
+The OctoMap library implements a 3D occupancy grid mapping approach, providing
+data structures and mapping algorithms in C++ particularly suited for robotics.
+The map implementation is based on an octree and is designed to meet the
+following requirements:
+* Full 3D model. The map is able to model arbitrary environments without prior
+ assumptions about it. The representation models occupied areas as well as free
+ space. Unknown areas of the environment are implicitly encoded in the map.
+ While the distinction between free and occupied space is essential for safe
+ robot navigation, information about unknown areas is important, e.g., for
+ autonomous exploration of an environment.
+* Updatable. It is possible to add new information or sensor readings at any
+ time. Modeling and updating is done in a probabilistic fashion. This accounts
+ for sensor noise or measurements which result from dynamic changes in the
+ environment, e.g., because of dynamic objects.
+* Flexible. The extent of the map does not have to be known in advance. Instead,
+ the map is dynamically expanded as needed. The map is multi-resolution so
+ that, for instance, a high-level planner is able to use a coarse map, while a
+ local planner may operate using a fine resolution.
+ close-up views.
+* Compact. The map is stored efficiently, both in memory and on disk. It is
+ possible to generate compressed files for later usage or convenient exchange
+ between robots even under bandwidth constraints.
+
+WWW: https://octomap.github.io/
diff --git a/math/octomap/pkg-plist b/math/octomap/pkg-plist
new file mode 100644
index 000000000000..b081bb989527
--- /dev/null
+++ b/math/octomap/pkg-plist
@@ -0,0 +1,67 @@
+bin/binvox2bt
+bin/bt2vrml
+bin/compare_octrees
+bin/convert_octree
+bin/edit_octree
+bin/eval_octree_accuracy
+bin/graph2tree
+bin/log2graph
+include/dynamicEDT3D/bucketedqueue.h
+include/dynamicEDT3D/bucketedqueue.hxx
+include/dynamicEDT3D/dynamicEDT3D.h
+include/dynamicEDT3D/dynamicEDTOctomap.h
+include/dynamicEDT3D/dynamicEDTOctomap.hxx
+include/dynamicEDT3D/point.h
+include/octomap/AbstractOcTree.h
+include/octomap/AbstractOccupancyOcTree.h
+include/octomap/ColorOcTree.h
+include/octomap/CountingOcTree.h
+include/octomap/MCTables.h
+include/octomap/MapCollection.h
+include/octomap/MapCollection.hxx
+include/octomap/MapNode.h
+include/octomap/MapNode.hxx
+include/octomap/OcTree.h
+include/octomap/OcTreeBase.h
+include/octomap/OcTreeBaseImpl.h
+include/octomap/OcTreeBaseImpl.hxx
+include/octomap/OcTreeDataNode.h
+include/octomap/OcTreeDataNode.hxx
+include/octomap/OcTreeIterator.hxx
+include/octomap/OcTreeKey.h
+include/octomap/OcTreeNode.h
+include/octomap/OcTreeStamped.h
+include/octomap/OccupancyOcTreeBase.h
+include/octomap/OccupancyOcTreeBase.hxx
+include/octomap/Pointcloud.h
+include/octomap/ScanGraph.h
+include/octomap/math/Pose6D.h
+include/octomap/math/Quaternion.h
+include/octomap/math/Utils.h
+include/octomap/math/Vector3.h
+include/octomap/octomap.h
+include/octomap/octomap_deprecated.h
+include/octomap/octomap_timing.h
+include/octomap/octomap_types.h
+include/octomap/octomap_utils.h
+lib/libdynamicedt3d.so
+lib/libdynamicedt3d.so.1.9
+lib/libdynamicedt3d.so.1.9.0
+lib/liboctomap.so
+lib/liboctomap.so.1.9
+lib/liboctomap.so.1.9.0
+lib/liboctomath.so
+lib/liboctomath.so.1.9
+lib/liboctomath.so.1.9.0
+libdata/pkgconfig/dynamicEDT3D.pc
+libdata/pkgconfig/octomap.pc
+share/dynamicEDT3D/dynamicEDT3DConfig-version.cmake
+share/dynamicEDT3D/dynamicEDT3DConfig.cmake
+share/dynamicEDT3D/dynamicEDT3DTargets-%%CMAKE_BUILD_TYPE%%.cmake
+share/dynamicEDT3D/dynamicEDT3DTargets.cmake
+share/dynamic_edt_3d/package.xml
+%%DATADIR%%/octomap-config-version.cmake
+%%DATADIR%%/octomap-config.cmake
+%%DATADIR%%/octomap-targets-%%CMAKE_BUILD_TYPE%%.cmake
+%%DATADIR%%/octomap-targets.cmake
+%%DATADIR%%/package.xml