aboutsummaryrefslogtreecommitdiff
path: root/math/oleo
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-07-19 04:54:32 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-07-19 04:54:32 +0000
commitf5be3fcbca5769556830cee6cb08c3500da1b5d7 (patch)
tree63f7570fe6335577c7413c200e04fff8c3b0f46d /math/oleo
parent74c0a9561d68c40e40ff0b58b4403863beef86f2 (diff)
downloadports-f5be3fcbca5769556830cee6cb08c3500da1b5d7.tar.gz
ports-f5be3fcbca5769556830cee6cb08c3500da1b5d7.zip
Fix build, and another fixes for building.
Unbreak. PR: 51923 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=85174
Diffstat (limited to 'math/oleo')
-rw-r--r--math/oleo/Makefile10
-rw-r--r--math/oleo/files/patch-src::eval.c11
-rw-r--r--math/oleo/files/patch-src::global.h11
-rw-r--r--math/oleo/files/patch-src::io-utils.c20
-rw-r--r--math/oleo/files/patch-src::ref.c20
5 files changed, 65 insertions, 7 deletions
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index bc23a643aba3..0ca33741efe7 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -15,12 +15,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= The GNU spreadsheet for X11 and terminals
-BROKEN= "Does not compile"
-
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+USE_PERL5_BUILD= yes
+USE_BISON= yes
USE_REINPLACE= yes
-USE_AUTOCONF_VER=213
+USE_AUTOCONF_VER= 213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --with-x --without-xlt --without-SciPlot
@@ -38,10 +38,6 @@ CONFIGURE_ARGS+= --without-motif
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
pre-everything::
.if !defined(WITH_MOTIF)
@${ECHO_MSG}
diff --git a/math/oleo/files/patch-src::eval.c b/math/oleo/files/patch-src::eval.c
new file mode 100644
index 000000000000..81e13020ce62
--- /dev/null
+++ b/math/oleo/files/patch-src::eval.c
@@ -0,0 +1,11 @@
+--- src/eval.c.org Sat Jul 19 13:42:11 2003
++++ src/eval.c Sat Jul 19 13:47:43 2003
+@@ -565,7 +565,7 @@
+ case CONST_NINF:
+ case CONST_NAN:
+ p->type = TYP_FLT;
+- p->Float = (byte == CONST_INF) ? __plinf : ((byte == CONST_NINF) ? __neinf : __nan);
++ p->Float = (byte == CONST_INF) ? __plinf : ((byte == CONST_NINF) ? __neinf : ___nan);
+ break;
+
+ case VAR:
diff --git a/math/oleo/files/patch-src::global.h b/math/oleo/files/patch-src::global.h
new file mode 100644
index 000000000000..4594ce52a581
--- /dev/null
+++ b/math/oleo/files/patch-src::global.h
@@ -0,0 +1,11 @@
+--- src/global.h.org Thu Feb 15 05:54:50 2001
++++ src/global.h Sat Jul 19 13:45:39 2003
+@@ -208,7 +208,7 @@
+ extern char nname[];
+
+ extern VOIDSTAR parse_hash;
+-extern double __plinf, __neinf, __nan;
++extern double __plinf, __neinf, ___nan;
+
+ /* These have two uses. During parsing, these contain the
+ * base address of all relative references. During evaluation,
diff --git a/math/oleo/files/patch-src::io-utils.c b/math/oleo/files/patch-src::io-utils.c
new file mode 100644
index 000000000000..05b02e8aa396
--- /dev/null
+++ b/math/oleo/files/patch-src::io-utils.c
@@ -0,0 +1,20 @@
+--- src/io-utils.c.org Sat Jul 19 13:42:11 2003
++++ src/io-utils.c Sat Jul 19 13:48:32 2003
+@@ -71,7 +71,7 @@
+
+ double __plinf;
+ double __neinf;
+-double __nan;
++double ___nan;
+
+ char nname[] = "#NOT_A_NUMBER";
+ char iname[] = "#INFINITY";
+@@ -125,7 +125,7 @@
+ __neinf = divide (-1., 0.);
+ (void) signal (SIGFPE, ignore_sig);
+ #endif
+- __nan = __plinf + __neinf;
++ ___nan = __plinf + __neinf;
+ }
+
+
diff --git a/math/oleo/files/patch-src::ref.c b/math/oleo/files/patch-src::ref.c
new file mode 100644
index 000000000000..f7e9c2a48953
--- /dev/null
+++ b/math/oleo/files/patch-src::ref.c
@@ -0,0 +1,20 @@
+--- src/ref.c.orig Wed Feb 14 08:38:06 2001
++++ src/ref.c Sat Jul 19 13:51:39 2003
+@@ -263,7 +263,7 @@
+ read_new_value (CELLREF row, CELLREF col, char *form, char *val)
+ {
+ unsigned char *new_bytes;
+- extern double __plinf, __neinf, __nan;
++ extern double __plinf, __neinf, ___nan;
+
+ cur_row = row;
+ cur_col = col;
+@@ -348,7 +348,7 @@
+ else if (!stricmp (nname, val))
+ {
+ SET_TYP (my_cell, TYP_FLT);
+- my_cell->cell_flt = __nan;
++ my_cell->cell_flt = ___nan;
+ }
+ else
+ {