aboutsummaryrefslogtreecommitdiff
path: root/math/oleo
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-14 09:40:28 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-14 09:40:28 +0000
commit001e4c6a572ff939cf8e594e4dafe809c3250ce3 (patch)
tree7e3d2f253d0f7ccf077b09d1342562429ba7428e /math/oleo
parentba0df27f641acf22293a623fc4161a96ee67d4ca (diff)
downloadports-001e4c6a572ff939cf8e594e4dafe809c3250ce3.tar.gz
ports-001e4c6a572ff939cf8e594e4dafe809c3250ce3.zip
Notes
Diffstat (limited to 'math/oleo')
-rw-r--r--math/oleo/Makefile21
-rw-r--r--math/oleo/files/patch-Xresources_Makefile.in26
-rw-r--r--math/oleo/files/patch-po_Makefile.in.in48
-rw-r--r--math/oleo/files/patch-src_io-term.c22
-rw-r--r--math/oleo/pkg-plist1
5 files changed, 102 insertions, 16 deletions
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 76016bb6707a..35b7799c0535 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -11,25 +11,26 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gahr@FreeBSD.org
COMMENT= The GNU spreadsheet for X11 and terminals
+LICENSE= GPLv2
+
USE_PERL5= build
USES= bison perl5
USE_AUTOTOOLS= autoconf213
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+MAKE_ENV+= DESTDIR=${STAGEDIR}
CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --with-x --without-xlt --without-SciPlot
INFO= oleo
-PORTDOCS= AUTHORS FAQ
OPTIONS_DEFINE= MOTIF NLS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMOTIF}
-LIB_DEPENDS+= plot:${PORTSDIR}/graphics/plotutils \
- Xbae:${PORTSDIR}/x11-toolkits/xbae \
- XmHTML:${PORTSDIR}/x11-toolkits/xmhtml
+LIB_DEPENDS+= libplot.so:${PORTSDIR}/graphics/plotutils \
+ libXbae.so:${PORTSDIR}/x11-toolkits/xbae \
+ libXmHTML.so:${PORTSDIR}/x11-toolkits/xmhtml
USES+= motif
CONFIGURE_ARGS+= --with-motif
.else
@@ -48,20 +49,14 @@ PLIST_SUB= NLS="@comment "
post-patch:
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
+ @${REINPLACE_CMD} -e '/^DESTDIR/s|=|?=|' \
+ ${WRKSRC}/Makefile.in
.for pof in en fr nl
@${REINPLACE_CMD} -e "s|CHARSET|ISO-8859-1|;s|ENCODING|8bit|" \
${WRKSRC}/po/${pof}.po
.endfor
-.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e "s|am: install-docDATA|am:|" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|install-info-am install-htmlDATA|install-info-am|" \
${WRKSRC}/doc/Makefile.in
-.endif
-
-pre-build:
-.for file in src/io-term.c
- cd ${WRKSRC} && ${MV} ${file} ${file}.pre_iconv \
- && iconv -c -t ascii ${file}.pre_iconv > ${file} || ${TRUE}
-.endfor
.include <bsd.port.mk>
diff --git a/math/oleo/files/patch-Xresources_Makefile.in b/math/oleo/files/patch-Xresources_Makefile.in
new file mode 100644
index 000000000000..c0d488ee0bbb
--- /dev/null
+++ b/math/oleo/files/patch-Xresources_Makefile.in
@@ -0,0 +1,26 @@
+--- Xresources/Makefile.in.orig 2001-03-10 15:32:46.000000000 +0100
++++ Xresources/Makefile.in 2014-02-14 10:40:45.000000000 +0100
+@@ -41,7 +41,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DESTDIR =
++DESTDIR ?=
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -235,10 +235,10 @@
+
+
+ install-data-hook:
+- $(mkinstalldirs) $(nldir) $(frdir) $(endir)
+- $(INSTALL_DATA) $(srcdir)/Oleo.nl $(nldir)/Oleo
+- $(INSTALL_DATA) $(srcdir)/Oleo.fr $(frdir)/Oleo
+- $(INSTALL_DATA) $(srcdir)/Oleo.en $(endir)/Oleo
++ $(mkinstalldirs) $(DESTDIR)$(nldir) $(DESTDIR)$(frdir) $(DESTDIR)$(endir)
++ $(INSTALL_DATA) $(srcdir)/Oleo.nl $(DESTDIR)$(nldir)/Oleo
++ $(INSTALL_DATA) $(srcdir)/Oleo.fr $(DESTDIR)$(frdir)/Oleo
++ $(INSTALL_DATA) $(srcdir)/Oleo.en $(DESTDIR)$(endir)/Oleo
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/math/oleo/files/patch-po_Makefile.in.in b/math/oleo/files/patch-po_Makefile.in.in
new file mode 100644
index 000000000000..8c483b50f5c1
--- /dev/null
+++ b/math/oleo/files/patch-po_Makefile.in.in
@@ -0,0 +1,48 @@
+--- po/Makefile.in.in.orig 1998-08-27 23:15:29.000000000 +0200
++++ po/Makefile.in.in 2014-02-14 10:38:35.000000000 +0100
+@@ -16,6 +16,8 @@
+ top_srcdir = @top_srcdir@
+ VPATH = @srcdir@
+
++DESTDIR ?=
++
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ datadir = $(prefix)/@DATADIRNAME@
+@@ -111,16 +113,16 @@
+ install-data-no: all
+ install-data-yes: all
+ if test -r "$(MKINSTALLDIRS)"; then \
+- $(MKINSTALLDIRS) $(datadir); \
++ $(MKINSTALLDIRS) $(DESTDIR)$(datadir); \
+ else \
+- $(SHELL) $(top_srcdir)/mkinstalldirs $(datadir); \
++ $(SHELL) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(datadir); \
+ fi
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+ case "$$cat" in \
+- *.gmo) destdir=$(gnulocaledir);; \
+- *) destdir=$(localedir);; \
++ *.gmo) destdir=$(DESTDIR)$(gnulocaledir);; \
++ *) destdir=$(DESTDIR)$(localedir);; \
+ esac; \
+ lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
+ dir=$$destdir/$$lang/LC_MESSAGES; \
+@@ -153,12 +155,12 @@
+ done
+ if test "$(PACKAGE)" = "gettext"; then \
+ if test -r "$(MKINSTALLDIRS)"; then \
+- $(MKINSTALLDIRS) $(gettextsrcdir); \
++ $(MKINSTALLDIRS) $(DESTDIR)$(gettextsrcdir); \
+ else \
+- $(SHELL) $(top_srcdir)/mkinstalldirs $(gettextsrcdir); \
++ $(SHELL) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(gettextsrcdir); \
+ fi; \
+ $(INSTALL_DATA) $(srcdir)/Makefile.in.in \
+- $(gettextsrcdir)/Makefile.in.in; \
++ $(DESTDIR)$(gettextsrcdir)/Makefile.in.in; \
+ else \
+ : ; \
+ fi
diff --git a/math/oleo/files/patch-src_io-term.c b/math/oleo/files/patch-src_io-term.c
index 16f7beff3e03..d0374732df68 100644
--- a/math/oleo/files/patch-src_io-term.c
+++ b/math/oleo/files/patch-src_io-term.c
@@ -1,5 +1,14 @@
---- src/io-term.c.orig 2008-02-08 16:43:28.000000000 +0100
-+++ src/io-term.c 2008-02-08 16:45:06.000000000 +0100
+--- src/io-term.c.orig 2014-02-14 10:32:37.000000000 +0100
++++ src/io-term.c 2014-02-14 10:32:58.000000000 +0100
+@@ -1,7 +1,7 @@
+ /*
+ * $Id: io-term.c,v 1.51 2001/02/13 23:38:06 danny Exp $
+ *
+- * Copyright © 1990, 1992, 1993, 1999, 2000, 2001 Free Software Foundation, Inc.
++ * Copyright 1990, 1992, 1993, 1999, 2000, 2001 Free Software Foundation, Inc.
+ *
+ * This file is part of Oleo, the GNU Spreadsheet.
+ *
@@ -220,6 +220,7 @@
{
int set_opt = 1;
@@ -23,3 +32,12 @@
if (Preferences[i].cont == 0)
return 1;
+@@ -1023,7 +1026,7 @@
+ case 'v':
+ case 'V':
+ printf(_("%s %s\n"), GNU_PACKAGE, VERSION);
+- printf(_("Copyright © 1992-2000 Free Software Foundation, Inc.\n"));
++ printf(_("Copyright 1992-2000 Free Software Foundation, Inc.\n"));
+ printf(_("%s comes with ABSOLUTELY NO WARRANTY.\n"), GNU_PACKAGE);
+ printf(_("You may redistribute copies of %s\n"), PACKAGE);
+ printf(_("under the terms of the GNU General Public License.\n"));
diff --git a/math/oleo/pkg-plist b/math/oleo/pkg-plist
index 2135037d08ac..e809d2229db7 100644
--- a/math/oleo/pkg-plist
+++ b/math/oleo/pkg-plist
@@ -5,7 +5,6 @@ bin/oleo
%%DATADIR%%/Oleo
%%DATADIR%%/fr/Oleo
%%DATADIR%%/nl/Oleo
-%%PORTDOCS%%%%DOCSDIR%%/oleo.html
@dirrm %%DATADIR%%/nl
@dirrm %%DATADIR%%/fr
@dirrm %%DATADIR%%