aboutsummaryrefslogtreecommitdiff
path: root/math/openblas
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2017-08-25 19:58:51 +0000
committerDon Lewis <truckman@FreeBSD.org>2017-08-25 19:58:51 +0000
commitf74fc65c9a2da00b61a64444afdcc3ed46818e0f (patch)
treebb5fa8caf7e146b131a41545573ea6393bbfcf00 /math/openblas
parentc0db7227aa7ed409b668fdc65deb8354fc1adbec (diff)
downloadports-f74fc65c9a2da00b61a64444afdcc3ed46818e0f.tar.gz
ports-f74fc65c9a2da00b61a64444afdcc3ed46818e0f.zip
Upgrade OpenBLAS to 0.2.20:
* Fixed several thread race and locking bugs * Fixed default LAPACK optimization level * Updated LAPACK to 3.7.0 * Power - Optimizations for Power9 - Fixed several Power8 assembly bugs * ARM - New optimized Vulcan and ThunderX2T99 targets - Support for ARMV7 SOFT_FP ABI (make ARM_SOFTFP_ABI=1) - Detect all cpu cores including offline ones - Fix compilation with CLANG * MIPS - Fixed several threading issues - Fix compilation with CLANG * x86_64 - Detect Intel Bay Trail and Apollo Lake - Detect Intel Sky Lake and Kaby Lake - Detect Intel Knights Landing - Detect AMD A8, A10, A12 and Ryzen - Fix cmake builds for Haswell and related cpus - Fix building for Sandybridge with CLANG 3.9 Pet portlint (USES vs. USE) PR: 221633 Submitted by: truckman Approved by: phd_kimberlite@yahoo.co.jp (maintainer)
Notes
Notes: svn path=/head/; revision=448738
Diffstat (limited to 'math/openblas')
-rw-r--r--math/openblas/Makefile6
-rw-r--r--math/openblas/distinfo6
-rw-r--r--math/openblas/files/patch-common__arm.h8
-rw-r--r--math/openblas/files/patch-driver_others_blas__server.c11
4 files changed, 6 insertions, 25 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index 97d54d36ecea..b414bcff4e2f 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= openblas
-PORTVERSION= 0.2.19
-PORTREVISION= 1
+PORTVERSION= 0.2.20
DISTVERSIONPREFIX= v
PORTEPOCH= 1
CATEGORIES= math
@@ -17,13 +16,14 @@ COMMENT= Optimized BLAS library based on GotoBLAS2
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+USES= fortran gmake perl5
+
USE_GITHUB= yes
GH_ACCOUNT= xianyi
GH_PROJECT= OpenBLAS
LARGE_FILE= large.tgz
TIMING_FILE= timing.tgz
-USES= fortran gmake perl5
USE_LDCONFIG= yes
USE_PERL5= build
diff --git a/math/openblas/distinfo b/math/openblas/distinfo
index ca001bf58e33..1e4fac8f5207 100644
--- a/math/openblas/distinfo
+++ b/math/openblas/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1483295026
+TIMESTAMP = 1503123719
SHA256 (openblas/large.tgz) = f328d88b7fa97722f271d7d0cfea1c220e0f8e5ed5ff01d8ef1eb51d6f4243a1
SIZE (openblas/large.tgz) = 2595
SHA256 (openblas/timing.tgz) = 999c65f8ea8bd4eac7f1c7f3463d4946917afd20a997807300fe35d70122f3af
SIZE (openblas/timing.tgz) = 1059485
-SHA256 (openblas/xianyi-OpenBLAS-v0.2.19_GH0.tar.gz) = 9c40b5e4970f27c5f6911cb0a28aa26b6c83f17418b69f8e5a116bb983ca8557
-SIZE (openblas/xianyi-OpenBLAS-v0.2.19_GH0.tar.gz) = 10834034
+SHA256 (openblas/xianyi-OpenBLAS-v0.2.20_GH0.tar.gz) = 5ef38b15d9c652985774869efd548b8e3e972e1e99475c673b25537ed7bcf394
+SIZE (openblas/xianyi-OpenBLAS-v0.2.20_GH0.tar.gz) = 11637301
diff --git a/math/openblas/files/patch-common__arm.h b/math/openblas/files/patch-common__arm.h
index 079c7f7f9d23..8d61c3e232d8 100644
--- a/math/openblas/files/patch-common__arm.h
+++ b/math/openblas/files/patch-common__arm.h
@@ -14,11 +14,3 @@
#ifndef F_INTERFACE
#define REALNAME ASMNAME
-@@ -105,7 +112,6 @@ static inline int blas_quickdivide(blasi
- #define PROLOGUE \
- .arm ;\
- .global REALNAME ;\
-- .func REALNAME ;\
- REALNAME:
-
- #define EPILOGUE
diff --git a/math/openblas/files/patch-driver_others_blas__server.c b/math/openblas/files/patch-driver_others_blas__server.c
deleted file mode 100644
index 199ba825026b..000000000000
--- a/math/openblas/files/patch-driver_others_blas__server.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- driver/others/blas_server.c.orig 2016-04-12 19:29:19 UTC
-+++ driver/others/blas_server.c
-@@ -70,7 +70,7 @@ USE OF THIS SOFTWARE, EVEN IF ADVISED OF
- /*********************************************************************/
-
- #include "common.h"
--#if defined(OS_LINUX) || defined(OS_NETBSD) || defined(OS_DARWIN) || defined(OS_ANDROID) || defined(OS_SUNOS)
-+#if defined(OS_LINUX) || defined(OS_NETBSD) || defined(OS_DARWIN) || defined(OS_ANDROID) || defined(OS_SUNOS) || defined(OS_FREEBSD)
- #include <dlfcn.h>
- #include <signal.h>
- #include <sys/resource.h>