aboutsummaryrefslogtreecommitdiff
path: root/math/openlibm
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-17 07:17:10 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-17 07:17:10 +0000
commit783848e5d2d8bae8228c9c0c243f37fcd6ded146 (patch)
tree40381eee99aa111747c24255010afa0506e15f53 /math/openlibm
parent32667877aa88e8629976fa06ff230d685e7e84f3 (diff)
downloadports-783848e5d2d8bae8228c9c0c243f37fcd6ded146.tar.gz
ports-783848e5d2d8bae8228c9c0c243f37fcd6ded146.zip
Notes
Diffstat (limited to 'math/openlibm')
-rw-r--r--math/openlibm/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/math/openlibm/Makefile b/math/openlibm/Makefile
index 25cc98b3c31b..6408b90d9a1c 100644
--- a/math/openlibm/Makefile
+++ b/math/openlibm/Makefile
@@ -17,9 +17,8 @@ BROKEN_armv6= fails to compile: a parameter list without types is only allowed
BROKEN_armv7= fails to compile: a parameter list without types is only allowed in a function definition
BROKEN_mips= fails to compile: No rule to make target mips/Make.files
BROKEN_mips64= fails to compile: No rule to make target mips64/Make.files
-BROKEN_powerpc64= fails to build: gmake: clang: Command not found
-USES= gmake
+USES= compiler:c11 gmake
USE_GITHUB= yes
GH_ACCOUNT= JuliaMath
GH_PROJECT= openlibm
@@ -28,8 +27,16 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-MAKE_ENV+= prefix=${PREFIX}
+MAKE_ENV+= prefix=${PREFIX} ${MAKE_ENV_${CHOSEN_COMPILER_TYPE}}
+MAKE_ENV_gcc= USEGCC=1 USECLANG=0
+MAKE_ENV_clang= USEGCC=0 USECLANG=1
TEST_TARGET= check
+post-patch:
+ ${REINPLACE_CMD} -e 's/USEGCC =/USEGCC ?=/g' \
+ -e 's/USECLANG =/USECLANG ?=/g' \
+ -e '/TOOLPREFIX)gcc/s/$$/${GCC_DEFAULT}/g' \
+ ${WRKSRC}/Make.inc
+
.include <bsd.port.post.mk>