aboutsummaryrefslogtreecommitdiff
path: root/math/p5-AI-DecisionTree
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-28 00:19:45 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-28 00:19:45 +0000
commitec8af96e9ad50efadc6da1610c2fee6e94567c11 (patch)
tree6a7664b4b0970d5d1693cdade7f4e48d018c002e /math/p5-AI-DecisionTree
parentbb173a1a69620736a10d61ab97dddeb2f8eb3d9a (diff)
downloadports-ec8af96e9ad50efadc6da1610c2fee6e94567c11.tar.gz
ports-ec8af96e9ad50efadc6da1610c2fee6e94567c11.zip
Notes
Diffstat (limited to 'math/p5-AI-DecisionTree')
-rw-r--r--math/p5-AI-DecisionTree/Makefile29
-rw-r--r--math/p5-AI-DecisionTree/distinfo1
-rw-r--r--math/p5-AI-DecisionTree/pkg-descr11
-rw-r--r--math/p5-AI-DecisionTree/pkg-plist10
4 files changed, 51 insertions, 0 deletions
diff --git a/math/p5-AI-DecisionTree/Makefile b/math/p5-AI-DecisionTree/Makefile
new file mode 100644
index 000000000000..f2580b892a8a
--- /dev/null
+++ b/math/p5-AI-DecisionTree/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: math/p5-AI-DecisionTree
+# Date created: Dec 29 2003
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AI-DecisionTree
+PORTVERSION= 0.08
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= AI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Perl module for Automatically Learning Decision Trees
+
+PERL_CONFIGURE= yes
+
+MAN3= AI::DecisionTree.3 \
+ AI::DecisionTree::Instance.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-AI-DecisionTree/distinfo b/math/p5-AI-DecisionTree/distinfo
new file mode 100644
index 000000000000..9dcce82e3908
--- /dev/null
+++ b/math/p5-AI-DecisionTree/distinfo
@@ -0,0 +1 @@
+MD5 (AI-DecisionTree-0.08.tar.gz) = eaed56886a22506b8ed5f6dab88e7060
diff --git a/math/p5-AI-DecisionTree/pkg-descr b/math/p5-AI-DecisionTree/pkg-descr
new file mode 100644
index 000000000000..1c4f630b451a
--- /dev/null
+++ b/math/p5-AI-DecisionTree/pkg-descr
@@ -0,0 +1,11 @@
+The AI::DecisionTree module automatically creates so-called "decision trees"
+to explain a set of training data. A decision tree is a kind of categorizer
+that use a flowchart-like process for categorizing new instances.
+
+A decision tree like this one can be learned from training data, and
+then applied to previously unseen data to obtain results that are consistent
+with the training data.
+
+WWW: http://search.cpan.org/dist/AI-DecisionTree
+
+Author: Ken Williams <ken@mathforum.org>
diff --git a/math/p5-AI-DecisionTree/pkg-plist b/math/p5-AI-DecisionTree/pkg-plist
new file mode 100644
index 000000000000..c27c4062cf4b
--- /dev/null
+++ b/math/p5-AI-DecisionTree/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/AI/DecisionTree.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/AI/DecisionTree/Instance.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AI/DecisionTree/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AI/DecisionTree/Instance/Instance.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AI/DecisionTree/Instance/Instance.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/AI/DecisionTree
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/AI/DecisionTree/Instance
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/AI/DecisionTree
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/AI 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/AI 2>/dev/null || true