aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Graph/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-01-19 15:43:23 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-01-19 15:43:23 +0000
commit17313780a72b0b89b5410bdce6119458e924254c (patch)
treee21e6103894f29378705323a2df3eb2bec8144ef /math/p5-Graph/Makefile
parent0bed2294bfa81c91ea40ec706aa804791156e46b (diff)
downloadports-17313780a72b0b89b5410bdce6119458e924254c.tar.gz
ports-17313780a72b0b89b5410bdce6119458e924254c.zip
Notes
Diffstat (limited to 'math/p5-Graph/Makefile')
-rw-r--r--math/p5-Graph/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/math/p5-Graph/Makefile b/math/p5-Graph/Makefile
index 384ec0caedb7..694f3309cd92 100644
--- a/math/p5-Graph/Makefile
+++ b/math/p5-Graph/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= Graph
-PORTVERSION= 0.20105
+PORTVERSION= 0.54
+PORTEPOCH= 1
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Graph
@@ -15,18 +16,23 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Graph, the Perl module for graph operations
-BUILD_DEPENDS= ${SITE_PERL}/Heap.pm:${PORTSDIR}/devel/p5-Heap
+BUILD_DEPENDS= ${SITE_PERL}/Heap.pm:${PORTSDIR}/devel/p5-Heap \
+ ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Graph.3 \
- Graph::BFS.3 \
- Graph::Base.3 \
- Graph::DFS.3 \
- Graph::Directed.3 \
- Graph::HeapElem.3 \
+ Graph::AdjacencyMap.3 \
+ Graph::AdjacencyMap::Vertex.3 \
+ Graph::AdjacencyMatrix.3 \
+ Graph::BitMatrix.3 \
+ Graph::Matrix.3 \
+ Graph::TransitiveClosure.3 \
+ Graph::TransitiveClosure::Matrix.3 \
Graph::Traversal.3 \
- Graph::Undirected.3
+ Graph::Traversal::BFS.3 \
+ Graph::Traversal::DFS.3 \
+ Graph::UnionFind.3
.include <bsd.port.mk>