aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Graph
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-01-19 15:43:23 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-01-19 15:43:23 +0000
commit17313780a72b0b89b5410bdce6119458e924254c (patch)
treee21e6103894f29378705323a2df3eb2bec8144ef /math/p5-Graph
parent0bed2294bfa81c91ea40ec706aa804791156e46b (diff)
downloadports-17313780a72b0b89b5410bdce6119458e924254c.tar.gz
ports-17313780a72b0b89b5410bdce6119458e924254c.zip
Notes
Diffstat (limited to 'math/p5-Graph')
-rw-r--r--math/p5-Graph/Makefile22
-rw-r--r--math/p5-Graph/distinfo4
-rw-r--r--math/p5-Graph/pkg-plist23
3 files changed, 35 insertions, 14 deletions
diff --git a/math/p5-Graph/Makefile b/math/p5-Graph/Makefile
index 384ec0caedb7..694f3309cd92 100644
--- a/math/p5-Graph/Makefile
+++ b/math/p5-Graph/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= Graph
-PORTVERSION= 0.20105
+PORTVERSION= 0.54
+PORTEPOCH= 1
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Graph
@@ -15,18 +16,23 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Graph, the Perl module for graph operations
-BUILD_DEPENDS= ${SITE_PERL}/Heap.pm:${PORTSDIR}/devel/p5-Heap
+BUILD_DEPENDS= ${SITE_PERL}/Heap.pm:${PORTSDIR}/devel/p5-Heap \
+ ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Graph.3 \
- Graph::BFS.3 \
- Graph::Base.3 \
- Graph::DFS.3 \
- Graph::Directed.3 \
- Graph::HeapElem.3 \
+ Graph::AdjacencyMap.3 \
+ Graph::AdjacencyMap::Vertex.3 \
+ Graph::AdjacencyMatrix.3 \
+ Graph::BitMatrix.3 \
+ Graph::Matrix.3 \
+ Graph::TransitiveClosure.3 \
+ Graph::TransitiveClosure::Matrix.3 \
Graph::Traversal.3 \
- Graph::Undirected.3
+ Graph::Traversal::BFS.3 \
+ Graph::Traversal::DFS.3 \
+ Graph::UnionFind.3
.include <bsd.port.mk>
diff --git a/math/p5-Graph/distinfo b/math/p5-Graph/distinfo
index 75b1f093cedf..2dcef51d507a 100644
--- a/math/p5-Graph/distinfo
+++ b/math/p5-Graph/distinfo
@@ -1,2 +1,2 @@
-MD5 (Graph-0.20105.tar.gz) = 686176a59a36a5480a65b4fb36c967a7
-SIZE (Graph-0.20105.tar.gz) = 20877
+MD5 (Graph-0.54.tar.gz) = cf623c7c9004c9cef9030f6ea645f73f
+SIZE (Graph-0.54.tar.gz) = 87310
diff --git a/math/p5-Graph/pkg-plist b/math/p5-Graph/pkg-plist
index 40423eeb884e..ff7e4ea2040a 100644
--- a/math/p5-Graph/pkg-plist
+++ b/math/p5-Graph/pkg-plist
@@ -1,11 +1,26 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graph/.packlist
%%SITE_PERL%%/Graph.pm
+%%SITE_PERL%%/Graph.pod
+%%SITE_PERL%%/Graph/AdjacencyMap.pm
+%%SITE_PERL%%/Graph/AdjacencyMap/Heavy.pm
+%%SITE_PERL%%/Graph/AdjacencyMap/Light.pm
+%%SITE_PERL%%/Graph/AdjacencyMap/Vertex.pm
+%%SITE_PERL%%/Graph/AdjacencyMatrix.pm
+%%SITE_PERL%%/Graph/Attribute.pm
+%%SITE_PERL%%/Graph/BitMatrix.pm
%%SITE_PERL%%/Graph/Directed.pm
-%%SITE_PERL%%/Graph/HeapElem.pm
-%%SITE_PERL%%/Graph/DFS.pm
-%%SITE_PERL%%/Graph/Base.pm
+%%SITE_PERL%%/Graph/MSTHeapElem.pm
+%%SITE_PERL%%/Graph/Matrix.pm
+%%SITE_PERL%%/Graph/SPTHeapElem.pm
+%%SITE_PERL%%/Graph/TransitiveClosure.pm
+%%SITE_PERL%%/Graph/TransitiveClosure/Matrix.pm
%%SITE_PERL%%/Graph/Traversal.pm
-%%SITE_PERL%%/Graph/BFS.pm
+%%SITE_PERL%%/Graph/Traversal/BFS.pm
+%%SITE_PERL%%/Graph/Traversal/DFS.pm
%%SITE_PERL%%/Graph/Undirected.pm
+%%SITE_PERL%%/Graph/UnionFind.pm
+@dirrm %%SITE_PERL%%/Graph/AdjacencyMap
+@dirrm %%SITE_PERL%%/Graph/TransitiveClosure
+@dirrm %%SITE_PERL%%/Graph/Traversal
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graph 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Graph 2>/dev/null || true