aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Bezier-Convert
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-02-07 16:50:23 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-02-07 16:50:23 +0000
commite90a76ff565ef4d87e7e0d24183cbcd301a8b073 (patch)
treecdd214bdbf7ea7f9ee4272b997da457d41259a70 /math/p5-Math-Bezier-Convert
parent51fdd4cbc974b0c2ccb49eab77894e0514d77e80 (diff)
downloadports-e90a76ff565ef4d87e7e0d24183cbcd301a8b073.tar.gz
ports-e90a76ff565ef4d87e7e0d24183cbcd301a8b073.zip
Notes
Diffstat (limited to 'math/p5-Math-Bezier-Convert')
-rw-r--r--math/p5-Math-Bezier-Convert/Makefile34
-rw-r--r--math/p5-Math-Bezier-Convert/distinfo2
-rw-r--r--math/p5-Math-Bezier-Convert/pkg-descr5
-rw-r--r--math/p5-Math-Bezier-Convert/pkg-plist7
4 files changed, 48 insertions, 0 deletions
diff --git a/math/p5-Math-Bezier-Convert/Makefile b/math/p5-Math-Bezier-Convert/Makefile
new file mode 100644
index 000000000000..255b76907a2a
--- /dev/null
+++ b/math/p5-Math-Bezier-Convert/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Math-Bezier-Convert
+# Date created: 07 February 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Bezier-Convert
+PORTVERSION= 0.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/Y/YS/YSAS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Convert cubic and quadratic bezier each other
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::Bezier::Convert.3
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//'
+
+post-configure:
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Bezier-Convert/distinfo b/math/p5-Math-Bezier-Convert/distinfo
new file mode 100644
index 000000000000..46bbbbce3e8c
--- /dev/null
+++ b/math/p5-Math-Bezier-Convert/distinfo
@@ -0,0 +1,2 @@
+MD5 (Math-Bezier-Convert-0.02.tar.gz) = fb5237be267b594ae9849fcdd389ed11
+SIZE (Math-Bezier-Convert-0.02.tar.gz) = 6483
diff --git a/math/p5-Math-Bezier-Convert/pkg-descr b/math/p5-Math-Bezier-Convert/pkg-descr
new file mode 100644
index 000000000000..c91d3aa219c2
--- /dev/null
+++ b/math/p5-Math-Bezier-Convert/pkg-descr
@@ -0,0 +1,5 @@
+Math::Bezier::Convert provides functions to convert quadratic bezier to
+cubic, to approximate cubic bezier to quadratic, and to approximate
+cubic and quadratic bezier to polyline.
+
+WWW: http://search.cpan.org/dist/Math-Bezier-Convert/
diff --git a/math/p5-Math-Bezier-Convert/pkg-plist b/math/p5-Math-Bezier-Convert/pkg-plist
new file mode 100644
index 000000000000..f15ff1adb99d
--- /dev/null
+++ b/math/p5-Math-Bezier-Convert/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Math/Bezier/Convert.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Bezier/Convert/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/Math/Bezier 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Math 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Bezier/Convert
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Bezier 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true