aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Logic
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-09-20 18:47:37 +0000
committerWill Andrews <will@FreeBSD.org>2000-09-20 18:47:37 +0000
commit3d08e51a03f45a80fb07ecafbf4bc13fbffeeb63 (patch)
tree52166131d4734ea800470adc96b34a852e18c25f /math/p5-Math-Logic
parentc1e19dddb5067ffb21a7e7ebc598e425498734e7 (diff)
downloadports-3d08e51a03f45a80fb07ecafbf4bc13fbffeeb63.tar.gz
ports-3d08e51a03f45a80fb07ecafbf4bc13fbffeeb63.zip
Add p5-Math-Logic 1.19, a perl module providing pure 2, 3 or multi-value
logic. PR: 21420 Submitted by: Mario Sergio Fujikawa Ferriera <lioux@uol.com.br>
Notes
Notes: svn path=/head/; revision=32904
Diffstat (limited to 'math/p5-Math-Logic')
-rw-r--r--math/p5-Math-Logic/Makefile22
-rw-r--r--math/p5-Math-Logic/distinfo1
-rw-r--r--math/p5-Math-Logic/pkg-comment1
-rw-r--r--math/p5-Math-Logic/pkg-descr10
-rw-r--r--math/p5-Math-Logic/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/math/p5-Math-Logic/Makefile b/math/p5-Math-Logic/Makefile
new file mode 100644
index 000000000000..2320835918e7
--- /dev/null
+++ b/math/p5-Math-Logic/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Math-Logic
+# Date created: 20 Sep 2000
+# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Logic
+PORTVERSION= 1.19
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lioux@linf.unb.br
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Math::Logic.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Logic/distinfo b/math/p5-Math-Logic/distinfo
new file mode 100644
index 000000000000..ffcc20de53e5
--- /dev/null
+++ b/math/p5-Math-Logic/distinfo
@@ -0,0 +1 @@
+MD5 (Math-Logic-1.19.tar.gz) = 01352cf5bf8f4be78779ac57c033b7b5
diff --git a/math/p5-Math-Logic/pkg-comment b/math/p5-Math-Logic/pkg-comment
new file mode 100644
index 000000000000..e4f630aeedc7
--- /dev/null
+++ b/math/p5-Math-Logic/pkg-comment
@@ -0,0 +1 @@
+Perl module providing pure 2, 3 or multi-value logic
diff --git a/math/p5-Math-Logic/pkg-descr b/math/p5-Math-Logic/pkg-descr
new file mode 100644
index 000000000000..c97c337c80f0
--- /dev/null
+++ b/math/p5-Math-Logic/pkg-descr
@@ -0,0 +1,10 @@
+Perl's built-in logical operators, C<and>, C<or>, C<xor> and C<not>
+support 2-value logic. This means that they always produce a result
+which is either true or false. In fact perl sometimes returns 0
+and sometimes returns undef for false depending on the operator
+and the order of the arguments. For "true" Perl generally returns
+the first value that evaluated to true which turns out to be
+extremely useful in practice. Given the choice Perl's built-in
+logical operators are to be preferred -- but when you really want
+pure 2-degree logic or 3-degree logic or multi-degree logic they
+are available through this module
diff --git a/math/p5-Math-Logic/pkg-plist b/math/p5-Math-Logic/pkg-plist
new file mode 100644
index 000000000000..a1e8c9fb0950
--- /dev/null
+++ b/math/p5-Math-Logic/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Logic/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Math/Logic.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Math
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Logic
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math