aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Pari
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2006-11-10 16:32:07 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2006-11-10 16:32:07 +0000
commitcd65b94e0ede3b16edf4c370372551b511c5c222 (patch)
treefbe21dec6d252daf25153e899938903569a10087 /math/p5-Math-Pari
parent8b0eaf55e60a061bad8744a8d833909b00ecc5ea (diff)
downloadports-cd65b94e0ede3b16edf4c370372551b511c5c222.tar.gz
ports-cd65b94e0ede3b16edf4c370372551b511c5c222.zip
Notes
Diffstat (limited to 'math/p5-Math-Pari')
-rw-r--r--math/p5-Math-Pari/Makefile27
-rw-r--r--math/p5-Math-Pari/distinfo6
-rw-r--r--math/p5-Math-Pari/files/patch-Makefile.PL22
-rw-r--r--math/p5-Math-Pari/files/patch-makefile17
-rw-r--r--math/p5-Math-Pari/pkg-plist1
5 files changed, 35 insertions, 38 deletions
diff --git a/math/p5-Math-Pari/Makefile b/math/p5-Math-Pari/Makefile
index 88c2b67d6790..f76c5ee0caf2 100644
--- a/math/p5-Math-Pari/Makefile
+++ b/math/p5-Math-Pari/Makefile
@@ -6,37 +6,30 @@
#
PORTNAME= Math-Pari
-PORTVERSION= 2.010500
+PORTVERSION= 2.010709
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Math
PKGNAMEPREFIX= p5-
-MAINTAINER= mharo@FreeBSD.org
+MAINTAINER= skv@FreeBSD.org
COMMENT= PARI - numerical/scientific/number-theoretic calculations
-BROKEN= fails to install
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-12-01
-
BUILD_DEPENDS= pari:${PORTSDIR}/math/pari:configure
+LIB_DEPENDS= pari:${PORTSDIR}/math/pari
-USE_GMAKE= yes
USE_GCC= 3.2+
PERL_CONFIGURE= yes
-MAN3= Math::Pari.3 Math::libPARI.3 \
- Math::PariInit.3 Math::libPARI.dumb.3
-
-.include <bsd.port.pre.mk>
+CONFIGURE_ARGS= parilib="-L${LOCALBASE}/lib -lpari" \
+ paridir=`${MAKE} -C ${PORTSDIR}/math/pari -V WRKSRC`
-PARI_PORT?= math/pari
-PARI_PORTDIR?= ${PORTSDIR}/${PARI_PORT}
-PARI_WRKSRC!= cd ${PARI_PORTDIR} && ${MAKE} -V WRKSRC
+MAN3= Math::Pari.3 Math::libPARI.3 Math::PariInit.3
-CONFIGURE_ARGS= paridir=${PARI_WRKSRC}
+post-patch:
+ ${REINPLACE_CMD} -e 's/2001004/2003000/' ${WRKSRC}/Makefile.PL
post-clean:
- @cd ${PARI_PORTDIR} && ${MAKE} -DBATCH clean
+ ${MAKE} -C ${PORTSDIR}/math/pari -DBATCH clean
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Pari/distinfo b/math/p5-Math-Pari/distinfo
index 97902ee8abfd..8e4652e183f5 100644
--- a/math/p5-Math-Pari/distinfo
+++ b/math/p5-Math-Pari/distinfo
@@ -1,3 +1,3 @@
-MD5 (Math-Pari-2.010500.tar.gz) = 6ae5d0b044984a4fdc7817e79922419e
-SHA256 (Math-Pari-2.010500.tar.gz) = eea5b9918b4861274d48457b360310737755415f3200e080511ff19a57598676
-SIZE (Math-Pari-2.010500.tar.gz) = 91295
+MD5 (Math-Pari-2.010709.tar.gz) = 58fdea358b37d00072723bd9cd69ce9e
+SHA256 (Math-Pari-2.010709.tar.gz) = f64c4d7540b1f67ae3c3b69e0dbb0aaa898c70e1f5519106acf8d63243dbcb9b
+SIZE (Math-Pari-2.010709.tar.gz) = 113280
diff --git a/math/p5-Math-Pari/files/patch-Makefile.PL b/math/p5-Math-Pari/files/patch-Makefile.PL
new file mode 100644
index 000000000000..ab829f0b95cd
--- /dev/null
+++ b/math/p5-Math-Pari/files/patch-Makefile.PL
@@ -0,0 +1,22 @@
+--- Makefile.PL.orig Wed May 31 12:39:28 2006
++++ Makefile.PL Fri Sep 15 13:45:27 2006
+@@ -91,9 +91,9 @@
+ }
+
+ my %opts;
++ make_pod 'libPARI.pod', '-to_pod', $paridir; # Now the docs
+ unless ($common::parilib) {
+ build_tests $paridir; # Convert the test suite
+- make_pod 'libPARI.pod', '-to_pod', $paridir; # Now the docs
+ make_pod 'libPARI.dumb.pod', '-to_dumb_pod', $paridir;
+ %opts = build_paricfg($paridir, $common::do_configure); # ... and paricfg.h
+
+@@ -139,7 +139,7 @@
+ # the contents of the Makefile being created.
+ &WriteMakefile(
+ LIBS => $libs,
+- INC => $extra_inc . ' -I$(PARI_DIR)/src/headers -I$(PARI_DIR)/src -I./libPARI',
++ INC => '-I$(PREFIX)/include/pari -I$(PARI_DIR)/src',
+ NAME => 'Math::Pari',
+ ($common::parilib ? () :
+ (MYEXTLIB => 'libPARI/libPARI$(LIB_EXT)')),
diff --git a/math/p5-Math-Pari/files/patch-makefile b/math/p5-Math-Pari/files/patch-makefile
deleted file mode 100644
index d850c3f29b8e..000000000000
--- a/math/p5-Math-Pari/files/patch-makefile
+++ /dev/null
@@ -1,17 +0,0 @@
---- libPARI/Makefile.PL.orig Thu Apr 24 05:23:32 2003
-+++ libPARI/Makefile.PL Thu Aug 21 14:51:06 2003
-@@ -137,11 +137,13 @@
- $mycflags .= " -DASMINLINE";
- }
--$mycflags .= ' -DGCC_INLINE' if $Config{gccversion};
-+$mycflags .= ' -O -DGCC_INLINE' if $Config{gccversion};
-+$mycflags .= " $ENV{CFLAGS} " if $ENV{CFLAGS};
-
- @obj_files = map { "$_\$(OBJ_EXT)" } keys(%cfiles), qw(kernel mp mpinl);
- push @obj_files, 'kernel2$(OBJ_EXT)' if $kernel{converted2};
-
- $mycflags .= " -DDYNAMIC_PLOTTING";
-+$mycflags .= " -DDL_DFLT_NAME=\\\"libpari.2.1.3\\\"";
- # OMF build needs no underscores:
- $mycflags .= " -D__NO_AOUT" if $^O eq 'os2' and !$OS2::is_aout;
-
diff --git a/math/p5-Math-Pari/pkg-plist b/math/p5-Math-Pari/pkg-plist
index a906d62edc59..21b045c31920 100644
--- a/math/p5-Math-Pari/pkg-plist
+++ b/math/p5-Math-Pari/pkg-plist
@@ -1,6 +1,5 @@
%%SITE_PERL%%/%%PERL_ARCH%%/Math/Pari.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Math/PariInit.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Math/libPARI.dumb.pod
%%SITE_PERL%%/%%PERL_ARCH%%/Math/libPARI.pod
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Pari/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Pari/Pari.bs