aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Pari
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-08-21 13:16:11 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-08-21 13:16:11 +0000
commit7863e0920beda435801fecd483b342a9cd8d0d9e (patch)
treef497c4294f18d6813c388cd1fa54539a0ea70356 /math/p5-Math-Pari
parent78dc0ca84e665cbb930a67eeb5306a901351772f (diff)
downloadports-7863e0920beda435801fecd483b342a9cd8d0d9e.tar.gz
ports-7863e0920beda435801fecd483b342a9cd8d0d9e.zip
Notes
Diffstat (limited to 'math/p5-Math-Pari')
-rw-r--r--math/p5-Math-Pari/Makefile19
-rw-r--r--math/p5-Math-Pari/distinfo2
-rw-r--r--math/p5-Math-Pari/files/patch-makefile23
-rw-r--r--math/p5-Math-Pari/pkg-descr2
-rw-r--r--math/p5-Math-Pari/pkg-plist20
5 files changed, 37 insertions, 29 deletions
diff --git a/math/p5-Math-Pari/Makefile b/math/p5-Math-Pari/Makefile
index 4992e7bd53da..8ac89716ebb3 100644
--- a/math/p5-Math-Pari/Makefile
+++ b/math/p5-Math-Pari/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Math-Pari
-PORTVERSION= 2.010201
+PORTVERSION= 2.010500
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Math
@@ -19,7 +19,18 @@ BUILD_DEPENDS= pari:${PORTSDIR}/math/pari:configure
PERL_CONFIGURE= yes
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-MAN3= Math::Pari.3 Math::libPARI.3
+MAN3= Math::Pari.3 Math::libPARI.3 \
+ Math::PariInit.3 Math::libPARI.dumb.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+PARI_PORT?= math/pari
+PARI_PORTDIR?= ${PORTSDIR}/${PARI_PORT}
+PARI_WRKSRC!= cd ${PARI_PORTDIR} && ${MAKE} -V WRKSRC
+
+CONFIGURE_ARGS= paridir=${PARI_WRKSRC}
+
+post-clean:
+ @cd ${PARI_PORTDIR} && ${MAKE} -DBATCH clean
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Pari/distinfo b/math/p5-Math-Pari/distinfo
index 033e4ff6f617..5a08be8de29d 100644
--- a/math/p5-Math-Pari/distinfo
+++ b/math/p5-Math-Pari/distinfo
@@ -1 +1 @@
-MD5 (Math-Pari-2.010201.tar.gz) = 0776e5b046ad8fcd20f94f67a0d2436e
+MD5 (Math-Pari-2.010500.tar.gz) = 6ae5d0b044984a4fdc7817e79922419e
diff --git a/math/p5-Math-Pari/files/patch-makefile b/math/p5-Math-Pari/files/patch-makefile
index a8a60fb4d0fd..9a33e8398aa6 100644
--- a/math/p5-Math-Pari/files/patch-makefile
+++ b/math/p5-Math-Pari/files/patch-makefile
@@ -1,18 +1,13 @@
---- Makefile.PL.orig Tue Sep 11 02:52:45 2001
-+++ Makefile.PL Tue Sep 11 02:53:18 2001
-@@ -4,7 +4,7 @@
- use File::Copy 'copy';
+--- libPARI/Makefile.PL.orig Thu Apr 24 05:23:32 2003
++++ libPARI/Makefile.PL Thu Aug 21 14:51:06 2003
+@@ -137,11 +137,13 @@
+ $mycflags .= " -DASMINLINE";
+ }
+ $mycflags .= ' -DGCC_INLINE' if $Config{gccversion};
++$mycflags .= " $ENV{CFLAGS} " if $ENV{CFLAGS};
- # Uncomment and change this line if I fail to find it
--# $paridir = "..";
-+$paridir = "../../../pari/work/pari-2.1.3";
-
- unless (-t STDOUT) { # Better reports if run with redirections
- my $odef = select STDERR;
---- libPARI/Makefile.PL.orig Thu Mar 14 15:04:06 2002
-+++ libPARI/Makefile.PL Thu Mar 14 15:03:30 2002
-@@ -381,6 +381,7 @@
- #}
+ @obj_files = map { "$_\$(OBJ_EXT)" } keys(%cfiles), qw(kernel mp mpinl);
+ push @obj_files, 'kernel2$(OBJ_EXT)' if $kernel{converted2};
$mycflags .= " -DDYNAMIC_PLOTTING";
+$mycflags .= " -DDL_DFLT_NAME=\\\"libpari.2.1.3\\\"";
diff --git a/math/p5-Math-Pari/pkg-descr b/math/p5-Math-Pari/pkg-descr
index ad572553c596..e630948f955b 100644
--- a/math/p5-Math-Pari/pkg-descr
+++ b/math/p5-Math-Pari/pkg-descr
@@ -3,4 +3,6 @@ numerical/scientific/number-theoretic calculations. It allows use of most
PARI functions as Perl functions, and (almost) seamless merging of PARI
and Perl data.
+WWW: http://search.cpan.org/dist/Math-Pari/
+
-- Michael
diff --git a/math/p5-Math-Pari/pkg-plist b/math/p5-Math-Pari/pkg-plist
index 75b56d54fb94..c9c59034f330 100644
--- a/math/p5-Math-Pari/pkg-plist
+++ b/math/p5-Math-Pari/pkg-plist
@@ -1,10 +1,10 @@
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math/Pari.pm
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math/comp_funcs.pl
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math/foncpari.pl
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math/libPARI.pod
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Pari/.packlist
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Pari/Pari.bs
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Pari/Pari.so
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Pari
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Pari.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/PariInit.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/libPARI.dumb.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/libPARI.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Pari/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Pari/Pari.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Pari/Pari.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Pari
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Math 2>/dev/null || true