aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-RPN
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2010-06-01 05:50:11 +0000
committerKevin Lo <kevlo@FreeBSD.org>2010-06-01 05:50:11 +0000
commit1c6777665bc6772cfbb6e0e346dde85ddce6a407 (patch)
tree4cf4fd793f63948c7864a47e3be8466a509c1135 /math/p5-Math-RPN
parentae26aba9404f2588180d021ae7e52cfb85455fc0 (diff)
Notes
Diffstat (limited to 'math/p5-Math-RPN')
-rw-r--r--math/p5-Math-RPN/Makefile26
-rw-r--r--math/p5-Math-RPN/distinfo3
-rw-r--r--math/p5-Math-RPN/pkg-descr5
-rw-r--r--math/p5-Math-RPN/pkg-plist2
4 files changed, 36 insertions, 0 deletions
diff --git a/math/p5-Math-RPN/Makefile b/math/p5-Math-RPN/Makefile
new file mode 100644
index 000000000000..9b03bfb56fd5
--- /dev/null
+++ b/math/p5-Math-RPN/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Math-RPN
+# Date created: 1 June 2010
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-RPN
+PORTVERSION= 1.09
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= Reverse polish math expression evaluation
+
+RUN_DEPENDS= ${SITE_PERL}/Test/Warn.pm:${PORTSDIR}/devel/p5-Test-Warn \
+ ${SITE_PERL}/ExtUtils/MakeMaker.pm::${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::RPN.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-RPN/distinfo b/math/p5-Math-RPN/distinfo
new file mode 100644
index 000000000000..8ea9d2b75f87
--- /dev/null
+++ b/math/p5-Math-RPN/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-RPN-1.09.tar.gz) = 616f61e929f085f02778d32e77bc5db6
+SHA256 (Math-RPN-1.09.tar.gz) = 476e7c6829bc59537d7b55746069212f016c81f766fa89aa1453d5398b1e5c86
+SIZE (Math-RPN-1.09.tar.gz) = 20705
diff --git a/math/p5-Math-RPN/pkg-descr b/math/p5-Math-RPN/pkg-descr
new file mode 100644
index 000000000000..41b2a4335c5c
--- /dev/null
+++ b/math/p5-Math-RPN/pkg-descr
@@ -0,0 +1,5 @@
+The rpn function will take a scalar or list of sclars which
+contain an RPN expression as a set of comma delimited values and
+operators, and return the result or stack, depending on context.
+
+WWW: http://search.cpan.org/dist/Math-RPN/
diff --git a/math/p5-Math-RPN/pkg-plist b/math/p5-Math-RPN/pkg-plist
new file mode 100644
index 000000000000..85a24f1f2522
--- /dev/null
+++ b/math/p5-Math-RPN/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Math/RPN.pm
+@dirrmtry %%SITE_PERL%%/Math