aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Random-ISAAC
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-12-07 14:19:26 +0000
committerWen Heping <wen@FreeBSD.org>2009-12-07 14:19:26 +0000
commitfb32debab6e22238fc3bf4c1847748ecfb838404 (patch)
tree83d1aa4cec2a4388e518ca86e31cba2a579034c7 /math/p5-Math-Random-ISAAC
parentbbceeb5efd53f13376f6c806c62b9c420cac5cca (diff)
downloadports-fb32debab6e22238fc3bf4c1847748ecfb838404.tar.gz
ports-fb32debab6e22238fc3bf4c1847748ecfb838404.zip
Notes
Diffstat (limited to 'math/p5-Math-Random-ISAAC')
-rw-r--r--math/p5-Math-Random-ISAAC/Makefile25
-rw-r--r--math/p5-Math-Random-ISAAC/distinfo3
-rw-r--r--math/p5-Math-Random-ISAAC/pkg-descr12
-rw-r--r--math/p5-Math-Random-ISAAC/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/math/p5-Math-Random-ISAAC/Makefile b/math/p5-Math-Random-ISAAC/Makefile
new file mode 100644
index 000000000000..9591212f1fb7
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: Math::Random::ISAAC
+# Date created: 07 Dec, 2009
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Random-ISAAC
+PORTVERSION= 1.002
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Perl interface to the ISAAC PRNG Algorithm
+
+BUILD_DEPENDS= p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Math::Random::ISAAC::PP.3 \
+ Math::Random::ISAAC.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Random-ISAAC/distinfo b/math/p5-Math-Random-ISAAC/distinfo
new file mode 100644
index 000000000000..a104af307cbc
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Random-ISAAC-1.002.tar.gz) = 92bbf5de885b72626160a5b9461bf4d6
+SHA256 (Math-Random-ISAAC-1.002.tar.gz) = cdf6428f4a226b55d3f9efffa8ad39f78286cb8e7bf2aeff09f266a2efa9a239
+SIZE (Math-Random-ISAAC-1.002.tar.gz) = 43022
diff --git a/math/p5-Math-Random-ISAAC/pkg-descr b/math/p5-Math-Random-ISAAC/pkg-descr
new file mode 100644
index 000000000000..88b97ac404a5
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC/pkg-descr
@@ -0,0 +1,12 @@
+As with other Pseudo-Random Number Generator (PRNG) algorithms like the
+Mersenne Twister (see Math::Random::MT), this algorithm is designed to
+take some seed information and produce seemingly random results as output.
+
+However, ISAAC (Indirection, Shift, Accumulate, Add, and Count) has
+different goals than these commonly used algorithms. In particular, it's
+really fast - on average, it requires only 18.75 machine cycles to generate
+a 32-bit value. This makes it suitable for applications where a significant
+amount of random data needs to be produced quickly, such solving using the
+Monte Carlo method or for games.
+
+WWW: http://search.cpan.org/dist/Math-Random-ISAAC/
diff --git a/math/p5-Math-Random-ISAAC/pkg-plist b/math/p5-Math-Random-ISAAC/pkg-plist
new file mode 100644
index 000000000000..5ce47d0bd3c7
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Math/Random/ISAAC/PP.pm
+%%SITE_PERL%%/Math/Random/ISAAC.pm
+@dirrmtry %%SITE_PERL%%/Math/Random/ISAAC
+@dirrmtry %%SITE_PERL%%/Math/Random
+@dirrmtry %%SITE_PERL%%/Math