aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Random-MT-Auto/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-01-13 09:06:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-01-13 09:06:18 +0000
commit76e86dada6b43d16232a3cc50ee84852d5f24ee0 (patch)
tree9d33a5a3a133c71f934ac262cc51bfdb158c183d /math/p5-Math-Random-MT-Auto/Makefile
parent58400574b550ea4660feff04a575e201186ff128 (diff)
Notes
Diffstat (limited to 'math/p5-Math-Random-MT-Auto/Makefile')
-rw-r--r--math/p5-Math-Random-MT-Auto/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/math/p5-Math-Random-MT-Auto/Makefile b/math/p5-Math-Random-MT-Auto/Makefile
index 6ea7ecdb2daf..9109c80e5f5d 100644
--- a/math/p5-Math-Random-MT-Auto/Makefile
+++ b/math/p5-Math-Random-MT-Auto/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Math-Random-MT-Auto
-PORTVERSION= 6.16
+PORTVERSION= 6.17
CATEGORIES= math perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:JDHEDDEN
@@ -15,12 +15,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Auto-seeded Mersenne Twister PRNGs
-BUILD_DEPENDS= p5-Object-InsideOut>=2.06:${PORTSDIR}/devel/p5-Object-InsideOut \
- p5-Exception-Class>=1.22:${PORTSDIR}/devel/p5-Exception-Class
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= p5-Exception-Class>=1.32:${PORTSDIR}/devel/p5-Exception-Class \
+ p5-Object-InsideOut>=3.85:${PORTSDIR}/devel/p5-Object-InsideOut
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
PERL_CONFIGURE= yes
MAN3= Math::Random::MT::Auto.3 Math::Random::MT::Auto::Range.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.23:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.23:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>