aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Round-Var
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-21 21:44:06 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-21 21:44:06 +0000
commit1db5d16f428980009cedc752c541ec403f21a10e (patch)
tree5ab56a52002cecc5bcecb8f5f71eb2741e52d00d /math/p5-Math-Round-Var
parent2ced4ae60e0e24e758dd3b41575fbc52ed8b7b7a (diff)
downloadports-1db5d16f428980009cedc752c541ec403f21a10e.tar.gz
ports-1db5d16f428980009cedc752c541ec403f21a10e.zip
Notes
Diffstat (limited to 'math/p5-Math-Round-Var')
-rw-r--r--math/p5-Math-Round-Var/Makefile28
-rw-r--r--math/p5-Math-Round-Var/distinfo3
-rw-r--r--math/p5-Math-Round-Var/pkg-descr10
-rw-r--r--math/p5-Math-Round-Var/pkg-plist3
4 files changed, 44 insertions, 0 deletions
diff --git a/math/p5-Math-Round-Var/Makefile b/math/p5-Math-Round-Var/Makefile
new file mode 100644
index 000000000000..cd883fa68c34
--- /dev/null
+++ b/math/p5-Math-Round-Var/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Math-Round-Var
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Round-Var
+PORTVERSION= 0.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Variations on rounding
+
+MAN3= Math::Round::Var.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Round-Var/distinfo b/math/p5-Math-Round-Var/distinfo
new file mode 100644
index 000000000000..64f78320e87f
--- /dev/null
+++ b/math/p5-Math-Round-Var/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Round-Var-0.02.tar.gz) = ec57279fb4f08b3c9282854053e5d03c
+SHA256 (Math-Round-Var-0.02.tar.gz) = ee430dddf678bbfcad7174656b8012c51853d9d19f9e11b4453762534f7ca162
+SIZE (Math-Round-Var-0.02.tar.gz) = 4260
diff --git a/math/p5-Math-Round-Var/pkg-descr b/math/p5-Math-Round-Var/pkg-descr
new file mode 100644
index 000000000000..05b5acc4eaa4
--- /dev/null
+++ b/math/p5-Math-Round-Var/pkg-descr
@@ -0,0 +1,10 @@
+This module gives you the ability to round numbers to either decimal or
+fractional precision while encapsulating the rounding precision in an
+object. This allows scripts and modules to maintain multiple precision
+values as objects.
+
+It also implements flexible scheme parsing, so that your programs and
+modules can offload the how-to-round decisions to this module.
+
+WWW: http://search.cpan.org/dist/Math-Round-Var
+Author: Eric L. Wilhelm <ewilhelm at cpan dot org>
diff --git a/math/p5-Math-Round-Var/pkg-plist b/math/p5-Math-Round-Var/pkg-plist
new file mode 100644
index 000000000000..dc2021a8ba48
--- /dev/null
+++ b/math/p5-Math-Round-Var/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Math/Round/Var.pm
+@dirrm %%SITE_PERL%%/Math/Round
+@dirrmtry %%SITE_PERL%%/Math