aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Series
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 17:18:09 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 17:18:09 +0000
commitb7f5e4e877b270712f673e67bda13610e3f28460 (patch)
tree193b966810f2deabeabe232ac8c3bad9ae823941 /math/p5-Math-Series
parent30bd87f5ee5b5b28a11082d8c8850fdd45450da8 (diff)
downloadports-b7f5e4e877b270712f673e67bda13610e3f28460.tar.gz
ports-b7f5e4e877b270712f673e67bda13610e3f28460.zip
Notes
Diffstat (limited to 'math/p5-Math-Series')
-rw-r--r--math/p5-Math-Series/Makefile26
-rw-r--r--math/p5-Math-Series/distinfo3
-rw-r--r--math/p5-Math-Series/pkg-descr28
-rw-r--r--math/p5-Math-Series/pkg-plist5
4 files changed, 62 insertions, 0 deletions
diff --git a/math/p5-Math-Series/Makefile b/math/p5-Math-Series/Makefile
new file mode 100644
index 000000000000..8c2c95089a77
--- /dev/null
+++ b/math/p5-Math-Series/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Math-Series
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Series
+PORTVERSION= 1.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl extension dealing with mathematic series
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/Math/Sequence.pm:${PORTSDIR}/math/p5-Math-Sequence
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Series.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Series/distinfo b/math/p5-Math-Series/distinfo
new file mode 100644
index 000000000000..cf0dbb5f59dd
--- /dev/null
+++ b/math/p5-Math-Series/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Series-1.01.tar.gz) = 1ab394433e6614333e263e209677ae0a
+SHA256 (Math-Series-1.01.tar.gz) = 7313442021d459a5b387dae4effc258ee3db755a111f9fbbe9bb1aca1352570a
+SIZE (Math-Series-1.01.tar.gz) = 5762
diff --git a/math/p5-Math-Series/pkg-descr b/math/p5-Math-Series/pkg-descr
new file mode 100644
index 000000000000..9d9ecdfddbc0
--- /dev/null
+++ b/math/p5-Math-Series/pkg-descr
@@ -0,0 +1,28 @@
+Math::Series defines a class for simple mathematic series with a recursive
+definition such as x_(n+1) = 1 / (x_n + 1). Such a recursive definition is
+treated as a sequence whose elements will be added to form a series. You
+can refer to the previous sequence element as well as to the current index
+in the series. Creation of a Math::Series object is described below in the
+paragraph about the constructor.
+
+Math::Series uses Math::Symbolic to parse and modify the recursive
+sequence definitions. That means you specify the sequence as a string
+which is parsed by Math::Symbolic. Alternatively, you can pass the
+constructor a Math::Symbolic tree directly.
+
+Because Math::Series uses Math::Symbolic for its implementation, all
+results will be Math::Symbolic objects which may contain other variables
+than the sequence variable and the iterator variable.
+
+Each Math::Series object is an iterator to iterate over the elements of
+the series starting at the first element (which was specified by the
+starting element, the second argument to the new() constructor). It offers
+facilities to cache all calculated elements and access any element
+directly, though unless the element has been cached in a previous
+calculation, this is just a shortcut for repeated use of the iterator.
+
+Every element in the series may only access its predecessor, not the
+elements before that.
+
+WWW: http://search.cpan.org/dist/Math-Series
+Author: Steffen Mueller <series-module@steffen-mueller.net>
diff --git a/math/p5-Math-Series/pkg-plist b/math/p5-Math-Series/pkg-plist
new file mode 100644
index 000000000000..52e4e638273b
--- /dev/null
+++ b/math/p5-Math-Series/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Math/Series.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Series/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Series
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math