aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-String
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-04-08 18:28:25 +0000
committerSteve Wills <swills@FreeBSD.org>2012-04-08 18:28:25 +0000
commit03ebb16928b14c32ab00413c44b5491067534869 (patch)
tree5486ec9e8940204d042d83de5a4d8899650d92fc /math/p5-Math-String
parentf774100b1d4e135750ad2fa64540ca4040f391d1 (diff)
downloadports-03ebb16928b14c32ab00413c44b5491067534869.tar.gz
ports-03ebb16928b14c32ab00413c44b5491067534869.zip
Notes
Diffstat (limited to 'math/p5-Math-String')
-rw-r--r--math/p5-Math-String/Makefile28
-rw-r--r--math/p5-Math-String/distinfo2
-rw-r--r--math/p5-Math-String/pkg-descr4
-rw-r--r--math/p5-Math-String/pkg-plist9
4 files changed, 43 insertions, 0 deletions
diff --git a/math/p5-Math-String/Makefile b/math/p5-Math-String/Makefile
new file mode 100644
index 000000000000..3401fe91ae14
--- /dev/null
+++ b/math/p5-Math-String/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Math-String
+# Date created: 2012-04-08
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-String
+PORTVERSION= 1.28
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl module to calculate with strings as if they were big integers
+
+BUILD_DEPENDS= p5-Math-BigInt>=1.87:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::String.3 \
+ Math::String::Charset.3 \
+ Math::String::Charset::Grouped.3 \
+ Math::String::Charset::Nested.3 \
+ Math::String::Sequence.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-String/distinfo b/math/p5-Math-String/distinfo
new file mode 100644
index 000000000000..f8cbc6257212
--- /dev/null
+++ b/math/p5-Math-String/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Math-String-1.28.tar.gz) = 7c41d9a3478bfe5a675556c87375419047c09fd7f0cb6117ddd1240fc5f2e0a0
+SIZE (Math-String-1.28.tar.gz) = 72979
diff --git a/math/p5-Math-String/pkg-descr b/math/p5-Math-String/pkg-descr
new file mode 100644
index 000000000000..26a97eb0cfa6
--- /dev/null
+++ b/math/p5-Math-String/pkg-descr
@@ -0,0 +1,4 @@
+Perl module which lets you calculate with strings (specifically passwords, but
+not limited to) as if they were big integers.
+
+WWW: http://search.cpan.org/dist/Math-String/
diff --git a/math/p5-Math-String/pkg-plist b/math/p5-Math-String/pkg-plist
new file mode 100644
index 000000000000..bad4495f960d
--- /dev/null
+++ b/math/p5-Math-String/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Math/String/Charset/Nested.pm
+%%SITE_PERL%%/Math/String/Charset/Grouped.pm
+%%SITE_PERL%%/Math/String/Charset.pm
+%%SITE_PERL%%/Math/String/Sequence.pm
+%%SITE_PERL%%/Math/String.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/String/.packlist
+@dirrmtry %%SITE_PERL%%/Math/String/Charset
+@dirrmtry %%SITE_PERL%%/Math/String
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/String