aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Symbolic-Custom-Pattern/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:43:24 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:43:24 +0000
commit0c61840fb0ae723c2549707015af7ccf853adff1 (patch)
tree09ef02d687a0d43eef6d9470bdb795542a3ffe60 /math/p5-Math-Symbolic-Custom-Pattern/Makefile
parent60f280a3e3e416b41554b853813903880a524741 (diff)
downloadports-0c61840fb0ae723c2549707015af7ccf853adff1.tar.gz
ports-0c61840fb0ae723c2549707015af7ccf853adff1.zip
Notes
Diffstat (limited to 'math/p5-Math-Symbolic-Custom-Pattern/Makefile')
-rw-r--r--math/p5-Math-Symbolic-Custom-Pattern/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/math/p5-Math-Symbolic-Custom-Pattern/Makefile b/math/p5-Math-Symbolic-Custom-Pattern/Makefile
new file mode 100644
index 000000000000..c76d95caeb0c
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Pattern/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Math-Symbolic-Custom-Pattern
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Symbolic-Custom-Pattern
+PORTVERSION= 1.11
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Pattern matching on Math::Symbolic trees
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Symbolic::Custom::Pattern.3 \
+ Math::Symbolic::Custom::Pattern::Export.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>