aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Symbolic-Custom-Simplification
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:50:32 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:50:32 +0000
commit9e1392e110229e3de87897a5f92d0e7ace4e5064 (patch)
tree882774877ec290364d0b5f9af4498bae2757cd9c /math/p5-Math-Symbolic-Custom-Simplification
parent0c61840fb0ae723c2549707015af7ccf853adff1 (diff)
downloadports-9e1392e110229e3de87897a5f92d0e7ace4e5064.tar.gz
ports-9e1392e110229e3de87897a5f92d0e7ace4e5064.zip
Notes
Diffstat (limited to 'math/p5-Math-Symbolic-Custom-Simplification')
-rw-r--r--math/p5-Math-Symbolic-Custom-Simplification/Makefile31
-rw-r--r--math/p5-Math-Symbolic-Custom-Simplification/distinfo3
-rw-r--r--math/p5-Math-Symbolic-Custom-Simplification/pkg-descr20
-rw-r--r--math/p5-Math-Symbolic-Custom-Simplification/pkg-plist9
4 files changed, 63 insertions, 0 deletions
diff --git a/math/p5-Math-Symbolic-Custom-Simplification/Makefile b/math/p5-Math-Symbolic-Custom-Simplification/Makefile
new file mode 100644
index 000000000000..5b7bfdeb5b01
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Simplification/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Math-Symbolic-Custom-Simplification
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Symbolic-Custom-Simplification
+PORTVERSION= 1.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= User defined simplification routines
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Symbolic::Custom::Simplification.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Symbolic-Custom-Simplification/distinfo b/math/p5-Math-Symbolic-Custom-Simplification/distinfo
new file mode 100644
index 000000000000..daf8da44f302
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Simplification/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Symbolic-Custom-Simplification-1.01.tar.gz) = dd516df0b2c870773aedcfef80a03b8b
+SHA256 (Math-Symbolic-Custom-Simplification-1.01.tar.gz) = cd99ef0a03596f8b76fa10bbdb5bed53763a3cd2ae040b897001bc7688e856cf
+SIZE (Math-Symbolic-Custom-Simplification-1.01.tar.gz) = 3767
diff --git a/math/p5-Math-Symbolic-Custom-Simplification/pkg-descr b/math/p5-Math-Symbolic-Custom-Simplification/pkg-descr
new file mode 100644
index 000000000000..fad27c9adbf7
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Simplification/pkg-descr
@@ -0,0 +1,20 @@
+This module is an extension to the Math::Symbolic module. A basic
+familiarity with that module is required.
+
+Math::Symbolic offers some builtin simplification routines. These,
+however, are not capable of complex simplifications. This extension offers
+facilities to override the default simplification routines through means
+of subclassing this module. A subclass of this module is required to
+define a simplify object method that implements a simplification of
+Math::Symbolic trees.
+
+There are two class methods to inherit: register and unregister. Calling
+the register method on your subclass registers your class as providing the
+simplify method that is invoked whenever simplify() is called on a
+Math::Symbolic::Operator object.
+
+Calling unregister on your subclass restores whichever simplification
+routines where in place before.
+
+WWW: http://search.cpan.org/dist/Math-Symbolic-Custom-Simplification
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Math-Symbolic-Custom-Simplification/pkg-plist b/math/p5-Math-Symbolic-Custom-Simplification/pkg-plist
new file mode 100644
index 000000000000..fbb8312053f1
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Simplification/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Math/Symbolic/Custom/Simplification.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom/Simplification/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom/Simplification
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math/Symbolic/Custom
+@dirrmtry %%SITE_PERL%%/Math/Symbolic
+@dirrmtry %%SITE_PERL%%/Math