aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-SymbolicX-BigNum/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 14:54:28 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 14:54:28 +0000
commit8c0396f6bf6d7be65631e467265aed9157882d13 (patch)
treed4687363ee1e7ea8698aa4359100f209aa0cda35 /math/p5-Math-SymbolicX-BigNum/Makefile
parentea42e87bab0ad8cf32c20f267005fec1ec2ab5f7 (diff)
downloadports-8c0396f6bf6d7be65631e467265aed9157882d13.tar.gz
ports-8c0396f6bf6d7be65631e467265aed9157882d13.zip
Notes
Diffstat (limited to 'math/p5-Math-SymbolicX-BigNum/Makefile')
-rw-r--r--math/p5-Math-SymbolicX-BigNum/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/p5-Math-SymbolicX-BigNum/Makefile b/math/p5-Math-SymbolicX-BigNum/Makefile
new file mode 100644
index 000000000000..35e6c746427a
--- /dev/null
+++ b/math/p5-Math-SymbolicX-BigNum/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Math-SymbolicX-BigNum
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-SymbolicX-BigNum
+PORTVERSION= 0.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Big number support for the Math::Symbolic parser
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/Math/SymbolicX/ParserExtensionFactory.pm:${PORTSDIR}/math/p5-Math-SymbolicX-ParserExtensionFactory
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::SymbolicX::BigNum.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>