aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Number-WithError/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 16:15:33 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 16:15:33 +0000
commit46701e0d9d0eafa78bbd3c909acea1bba164a4e7 (patch)
tree266823bbbae83a2c637797d8c6dd1de0ef42bb43 /math/p5-Number-WithError/Makefile
parent49011927726ae8d485b6510d63ccd66e2b71e37e (diff)
downloadports-46701e0d9d0eafa78bbd3c909acea1bba164a4e7.tar.gz
ports-46701e0d9d0eafa78bbd3c909acea1bba164a4e7.zip
Notes
Diffstat (limited to 'math/p5-Number-WithError/Makefile')
-rw-r--r--math/p5-Number-WithError/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/math/p5-Number-WithError/Makefile b/math/p5-Number-WithError/Makefile
new file mode 100644
index 000000000000..75a602c4a2da
--- /dev/null
+++ b/math/p5-Number-WithError/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Number-WithError
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Number-WithError
+PORTVERSION= 0.03
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Number
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Numbers with error propagation and scientific rounding
+
+BUILD_DEPENDS= ${SITE_PERL}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
+ ${SITE_PERL}/prefork.pm:${PORTSDIR}/devel/p5-prefork \
+ ${SITE_PERL}/Math/SymbolicX/Inline.pm:${PORTSDIR}/math/p5-Math-SymbolicX-Inline
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Number::WithError.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>