aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Number-WithError
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 16:15:33 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 16:15:33 +0000
commit46701e0d9d0eafa78bbd3c909acea1bba164a4e7 (patch)
tree266823bbbae83a2c637797d8c6dd1de0ef42bb43 /math/p5-Number-WithError
parent49011927726ae8d485b6510d63ccd66e2b71e37e (diff)
downloadports-46701e0d9d0eafa78bbd3c909acea1bba164a4e7.tar.gz
ports-46701e0d9d0eafa78bbd3c909acea1bba164a4e7.zip
Notes
Diffstat (limited to 'math/p5-Number-WithError')
-rw-r--r--math/p5-Number-WithError/Makefile33
-rw-r--r--math/p5-Number-WithError/distinfo3
-rw-r--r--math/p5-Number-WithError/pkg-descr18
-rw-r--r--math/p5-Number-WithError/pkg-plist5
4 files changed, 59 insertions, 0 deletions
diff --git a/math/p5-Number-WithError/Makefile b/math/p5-Number-WithError/Makefile
new file mode 100644
index 000000000000..75a602c4a2da
--- /dev/null
+++ b/math/p5-Number-WithError/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Number-WithError
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Number-WithError
+PORTVERSION= 0.03
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Number
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Numbers with error propagation and scientific rounding
+
+BUILD_DEPENDS= ${SITE_PERL}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
+ ${SITE_PERL}/prefork.pm:${PORTSDIR}/devel/p5-prefork \
+ ${SITE_PERL}/Math/SymbolicX/Inline.pm:${PORTSDIR}/math/p5-Math-SymbolicX-Inline
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Number::WithError.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Number-WithError/distinfo b/math/p5-Number-WithError/distinfo
new file mode 100644
index 000000000000..a13a96f45e84
--- /dev/null
+++ b/math/p5-Number-WithError/distinfo
@@ -0,0 +1,3 @@
+MD5 (Number-WithError-0.03.tar.gz) = 90bbaf3dc14afb3d7991f1dba1893256
+SHA256 (Number-WithError-0.03.tar.gz) = f658f3810f55b2c8dd94f73a3697ce0ecbdb5981317fdd7b872d3561dad66196
+SIZE (Number-WithError-0.03.tar.gz) = 31035
diff --git a/math/p5-Number-WithError/pkg-descr b/math/p5-Number-WithError/pkg-descr
new file mode 100644
index 000000000000..f0a0c3de61ae
--- /dev/null
+++ b/math/p5-Number-WithError/pkg-descr
@@ -0,0 +1,18 @@
+This class is a container class for numbers with a number of associated
+symmetric and asymmetric errors. It overloads practically all common
+arithmetic operations and trigonometric functions to propagate the errors.
+It can do proper scientific rounding (as explained in more detail below in
+the documentation of the significant_digit() method).
+
+You can use Math::BigFloat objects as the internal representation of
+numbers in order to support arbitrary precision calculations.
+
+Errors are propagated using Gaussian error propagation.
+
+With a notable exception, the test suite covers way over ninety percent of
+the code. The remaining holes are mostly difficult-to-test corner cases
+and sanity tests. The comparison routines are the exception for which
+there will be more extensive tests in a future release.
+
+WWW: http://search.cpan.org/dist/Number-WithError
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Number-WithError/pkg-plist b/math/p5-Number-WithError/pkg-plist
new file mode 100644
index 000000000000..8f9ec7ec105a
--- /dev/null
+++ b/math/p5-Number-WithError/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Number/WithError.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Number/WithError/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Number/WithError
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Number
+@dirrmtry %%SITE_PERL%%/Number