aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Set-IntSpan-Fast
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-02-15 20:44:56 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-02-15 20:44:56 +0000
commitf8d67d195552171686bbec9495ac82a577b60765 (patch)
treeec785d48b468f5398e270d82614a0e5245460d26 /math/p5-Set-IntSpan-Fast
parent0db284b58cd56fe2406ea981345afc590c75f11e (diff)
downloadports-f8d67d195552171686bbec9495ac82a577b60765.tar.gz
ports-f8d67d195552171686bbec9495ac82a577b60765.zip
Notes
Diffstat (limited to 'math/p5-Set-IntSpan-Fast')
-rw-r--r--math/p5-Set-IntSpan-Fast/Makefile34
-rw-r--r--math/p5-Set-IntSpan-Fast/distinfo3
-rw-r--r--math/p5-Set-IntSpan-Fast/pkg-descr9
-rw-r--r--math/p5-Set-IntSpan-Fast/pkg-plist7
4 files changed, 53 insertions, 0 deletions
diff --git a/math/p5-Set-IntSpan-Fast/Makefile b/math/p5-Set-IntSpan-Fast/Makefile
new file mode 100644
index 000000000000..dc051c80dbab
--- /dev/null
+++ b/math/p5-Set-IntSpan-Fast/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: math/p5-Set-IntSpan-Fast
+# Date created: 15 February 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Set-IntSpan-Fast
+PORTVERSION= 0.0.5
+DISTVERSIONPREFIX= v
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Set
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Fast handling of sets containing integer spans
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
+ ${SITE_PERL}/Data/Types.pm:${PORTSDIR}/devel/p5-Data-Types \
+ ${SITE_PERL}/Class/Std.pm:${PORTSDIR}/devel/p5-Class-Std
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Set::IntSpan::Fast.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Set-IntSpan-Fast/distinfo b/math/p5-Set-IntSpan-Fast/distinfo
new file mode 100644
index 000000000000..7cc37002b1dc
--- /dev/null
+++ b/math/p5-Set-IntSpan-Fast/distinfo
@@ -0,0 +1,3 @@
+MD5 (Set-IntSpan-Fast-v0.0.5.tar.gz) = eb87513d96d60962c290f5b394cb8aba
+SHA256 (Set-IntSpan-Fast-v0.0.5.tar.gz) = 606678c05ff6d79d5906b81e6abd8b40fa8043aa5d2845ab6e547fc6bac27e77
+SIZE (Set-IntSpan-Fast-v0.0.5.tar.gz) = 9924
diff --git a/math/p5-Set-IntSpan-Fast/pkg-descr b/math/p5-Set-IntSpan-Fast/pkg-descr
new file mode 100644
index 000000000000..7828f2762da2
--- /dev/null
+++ b/math/p5-Set-IntSpan-Fast/pkg-descr
@@ -0,0 +1,9 @@
+The Set::IntSpan module represents sets of integers as a number of
+inclusive ranges, for example '1-10,19-23,45-48'. Because many of its
+operations involve linear searches of the list of ranges its overall
+performance tends to be proportional to the number of distinct ranges.
+This is fine for small sets but suffers compared to other possible set
+representations (bit vectors, hash keys) when the number of ranges grows
+large. Set::IntSpan::Fast tries to fix that.
+
+WWW: http://search.cpan.org/dist/Set-IntSpan-Fast/
diff --git a/math/p5-Set-IntSpan-Fast/pkg-plist b/math/p5-Set-IntSpan-Fast/pkg-plist
new file mode 100644
index 000000000000..ff8def1207f0
--- /dev/null
+++ b/math/p5-Set-IntSpan-Fast/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Set/IntSpan/Fast.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/IntSpan/Fast/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/IntSpan/Fast
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/IntSpan
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set
+@dirrmtry %%SITE_PERL%%/Set/IntSpan
+@dirrmtry %%SITE_PERL%%/Set