aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Statistics-LineFit
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-01 01:59:37 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-01 01:59:37 +0000
commit3dc2a9865418578e8fb3a4f6df77f6d18b55ffef (patch)
treefec267a42baa72101515f5ea8612cf992d613f24 /math/p5-Statistics-LineFit
parent621307ff834153c234b05750e524cbe7cf94a24d (diff)
Add p5-Statistics-LineFit 0.06, least squares line fit, weighted or
unweighted. PR: ports/104688 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=175980
Diffstat (limited to 'math/p5-Statistics-LineFit')
-rw-r--r--math/p5-Statistics-LineFit/Makefile22
-rw-r--r--math/p5-Statistics-LineFit/distinfo3
-rw-r--r--math/p5-Statistics-LineFit/pkg-descr9
-rw-r--r--math/p5-Statistics-LineFit/pkg-plist6
4 files changed, 40 insertions, 0 deletions
diff --git a/math/p5-Statistics-LineFit/Makefile b/math/p5-Statistics-LineFit/Makefile
new file mode 100644
index 000000000000..a0f0ba589a1a
--- /dev/null
+++ b/math/p5-Statistics-LineFit/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Statistics-LineFit
+# Date created: 2006-10-23
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Statistics-LineFit
+PORTVERSION= 0.06
+CATEGORIES= math
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Statistics
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Least squares line fit, weighted or unweighted
+
+PERL_CONFIGURE= yes
+
+MAN3= Statistics::LineFit.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-LineFit/distinfo b/math/p5-Statistics-LineFit/distinfo
new file mode 100644
index 000000000000..739b2f53a1f5
--- /dev/null
+++ b/math/p5-Statistics-LineFit/distinfo
@@ -0,0 +1,3 @@
+MD5 (Statistics-LineFit-0.06.tar.gz) = 9c59317652dbfbc97ba53fbd113c2402
+SHA256 (Statistics-LineFit-0.06.tar.gz) = 190bbf735f5b3924a525fe3aaf83315300e29ca722d01425a315291967f3cc12
+SIZE (Statistics-LineFit-0.06.tar.gz) = 23679
diff --git a/math/p5-Statistics-LineFit/pkg-descr b/math/p5-Statistics-LineFit/pkg-descr
new file mode 100644
index 000000000000..c813781b3677
--- /dev/null
+++ b/math/p5-Statistics-LineFit/pkg-descr
@@ -0,0 +1,9 @@
+The Statistics::LineFit module does weighted or unweighted least-squares
+line fitting to two-dimensional data (y = a + b * x). (This is also
+called linear regression.) In addition to the slope and y-intercept, the
+module can return the square of the correlation coefficient (R squared),
+the Durbin-Watson statistic, the mean squared error, sigma, the t
+statistics, the variance of the estimates of the slope and y-intercept,
+the predicted y values and the residuals of the y values.
+
+WWW: http://search.cpan.org/dist/Statistics-LineFit/
diff --git a/math/p5-Statistics-LineFit/pkg-plist b/math/p5-Statistics-LineFit/pkg-plist
new file mode 100644
index 000000000000..b47c3abba248
--- /dev/null
+++ b/math/p5-Statistics-LineFit/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/LineFit/.packlist
+%%SITE_PERL%%/Statistics/LineFit.pm
+@dirrmtry %%SITE_PERL%%/Statistics
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/LineFit
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics