aboutsummaryrefslogtreecommitdiff
path: root/math/pari
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-04 15:46:24 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-04 15:46:24 +0000
commitcc4bc87661e46386cd3963024e0acfecd75709b7 (patch)
tree189e131c12c89b14e86dc3b3926295c2adca5ed0 /math/pari
parent0b6ae44462db35b805af58f22f897782abea49bd (diff)
downloadports-cc4bc87661e46386cd3963024e0acfecd75709b7.tar.gz
ports-cc4bc87661e46386cd3963024e0acfecd75709b7.zip
Notes
Diffstat (limited to 'math/pari')
-rw-r--r--math/pari/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/math/pari/Makefile b/math/pari/Makefile
index ccaa8a42b519..5b902bfd8800 100644
--- a/math/pari/Makefile
+++ b/math/pari/Makefile
@@ -22,7 +22,6 @@ USES= perl5 readline
USE_LDCONFIG= yes
USE_PERL5= build
HAS_CONFIGURE= yes
-CFLAGS_powerpc64= -mminimal-toc
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= --mandir=${MANPREFIX}/man/man1 \
--prefix=${PREFIX} \
@@ -58,6 +57,12 @@ PORTDATA= *
PORTDOCS= *
PORTEXAMPLES= *
+.include <bsd.port.pre.mk>
+
+.if defined(PPC_ABI) && ${PPC_ABI} == ELFv1
+CFLAGS+= -mminimal-toc
+.endif
+
post-patch:
@${REINPLACE_CMD} -E '/libpari_base\=/s/-tls|-gmp//' \
${WRKSRC}/Configure
@@ -77,4 +82,4 @@ do-test-PTHREADS-on:
do-test-MPI-on:
@cd ${WRKSRC} && ${MAKE_CMD} test-parallel RUNTEST="mpirun -np 3"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>