aboutsummaryrefslogtreecommitdiff
path: root/math/pari
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-22 18:55:30 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-22 18:55:30 +0000
commit7c95d801abdb2ce52664ec04382c6350e27aceb6 (patch)
tree4b1a19db70067a5062e312dcbecb7f49a6ea5ddc /math/pari
parent87ac2031cd6e1ab7f8e0d32c7070ddf4e9f986f4 (diff)
Notes
Diffstat (limited to 'math/pari')
-rw-r--r--math/pari/Makefile15
-rw-r--r--math/pari/files/patch-Configure15
-rw-r--r--math/pari/pkg-plist4
3 files changed, 10 insertions, 24 deletions
diff --git a/math/pari/Makefile b/math/pari/Makefile
index cf3ea7c6c639..5a9c6f103d88 100644
--- a/math/pari/Makefile
+++ b/math/pari/Makefile
@@ -2,16 +2,18 @@
# $FreeBSD$
PORTNAME= pari
-PORTVERSION= 2.9.3
+DISTVERSION= 2.9.3
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= math
MASTER_SITES= http://pari.math.u-bordeaux.fr/pub/pari/unix/ \
http://mirrors.rit.edu/zi/
-MAINTAINER= yuri@rawbw.com
+MAINTAINER= yuri@FreeBSD.org
COMMENT= Mathematics library and advanced calculator package
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgmp.so:math/gmp
@@ -24,7 +26,6 @@ CONFIGURE_ARGS= --mandir=${MANPREFIX}/man/man1 \
--prefix=${PREFIX} \
--with-readline
ALL_TARGET= gp
-MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= DOCS OPTIMIZED_CFLAGS X11
OPTIONS_RADIO= THREADS
@@ -49,14 +50,14 @@ MPI_CONFIGURE_ON= --mt=mpi --with-gmp=${LOCALBASE}
MPI_CONFIGURE_ENV= CC=${LOCALBASE}/bin/mpicc
OPTIONS_SUB= yes
-PLIST_SUB= GP_VERSION=${GP_VERSION} PORTVERSION=${PORTVERSION}
+PLIST_SUB= GP_VERSION=${PORTVERSION:R} PORTVERSION=${PORTVERSION}
PORTDATA= *
PORTDOCS= *
PORTEXAMPLES= *
-GP_VERSION= ${PORTVERSION:R}
-
post-patch:
+ @${REINPLACE_CMD} -E '/libpari_base\=/s/-tls|-gmp//' \
+ ${WRKSRC}/Configure
@${REINPLACE_CMD} -e '/^CFLAGS=/s/\$$cflags//' \
${WRKSRC}/config/get_cc
@${REINPLACE_CMD} -e 's|-lX11|-L${LOCALBASE}/lib -lX11|' \
@@ -65,7 +66,7 @@ post-patch:
${WRKSRC}/config/get_readline
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpari-gmp*.so.*
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpari.so.${PORTVERSION}
do-test-PTHREADS-on:
@cd ${WRKSRC} && ${MAKE_CMD} test-parallel
diff --git a/math/pari/files/patch-Configure b/math/pari/files/patch-Configure
deleted file mode 100644
index 863c79e0b77c..000000000000
--- a/math/pari/files/patch-Configure
+++ /dev/null
@@ -1,15 +0,0 @@
---- Configure.orig 2017-05-28 16:56:49 UTC
-+++ Configure
-@@ -104,9 +104,9 @@ case $kernlvl1 in
- gmp) libpari_base=pari-gmp;;
- none) libpari_base=pari;;
- esac
--case $enable_tls in
--yes) libpari_base="${libpari_base}-tls"
--esac
-+#case $enable_tls in
-+#yes) libpari_base="${libpari_base}-tls"
-+#esac
-
- if test `expr $VersionMinor % 2` = 0; then
- libpari_base=$libpari_base-$version
diff --git a/math/pari/pkg-plist b/math/pari/pkg-plist
index 1a7f680b436d..fe40b8721360 100644
--- a/math/pari/pkg-plist
+++ b/math/pari/pkg-plist
@@ -19,8 +19,8 @@ include/pari/paripriv.h
include/pari/paristio.h
include/pari/parisys.h
include/pari/paritune.h
-lib/libpari-gmp.so.%%PORTVERSION%%
-lib/libpari-gmp.so.5
+lib/libpari.so.%%PORTVERSION%%
+lib/libpari.so.5
lib/libpari.so
lib/pari/pari.cfg
man/man1/gp-%%GP_VERSION%%.1.gz