aboutsummaryrefslogtreecommitdiff
path: root/math/pdal
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-28 19:21:17 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-28 19:21:17 +0000
commit5d623418d7afdca1b9aca9380fb750143fb73064 (patch)
treea62b4f70c11fbc2811bcc8dde5b0d57a3760d2a4 /math/pdal
parente5eb74f060c7de02f9337bf2a6333dff681c151d (diff)
downloadports-5d623418d7afdca1b9aca9380fb750143fb73064.tar.gz
ports-5d623418d7afdca1b9aca9380fb750143fb73064.zip
Notes
Diffstat (limited to 'math/pdal')
-rw-r--r--math/pdal/Makefile71
-rw-r--r--math/pdal/distinfo4
-rw-r--r--math/pdal/files/patch-git_080e61432
-rw-r--r--math/pdal/files/patch-git_3c7e99738
-rw-r--r--math/pdal/files/patch-git_5a0b12320
-rw-r--r--math/pdal/files/patch-git_c8a1f8820
-rw-r--r--math/pdal/files/patch-src-Utils.cpp10
-rw-r--r--math/pdal/files/patch-src_PluginManager.cpp11
-rw-r--r--math/pdal/files/patch-vendor_gtest-1.7.0_include_gtest_internal_gtest-port.h28
-rw-r--r--math/pdal/pkg-plist192
10 files changed, 325 insertions, 101 deletions
diff --git a/math/pdal/Makefile b/math/pdal/Makefile
index cae763a40b92..bca268f624c8 100644
--- a/math/pdal/Makefile
+++ b/math/pdal/Makefile
@@ -1,8 +1,8 @@
-# Created by: bart <bart@bureau>
+# Created by: bart <coder@tuxfamily.org>
# $FreeBSD$
PORTNAME= pdal
-PORTVERSION= 0.9.8
+PORTVERSION= 1.1.0
CATEGORIES= math databases graphics
MAINTAINER= coder@tuxfamily.org
@@ -11,20 +11,68 @@ COMMENT= Library for translating and manipulating point cloud data
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= cmake compiler:c++11-lang
+LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal \
+ libgeos.so:${PORTSDIR}/graphics/geos \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs
+
+USES= cmake:outsource compiler:c++11-lib pathfix pkgconfig
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME:tu}
GH_PROJECT= ${GH_ACCOUNT}
-OPTIONS_DEFINE= GDAL GEOTIFF LIBXML2 EMBED_BOOST
-OPTIONS_DEFAULT= GDAL GEOTIFF LIBXML2
+# Unhide std::to_string() to fix build with GCC (see ports/193528 for details).
+CXXFLAGS+= -D_GLIBCXX_USE_C99
+
+OPTIONS_DEFINE= GEOTIFF LIBXML2 LASZIP APPS BASH ATTRIBUTE \
+ ICEBRIDGE PGPOINTCLOUD SQLITE \
+ PYTHON TESTS
+OPTIONS_DEFAULT= GEOTIFF LIBXML2 LASZIP APPS
+#Plugins with lib not in port:
+#RivLib, Matlab, MrSID, CPD, GeoWave, GreyHound, HexBin
OPTIONS_SUB= yes
-GDAL_DESC= Enable GDAL support
-GDAL_CMAKE_ON= -DWITH_GDAL:BOOL=TRUE
-GDAL_LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal
-GDAL_CMAKE_OFF= -DWITH_GDAL:BOOL=FALSE
+PGPOINTCLOUD_DESC= Enable Coherent PostgreSQL Point Cloud plugin
+PGPOINTCLOUD_CMAKE_ON= -DBUILD_PLUGIN_PGPOINTCLOUD:BOOL=TRUE
+PGPOINTCLOUD_USES= pgsql
+PGPOINTCLOUD_CMAKE_OFF= -DBUILD_PLUGIN_PGPOINTCLOUD:BOOL=FALSE
+
+SQLITE_DESC= Enable SQLite plugin
+SQLITE_CMAKE_ON= -DBUILD_PLUGIN_SQLITE:BOOL=TRUE
+SQLITE_USES= sqlite
+SQLITE_CMAKE_OFF= -DBUILD_PLUGIN_SQLITE:BOOL=FALSE
+
+PYTHON_DESC= Enable Python plugin
+PYTHON_CMAKE_ON= -DBUILD_PLUGIN_PYTHON:BOOL=TRUE
+PYTHON_USES= python
+PYTHON_BUILD_DEPENDS= ${PYNUMPY}
+PYTHON_RUN_DEPENDS= ${PYNUMPY}
+PYTHON_CMAKE_OFF= -DBUILD_PLUGIN_PYTHON:BOOL=FALSE
+
+TESTS_DESC= Enable Tests
+TESTS_CMAKE_ON= -DBUILD_PLUGIN_TESTS:BOOL=TRUE
+TESTS_CMAKE_OFF= DBUILD_PLUGIN_TESTS:BOOL=FALSE
+
+ATTRIBUTE_DESC= Enable attribute plugin
+ATTRIBUTE_CMAKE_ON= -DBUILD_PLUGIN_ATTRIBUTE:BOOL=TRUE
+ATTRIBUTE_CMAKE_OFF= -DBUILD_PLUGIN_ATTRIBUTE:BOOL=FALSE
+
+ICEBRIDGE_DESC= Enable Icebridge plugin
+ICEBRIDGE_LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5
+ICEBRIDGE_CMAKE_ON= -DBUILD_PLUGIN_ICEBRIDGE:BOOL=TRUE
+ICEBRIDGE_CMAKE_OFF= -DBUILD_PLUGIN_ICEBRIDGE:BOOL=FALSE
+
+APPS_DESC= PDAL command line application
+APPS_CMAKE_ON= -DWITH_APPS:BOOL=TRUE
+APPS_CMAKE_OFF= -DWITH_APPS:BOOL=FALSE
+
+BASH_DESC= BASH completion
+BASH_CMAKE_ON= -DWITH_BASH:BOOL=TRUE
+BASH_RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+BASH_CMAKE_OFF= -DWITH_BASH:BOOL=FALSE
+
+LASZIP_DESC= Enable LASZip support (Recommended)
+LASZIP_LIB_DEPENDS= liblaszip.so:${PORTSDIR}/archivers/laszip
GEOTIFF_CMAKE_ON= -DWITH_GEOTIFF:BOOL=TRUE
GEOTIFF_LIB_DEPENDS= libgeotiff.so:${PORTSDIR}/graphics/libgeotiff
@@ -34,9 +82,4 @@ LIBXML2_CMAKE_ON= -DWITH_LIBXML2:BOOL=TRUE
LIBXML2_LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
LIBXML2_CMAKE_OFF= -DWITH_LIBXML2:BOOL=FALSE
-EMBED_BOOST_DESC= Use embedded rather than system boost
-EMBED_BOOST_CMAKE_ON= -DPDAL_EMBED_BOOST:BOOL=TRUE
-EMBED_BOOST_CMAKE_OFF= -DPDAL_EMBED_BOOST:BOOL=FALSE
-EMBED_BOOST_LIB_DEPENDS_OFF= libboost_thread.so:${PORTSDIR}/devel/boost-libs
-
.include <bsd.port.mk>
diff --git a/math/pdal/distinfo b/math/pdal/distinfo
index 5f2e69d38597..cbdf2da1552c 100644
--- a/math/pdal/distinfo
+++ b/math/pdal/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PDAL-PDAL-0.9.8_GH0.tar.gz) = aef41ae7c8b87541eb9cc11c2e17f086ac26799f3e4da0f19f8e78e0538060ff
-SIZE (PDAL-PDAL-0.9.8_GH0.tar.gz) = 11046030
+SHA256 (PDAL-PDAL-1.1.0_GH0.tar.gz) = 70e0c84035b3fdc75c4eb72dde62a7a2138171d249f2a607170f79d5cafe589d
+SIZE (PDAL-PDAL-1.1.0_GH0.tar.gz) = 37323319
diff --git a/math/pdal/files/patch-git_080e614 b/math/pdal/files/patch-git_080e614
new file mode 100644
index 000000000000..a79fd3a8ef9d
--- /dev/null
+++ b/math/pdal/files/patch-git_080e614
@@ -0,0 +1,32 @@
+commit 080e614bd975aa3784a463a8a0b50885bc65c726
+Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Fri Mar 25 00:21:04 2016 +0100
+
+ Link against ${CMAKE_DL_LIBS} instead of libdl.
+
+ -dl only exists on Linux, so linking fails on other OSes like FreeBSD.
+ Use the portable CMAKE_DL_LIBS variable instead.
+--- src/util/CMakeLists.txt.orig 2016-03-24 21:27:02 UTC
++++ src/util/CMakeLists.txt
+@@ -33,20 +33,11 @@ set(PDAL_UTIL_SOURCES
+ ${PDAL_UTIL_HPP})
+
+ PDAL_ADD_LIBRARY(${PDAL_UTIL_LIB_NAME} SHARED ${PDAL_UTIL_SOURCES})
+-target_link_libraries(${PDAL_UTIL_LIB_NAME} ${Boost_LIBRARIES})
++target_link_libraries(${PDAL_UTIL_LIB_NAME} ${Boost_LIBRARIES} ${CMAKE_DL_LIBS})
+
+ set_target_properties(${PDAL_UTIL_LIB_NAME} PROPERTIES
+ VERSION "${PDAL_BUILD_VERSION}"
+ SOVERSION "${PDAL_API_VERSION}"
+ CLEAN_DIRECT_OUTPUT 1)
+
+-if (NOT WIN32)
+- target_link_libraries(${PDAL_UTIL_LIB_NAME} dl)
+-endif (NOT WIN32)
+-
+-if (NOT WIN32)
+- target_link_libraries(${PDAL_UTIL_LIB_NAME} dl)
+-endif (NOT WIN32)
+-
+ set_property(GLOBAL PROPERTY _UTIL_INCLUDED TRUE)
+-
diff --git a/math/pdal/files/patch-git_3c7e997 b/math/pdal/files/patch-git_3c7e997
new file mode 100644
index 000000000000..df8c07a81e83
--- /dev/null
+++ b/math/pdal/files/patch-git_3c7e997
@@ -0,0 +1,38 @@
+commit 3c7e9979ea67a56e8d29f7404e1e8153dc93c6bb
+Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Mon Mar 28 14:55:29 2016 +0200
+
+ portable_endian: Remove wrong byte-order macro definitions for the BSDs.
+
+ Only OpenBSD has {b,l}etoh{16,32,64} in addition to {b,l}e{16,32,64}toh,
+ so the macro definitions were breaking the build on all those OSes.
+
+--- include/pdal/util/portable_endian.hpp.orig 2015-11-25 18:45:33 UTC
++++ include/pdal/util/portable_endian.hpp
+@@ -41,23 +41,10 @@
+ # define __PDP_ENDIAN PDP_ENDIAN
+ **/
+
+-#elif defined(__OpenBSD__)
+-
+-# include <sys/endian.h>
+-
+-#elif defined(__NetBSD__) || defined(__FreeBSD__) || defined(__DragonFly__)
+-
++#elif defined(__OpenBSD__) || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__DragonFly__)
++
+ # include <sys/endian.h>
+-
+-# define be16toh betoh16
+-# define le16toh letoh16
+-
+-# define be32toh betoh32
+-# define le32toh letoh32
+-
+-# define be64toh betoh64
+-# define le64toh letoh64
+-
++
+ #elif defined(__WINDOWS__)
+
+ # include <winsock2.h>
diff --git a/math/pdal/files/patch-git_5a0b123 b/math/pdal/files/patch-git_5a0b123
new file mode 100644
index 000000000000..a415df4cfcec
--- /dev/null
+++ b/math/pdal/files/patch-git_5a0b123
@@ -0,0 +1,20 @@
+commit 5a0b123bfd7a843b18318ec2e95ce725c5f1f386
+Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Mon Mar 28 15:07:22 2016 +0200
+
+ utils: Include sys/wait.h for the WIFEXITED and WEXITSTATUS macros.
+
+ These two macros are defined in sys/wait.h, which was being included
+ indirectly by other headers. This did not work on systems such as
+ FreeBSD, so explicitly include all headers that we actually need.
+
+--- src/util/Utils.cpp.orig 2015-11-25 18:45:33 UTC
++++ src/util/Utils.cpp
+@@ -43,6 +43,7 @@
+ #ifndef _WIN32
+ #include <cxxabi.h>
+ #include <sys/ioctl.h>
++#include <sys/wait.h> // WIFEXITED, WEXITSTATUS
+ #endif
+
+ #ifdef PDAL_COMPILER_MSVC
diff --git a/math/pdal/files/patch-git_c8a1f88 b/math/pdal/files/patch-git_c8a1f88
new file mode 100644
index 000000000000..be7dbd162528
--- /dev/null
+++ b/math/pdal/files/patch-git_c8a1f88
@@ -0,0 +1,20 @@
+commit c8a1f887d7316f76853bd67ffe5a9bb556e54b57
+Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Fri Mar 25 17:48:33 2016 +0100
+
+ nanoflann: Include <cstdlib> for ::malloc().
+
+ malloc() is defined in stdlib.h, which was being included indirectly by
+ other on Linux. On systems such as FreeBSD, the code was just failing to
+ build because of the missing symbol.
+
+--- vendor/nanoflann-1.1.8/nanoflann.hpp.orig 2015-11-25 18:45:33 UTC
++++ vendor/nanoflann-1.1.8/nanoflann.hpp
+@@ -38,6 +38,7 @@
+ #include <algorithm>
+ #include <stdexcept>
+ #include <cstdio> // for fwrite()
++#include <cstdlib> // for malloc()
+ #include <cmath> // for fabs(),...
+ #include <limits>
+
diff --git a/math/pdal/files/patch-src-Utils.cpp b/math/pdal/files/patch-src-Utils.cpp
deleted file mode 100644
index 8615706edd13..000000000000
--- a/math/pdal/files/patch-src-Utils.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/Utils.cpp.orig 2014-07-27 19:02:59.456832475 +0200
-+++ src/Utils.cpp 2014-07-27 19:03:23.513363445 +0200
-@@ -37,6 +37,7 @@
- #include <cassert>
- #include <cstdlib>
- #include <cctype>
-+#include <sys/wait.h>
-
- #ifdef PDAL_COMPILER_MSVC
- # pragma warning(disable: 4127) // conditional expression is constant
diff --git a/math/pdal/files/patch-src_PluginManager.cpp b/math/pdal/files/patch-src_PluginManager.cpp
new file mode 100644
index 000000000000..616d7036103f
--- /dev/null
+++ b/math/pdal/files/patch-src_PluginManager.cpp
@@ -0,0 +1,11 @@
+--- src/PluginManager.cpp.orig 2015-11-25 18:45:33 UTC
++++ src/PluginManager.cpp
+@@ -58,7 +58,7 @@ namespace
+ {
+ #if defined(__APPLE__) && defined(__MACH__)
+ const std::string dynamicLibraryExtension(".dylib");
+-#elif defined __linux__
++#elif defined __linux__ || __FreeBSD__
+ const std::string dynamicLibraryExtension(".so");
+ #elif defined _WIN32
+ const std::string dynamicLibraryExtension(".dll");
diff --git a/math/pdal/files/patch-vendor_gtest-1.7.0_include_gtest_internal_gtest-port.h b/math/pdal/files/patch-vendor_gtest-1.7.0_include_gtest_internal_gtest-port.h
new file mode 100644
index 000000000000..706f1531fbf0
--- /dev/null
+++ b/math/pdal/files/patch-vendor_gtest-1.7.0_include_gtest_internal_gtest-port.h
@@ -0,0 +1,28 @@
+--- vendor/gtest-1.7.0/include/gtest/internal/gtest-port.h.orig 2016-03-24 21:27:13 UTC
++++ vendor/gtest-1.7.0/include/gtest/internal/gtest-port.h
+@@ -92,6 +92,7 @@
+ // the given platform; otherwise undefined):
+ // GTEST_OS_AIX - IBM AIX
+ // GTEST_OS_CYGWIN - Cygwin
++// GTEST_OS_FREEBSD - FreeBSD
+ // GTEST_OS_HPUX - HP-UX
+ // GTEST_OS_LINUX - Linux
+ // GTEST_OS_LINUX_ANDROID - Google Android
+@@ -267,6 +268,8 @@
+ # define GTEST_OS_OPENBSD 1
+ #elif defined __QNX__
+ # define GTEST_OS_QNX 1
++#elif defined __FreeBSD__
++# define GTEST_OS_FREEBSD 1
+ #endif // __CYGWIN__
+
+ #ifndef GTEST_LANG_CXX11
+@@ -646,7 +649,7 @@ using ::std::tuple_size;
+ (GTEST_OS_MAC && !GTEST_OS_IOS) || GTEST_OS_IOS_SIMULATOR || \
+ (GTEST_OS_WINDOWS_DESKTOP && _MSC_VER >= 1400) || \
+ GTEST_OS_WINDOWS_MINGW || GTEST_OS_AIX || GTEST_OS_HPUX || \
+- GTEST_OS_OPENBSD || GTEST_OS_QNX)
++ GTEST_OS_OPENBSD || GTEST_OS_QNX || GTEST_OS_FREEBSD)
+ # define GTEST_HAS_DEATH_TEST 1
+ # include <vector> // NOLINT
+ #endif
diff --git a/math/pdal/pkg-plist b/math/pdal/pkg-plist
index 5d3d0550eb62..9019583f2738 100644
--- a/math/pdal/pkg-plist
+++ b/math/pdal/pkg-plist
@@ -1,103 +1,145 @@
-bin/pc2pc
-bin/pcequal
-bin/pcinfo
-bin/pcpipeline
-bin/pcquery
+bin/pdal
bin/pdal-config
-include/pdal/Bounds.hpp
+include/pdal/BpfCompressor.hpp
+include/pdal/BpfHeader.hpp
+include/pdal/BpfReader.hpp
+include/pdal/BpfWriter.hpp
+include/pdal/BufferReader.hpp
+include/pdal/ChipperFilter.hpp
+include/pdal/ColorizationFilter.hpp
+include/pdal/Compression.hpp
+include/pdal/CropFilter.hpp
+include/pdal/DbReader.hpp
+include/pdal/DbWriter.hpp
+include/pdal/DecimationFilter.hpp
+include/pdal/DeltaKernel.hpp
+include/pdal/DerivativeWriter.hpp
+include/pdal/DiffKernel.hpp
include/pdal/Dimension.hpp
-include/pdal/Endian.hpp
-include/pdal/FileUtils.hpp
+include/pdal/DividerFilter.hpp
+include/pdal/FauxReader.hpp
+include/pdal/FerryFilter.hpp
include/pdal/Filter.hpp
-include/pdal/FilterIterator.hpp
+include/pdal/FlexWriter.hpp
+include/pdal/GDALReader.hpp
include/pdal/GDALUtils.hpp
+include/pdal/Geometry.hpp
+include/pdal/GeotiffSupport.hpp
include/pdal/GlobalEnvironment.hpp
+include/pdal/HeaderVal.hpp
+include/pdal/Ilvis2Reader.hpp
+include/pdal/InfoKernel.hpp
+include/pdal/KDIndex.hpp
+include/pdal/Kernel.hpp
+include/pdal/KernelFactory.hpp
+include/pdal/KernelSupport.hpp
+include/pdal/LasError.hpp
+include/pdal/LasHeader.hpp
+include/pdal/LasReader.hpp
+include/pdal/LasUtils.hpp
+include/pdal/LasWriter.hpp
include/pdal/Log.hpp
+include/pdal/MergeFilter.hpp
+include/pdal/MergeKernel.hpp
include/pdal/Metadata.hpp
-include/pdal/MultiFilter.hpp
-include/pdal/MultiFilterIterator.hpp
-include/pdal/Object.hpp
+include/pdal/MortonOrderFilter.hpp
+include/pdal/NullWriter.hpp
+include/pdal/OptechCommon.hpp
+include/pdal/OptechReader.hpp
+include/pdal/OptechRotationMatrix.hpp
include/pdal/Options.hpp
+include/pdal/PDALUtils.hpp
+include/pdal/PipelineKernel.hpp
include/pdal/PipelineManager.hpp
include/pdal/PipelineReader.hpp
include/pdal/PipelineWriter.hpp
-include/pdal/PointBuffer.hpp
-include/pdal/Range.hpp
+include/pdal/PluginManager.hpp
+include/pdal/PlyReader.hpp
+include/pdal/PlyWriter.hpp
+include/pdal/PointLayout.hpp
+include/pdal/PointTable.hpp
+include/pdal/PointView.hpp
+include/pdal/PointViewIter.hpp
+include/pdal/QfitReader.hpp
+include/pdal/QuadIndex.hpp
+include/pdal/QuickInfo.hpp
+include/pdal/RandomKernel.hpp
+include/pdal/RandomizeFilter.hpp
+include/pdal/RangeFilter.hpp
include/pdal/Reader.hpp
-include/pdal/ReaderIterator.hpp
-include/pdal/Schema.hpp
+include/pdal/ReprojectionFilter.hpp
+include/pdal/SbetCommon.hpp
+include/pdal/SbetReader.hpp
+include/pdal/SbetWriter.hpp
+include/pdal/SortFilter.hpp
+include/pdal/SortKernel.hpp
include/pdal/SpatialReference.hpp
+include/pdal/SplitKernel.hpp
+include/pdal/SplitterFilter.hpp
include/pdal/Stage.hpp
-include/pdal/StageBase.hpp
include/pdal/StageFactory.hpp
-include/pdal/StageIterator.hpp
-include/pdal/StreamFactory.hpp
-include/pdal/ThreadEnvironment.hpp
+include/pdal/StageWrapper.hpp
+include/pdal/StatsFilter.hpp
+include/pdal/SummaryData.hpp
+include/pdal/TIndexKernel.hpp
+include/pdal/TIndexReader.hpp
+include/pdal/TerrasolidReader.hpp
+include/pdal/TextWriter.hpp
+include/pdal/TransformationFilter.hpp
+include/pdal/TranslateKernel.hpp
include/pdal/UserCallback.hpp
-include/pdal/Utils.hpp
-include/pdal/Vector.hpp
+include/pdal/VariableLengthRecord.hpp
include/pdal/Writer.hpp
include/pdal/XMLSchema.hpp
-include/pdal/drivers/buffer/Reader.hpp
-include/pdal/drivers/caris/CloudIterator.hpp
-include/pdal/drivers/caris/CloudReader.hpp
-include/pdal/drivers/faux/Reader.hpp
-include/pdal/drivers/faux/Writer.hpp
-include/pdal/drivers/las/Header.hpp
-include/pdal/drivers/las/Reader.hpp
-include/pdal/drivers/las/ReaderBase.hpp
-include/pdal/drivers/las/SummaryData.hpp
-include/pdal/drivers/las/Support.hpp
-include/pdal/drivers/las/VariableLengthRecord.hpp
-include/pdal/drivers/las/Writer.hpp
-include/pdal/drivers/mrsid/Reader.hpp
-include/pdal/drivers/nitf/Reader.hpp
-include/pdal/drivers/nitf/Writer.hpp
-include/pdal/drivers/oci/Reader.hpp
-include/pdal/drivers/oci/Writer.hpp
-include/pdal/drivers/oci/common.hpp
-include/pdal/drivers/oci/oci_wrapper.h
-include/pdal/drivers/p2g/Writer.hpp
-include/pdal/drivers/pgpointcloud/Reader.hpp
-include/pdal/drivers/pgpointcloud/Writer.hpp
-include/pdal/drivers/pgpointcloud/common.hpp
-include/pdal/drivers/pipeline/Reader.hpp
-include/pdal/drivers/qfit/Reader.hpp
-include/pdal/drivers/soci/Reader.hpp
-include/pdal/drivers/soci/Writer.hpp
-include/pdal/drivers/soci/common.hpp
-include/pdal/drivers/terrasolid/Reader.hpp
-include/pdal/drivers/text/Writer.hpp
-include/pdal/filters/ByteSwap.hpp
-include/pdal/filters/Cache.hpp
-include/pdal/filters/Chipper.hpp
-include/pdal/filters/Color.hpp
-include/pdal/filters/Colorization.hpp
-include/pdal/filters/Crop.hpp
-include/pdal/filters/Decimation.hpp
-include/pdal/filters/HexBin.hpp
-include/pdal/filters/InPlaceReprojection.hpp
-include/pdal/filters/Index.hpp
-include/pdal/filters/Mosaic.hpp
-include/pdal/filters/PointBufferCache.hpp
-include/pdal/filters/Predicate.hpp
-include/pdal/filters/Programmable.hpp
-include/pdal/filters/Reprojection.hpp
-include/pdal/filters/Scaling.hpp
-include/pdal/filters/Selector.hpp
-include/pdal/filters/Stats.hpp
+include/pdal/ZipPoint.hpp
include/pdal/gitsha.h
+include/pdal/pdal.hpp
include/pdal/pdal_config.hpp
include/pdal/pdal_defines.h
-include/pdal/pdal_error.hpp
include/pdal/pdal_export.hpp
include/pdal/pdal_internal.hpp
include/pdal/pdal_macros.hpp
+include/pdal/pdal_test_main.hpp
include/pdal/pdal_types.hpp
+include/pdal/plang/Array.hpp
include/pdal/plang/BufferedInvocation.hpp
+include/pdal/plang/Environment.hpp
include/pdal/plang/Invocation.hpp
-include/pdal/plang/PythonEnvironment.hpp
+include/pdal/plang/Redirector.hpp
include/pdal/plang/Script.hpp
-include/pdal/third/nanoflann.hpp
-lib/libpdal.so
-lib/libpdal.so.0
+include/pdal/plugin.hpp
+include/pdal/util/Algorithm.hpp
+include/pdal/util/Bounds.hpp
+include/pdal/util/Charbuf.hpp
+include/pdal/util/Endian.hpp
+include/pdal/util/Extractor.hpp
+include/pdal/util/FileUtils.hpp
+include/pdal/util/Georeference.hpp
+include/pdal/util/IStream.hpp
+include/pdal/util/Inserter.hpp
+include/pdal/util/OStream.hpp
+include/pdal/util/Utils.hpp
+include/pdal/util/portable_endian.hpp
+lib/libpdal_base.so
+lib/libpdal_base.so.1
+lib/libpdal_base.so.2.0.0
+lib/libpdal_util.so
+lib/libpdal_util.so.1
+lib/libpdal_util.so.2.0.0
+lib/libpdalcpp.so
+%%PYTHON%%lib/libpdal_plang.so
+%%PYTHON%%lib/libpdal_plang.so.1
+%%PYTHON%%lib/libpdal_plang.so.2.0.0
+%%PYTHON%%lib/libpdal_plugin_filter_predicate.so
+%%PYTHON%%lib/libpdal_plugin_filter_programmable.so
+%%ATTRIBUTE%%lib/libpdal_plugin_filter_attribute.so
+%%ICEBRIDGE%%lib/libpdal_plugin_reader_icebridge.so
+%%SQLITE%%lib/libpdal_plugin_reader_sqlite.so
+%%SQLITE%%lib/libpdal_plugin_writer_sqlite.so
+%%PGPOINTCLOUD%%lib/libpdal_plugin_reader_pgpointcloud.so
+%%PGPOINTCLOUD%%lib/libpdal_plugin_writer_pgpointcloud.so
+lib/pdal/cmake/PDALConfig.cmake
+lib/pdal/cmake/PDALConfigVersion.cmake
+lib/pdal/cmake/PDALTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/pdal/cmake/PDALTargets.cmake
+libdata/pkgconfig/pdal.pc