aboutsummaryrefslogtreecommitdiff
path: root/math/pear-Structures_Graph/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-11 20:35:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-11 20:35:25 +0000
commit94c40ac78da251dff3ae8b7231c0a5afbc32f779 (patch)
tree4a344229727ecfea69f395a18c43c3f6f48f5cf7 /math/pear-Structures_Graph/Makefile
parentecd10303fa8d4eaa7f8e49396ff592bf8946ef78 (diff)
downloadports-94c40ac78da251dff3ae8b7231c0a5afbc32f779.tar.gz
ports-94c40ac78da251dff3ae8b7231c0a5afbc32f779.zip
Notes
Diffstat (limited to 'math/pear-Structures_Graph/Makefile')
-rw-r--r--math/pear-Structures_Graph/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/math/pear-Structures_Graph/Makefile b/math/pear-Structures_Graph/Makefile
new file mode 100644
index 000000000000..ca84cafa65ec
--- /dev/null
+++ b/math/pear-Structures_Graph/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: pear-Structures_Graph
+# Date created: 09 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Structures_Graph
+PORTVERSION= 1.0.1
+CATEGORIES= math devel pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR graph datastructure manipulation library
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Structures
+FILES= Graph/Manipulator/TopologicalSorter.php \
+ Graph/Manipulator/AcyclicTest.php Graph/Node.php Graph.php
+DOCS= Structures_Graph.pkg
+_DOCSDIR= docs/tutorials/Structures_Graph
+
+post-extract:
+ @${MV} ${WRKSRC}/Structures/* ${WRKSRC}/
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>