aboutsummaryrefslogtreecommitdiff
path: root/math/petiga
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-05-21 11:10:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-05-21 11:10:10 +0000
commit2d368bc6a736954ab9849f8aab0c298988d02dbf (patch)
tree125306f9013f535ab38c2f4b77d51cc427f29654 /math/petiga
parent9fc088d772c8e3449e820ed7e506feced2e78cc6 (diff)
Notes
Diffstat (limited to 'math/petiga')
-rw-r--r--math/petiga/Makefile40
-rw-r--r--math/petiga/distinfo3
-rw-r--r--math/petiga/files/patch-CMakeLists.txt23
-rw-r--r--math/petiga/pkg-descr13
4 files changed, 79 insertions, 0 deletions
diff --git a/math/petiga/Makefile b/math/petiga/Makefile
new file mode 100644
index 000000000000..d169938228b1
--- /dev/null
+++ b/math/petiga/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= petiga
+DISTVERSION= g20180518
+CATEGORIES= math python
+MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${BB_PROJECT}/get/${BB_COMMIT}.tar.gz?dummy=/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Framework for High Performance Isogeometric Analysis
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+BROKEN_FreeBSD_10= SSE instruction set not enabled
+
+LIB_DEPENDS= libblas.so:math/blas \
+ liblapack.so:math/lapack \
+ libmpich.so:net/mpich2 \
+ libpetsc.so:science/PETSc
+
+BB_ACCOUNT= dalcinl
+BB_PROJECT= ${PORTNAME}
+BB_COMMIT= e2a59b1ba054
+
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
+
+USES= cmake:outsource fortran
+USE_XORG= x11
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/petiga.h \
+ lib/libpetiga.so \
+ lib/petiga/conf/rules \
+ lib/petiga/conf/test \
+ lib/petiga/conf/variables
+
+post-install:
+ @cd ${STAGEDIR}${PREFIX}/include && ${RMDIR} petiga/cxx petiga/fad petiga
+
+.include <bsd.port.mk>
diff --git a/math/petiga/distinfo b/math/petiga/distinfo
new file mode 100644
index 000000000000..1e41e7484e45
--- /dev/null
+++ b/math/petiga/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1526897728
+SHA256 (petiga-g20180518.tar.gz) = 6be68ce0de611b7811de0097021b3b78a86185d29cdd36d3ce04f22b8ba9c9de
+SIZE (petiga-g20180518.tar.gz) = 189972
diff --git a/math/petiga/files/patch-CMakeLists.txt b/math/petiga/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..26cbb8470584
--- /dev/null
+++ b/math/petiga/files/patch-CMakeLists.txt
@@ -0,0 +1,23 @@
+--- CMakeLists.txt.orig 2018-05-17 14:35:00 UTC
++++ CMakeLists.txt
+@@ -15,7 +15,7 @@ else ()
+ find_library (PETSC_LIBRARIES NAMES petsc HINTS "${PETSC_DIR}" PATH_SUFFIXES "${PETSC_ARCH}/lib" "lib" NO_DEFAULT_PATH)
+ find_path (PETSC_CONF_DIR petscrules HINTS "${PETSC_DIR}/${PETSC_ARCH}" PATH_SUFFIXES "lib/petsc/conf" "conf" NO_DEFAULT_PATH)
+ mark_as_advanced (PETSC_CONF_DIR)
+- include (${PETSC_CONF_DIR}/PETScConfig.cmake)
++ include (${PETSC_CONF_DIR}/PETScBuildInternal.cmake)
+ mark_as_advanced (PETSC_CLANGUAGE_Cxx)
+ endif ()
+
+@@ -67,8 +67,8 @@ if (BUILD_STATIC_LIBS)
+ endif ()
+
+ install (DIRECTORY include/ DESTINATION include FILES_MATCHING PATTERN "*.h" )
+-install (DIRECTORY ${PETSC_ARCH}/include/ DESTINATION include FILES_MATCHING PATTERN "*.h" )
+-install (DIRECTORY ${PETSC_ARCH}/include/ DESTINATION include FILES_MATCHING PATTERN "*.mod" )
++#install (DIRECTORY ${PETSC_ARCH}/include/ DESTINATION include FILES_MATCHING PATTERN "*.h" )
++#install (DIRECTORY ${PETSC_ARCH}/include/ DESTINATION include FILES_MATCHING PATTERN "*.mod" )
+ install (DIRECTORY lib/petiga/conf/ DESTINATION lib/petiga/conf)
+-install (CODE "execute_process(COMMAND sed -i.arch -e s/$\(PETSC_ARCH\).//g \"${CMAKE_INSTALL_PREFIX}/lib/petiga/conf/variables\")")
++#install (CODE "execute_process(COMMAND sed -i.arch -e s/$\(PETSC_ARCH\).//g \"${CMAKE_INSTALL_PREFIX}/lib/petiga/conf/variables\")")
+ install (CODE "file(REMOVE \"${CMAKE_INSTALL_PREFIX}/lib/petiga/conf/variables.arch\")")
diff --git a/math/petiga/pkg-descr b/math/petiga/pkg-descr
new file mode 100644
index 000000000000..2c4274e488e8
--- /dev/null
+++ b/math/petiga/pkg-descr
@@ -0,0 +1,13 @@
+This software framework implements a NURBS-based Galerkin finite element method
+(FEM), popularly known as isogeometric analysis (IGA). It is heavily based on
+PETSc, the Portable, Extensible Toolkit for Scientific Computation. PETSc is a
+collection of algorithms and data structures for the solution of scientific
+problems, particularly those modeled by partial differential equations (PDEs).
+PETSc is written to be applicable to a range of problem sizes, including
+large-scale simulations where high performance parallel is a must. PetIGA can
+be thought of as an extension of PETSc, which adds the NURBS discretization
+capability and the integration of forms. The PetIGA framework is intended for
+researchers in the numeric solution of PDEs who have applications which require
+extensive computational resources.
+
+WWW: https://bitbucket.org/dalcinl/petiga/