aboutsummaryrefslogtreecommitdiff
path: root/math/petsc
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-06-21 19:54:23 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-06-21 19:54:23 +0000
commitea22d6eb2568dbc988111e0fb9c8eb9a096ee1a8 (patch)
tree444146c1869c4779622c1f9b6fc21248ea99329b /math/petsc
parente76b945cd6943061556e8270f473ce006d7c5bcd (diff)
downloadports-ea22d6eb2568dbc988111e0fb9c8eb9a096ee1a8.tar.gz
ports-ea22d6eb2568dbc988111e0fb9c8eb9a096ee1a8.zip
Notes
Diffstat (limited to 'math/petsc')
-rw-r--r--math/petsc/Makefile28
-rw-r--r--math/petsc/distinfo6
-rw-r--r--math/petsc/pkg-plist1
3 files changed, 22 insertions, 13 deletions
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index 548cdc349ec6..0a00ef0bbc5d 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= petsc
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= math parallel
MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
DISTNAME= ${PORTNAME}-${PORTVERSION}-p${PATCHLEVEL}
@@ -16,7 +17,7 @@ COMMENT= Portable, Extensible Toolkit for Scientific computation
RUN_DEPENDS= ksh93:${PORTSDIR}/shells/ksh93
-PATCHLEVEL= 7
+PATCHLEVEL= 14
HAS_CONFIGURE= yes
USE_PYTHON= yes
@@ -46,12 +47,6 @@ PFX= ${PORTNAME}
TARGET= ${OPSYS:L}
PLIST_SUB= PFX=${PFX} TARGET=${TARGET}
-.if !defined(WITHOUT_BLASLAPACK)
-LIB_DEPENDS+= f77blas.1:${PORTSDIR}/math/atlas
-LIBBLASLAPACK= "-L${LOCALBASE}/lib -lalapack -lf77blas -lcblas -latlas -lg2c -lm"
-CONFIGURE_ARGS+= --with-blas-lapack-lib=${LIBBLASLAPACK}
-.endif
-
.if !defined(WITHOUT_UMFPACK)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libumfpack.a:${PORTSDIR}/math/umfpack
CONFIGURE_ARGS+= --with-umfpack-include="${LOCALBASE}/include/UMFPACK" \
@@ -98,6 +93,19 @@ WITHOUT_SUPERLU= yes
PLIST_SUB+= MPIUNI=""
.endif
+.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
+WITH_ATLAS= yes
+.endif
+.if defined(WITH_ATLAS)
+LIB_DEPENDS+= f77blas.1:${PORTSDIR}/math/atlas
+LIBBLASLAPACK= "-L${LOCALBASE}/lib -lalapack -lf77blas -lcblas -latlas -lg2c -lm"
+CONFIGURE_ARGS+= --with-blas-lapack-lib=${LIBBLASLAPACK}
+.else
+LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack
+LIBBLASLAPACK= "-L${LOCALBASE}/lib -llapack -lblas -lm"
+CONFIGURE_ARGS+= --with-blas-lapack-lib=${LIBBLASLAPACK}
+.endif
+
.if !defined(WITHOUT_SUPERLU) && !defined(WITHOUT_BLASLAPACK)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsuperlu.a:${PORTSDIR}/math/superlu
CONFIGURE_ARGS+= --with-superlu-include=${LOCALBASE}/include/superlu \
@@ -196,8 +204,8 @@ pre-everything::
.if !defined (WITHOUT_X11)
@${ECHO_MSG} "Define WITHOUT_X11 to remove X11 support."
.endif
-.if !defined (WITHOUT_BLASLAPACK)
- @${ECHO_MSG} "Define WITHOUT_BLASLAPACK to remove Blas / Lapack support."
+.if !defined (WITH_ATLAS)
+ @${ECHO_MSG} "Define WITH_ATLAS to replace Blas / Lapack support by Atlas."
.endif
.if !defined (WITHOUT_BS95)
@${ECHO_MSG} "Define WITHOUT_BS95 to remove BlockSolve95 support."
@@ -239,7 +247,7 @@ post-install:
@${ECHO_MSG}
.if defined(MAINTAINER_MODE)
-test: build
+regression-test: build
@(cd ${BUILD_WRKSRC}; \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test)
.endif
diff --git a/math/petsc/distinfo b/math/petsc/distinfo
index ce72e73af231..e38e9fb1a79f 100644
--- a/math/petsc/distinfo
+++ b/math/petsc/distinfo
@@ -1,3 +1,3 @@
-MD5 (petsc-2.3.1-p7.tar.gz) = 2d2a15d0ad066a48e14ac11d6f082b3f
-SHA256 (petsc-2.3.1-p7.tar.gz) = 80e429fbcd5564b5086aecb559a0618f7551ea2891fce5f413bb1368194dca3d
-SIZE (petsc-2.3.1-p7.tar.gz) = 10278608
+MD5 (petsc-2.3.1-p14.tar.gz) = 4fe53540e6321c8866e5dd91b506728a
+SHA256 (petsc-2.3.1-p14.tar.gz) = 3e20543b5f7accbab1f1351ac1e0a346db4dd57a466dacadb18556a7f197f2d3
+SIZE (petsc-2.3.1-p14.tar.gz) = 10282297
diff --git a/math/petsc/pkg-plist b/math/petsc/pkg-plist
index 0a683581c299..b35acfcb1c05 100644
--- a/math/petsc/pkg-plist
+++ b/math/petsc/pkg-plist
@@ -115,6 +115,7 @@
%%PFX%%/include/finclude/petscdef.h.html
%%PFX%%/include/finclude/petscdraw.h
%%PFX%%/include/finclude/petscdraw.h.html
+%%PFX%%/include/finclude/petscerror.h
%%PFX%%/include/finclude/petscis.h
%%PFX%%/include/finclude/petscis.h.html
%%PFX%%/include/finclude/petscis.h90