aboutsummaryrefslogtreecommitdiff
path: root/math/petsc
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2010-11-14 22:00:23 +0000
committerThierry Thomas <thierry@FreeBSD.org>2010-11-14 22:00:23 +0000
commit7db179edb42024999f5ac287c3d633aad02c87ca (patch)
tree8c224de6d8dc6d3ee24f9a70da7351c634faba30 /math/petsc
parent9057d8b613a28938f843b07ce1ecc519556ce99f (diff)
downloadports-7db179edb42024999f5ac287c3d633aad02c87ca.tar.gz
ports-7db179edb42024999f5ac287c3d633aad02c87ca.zip
Notes
Diffstat (limited to 'math/petsc')
-rw-r--r--math/petsc/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index 80ba614cb627..dbcc84d68456 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= petsc
DISTVERSION= 2.3.3-p0
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= math parallel
MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
@@ -28,8 +28,8 @@ CONFIGURE_ENV= PETSC_ARCH=${TARGET} \
PETSC_DIR=${WRKSRC}
CONFIGURE_ARGS= --prefix=${PREFIX}/${PFX} --COPTFLAGS="${CFLAGS}" \
--CXXOPTFLAGS="${CXXFLAGS}" --FOPTFLAGS="${FFLAGS}" \
- --with-shared=1 --with-cc=${CC} --with-fc=${FC} \
- --CPPFLAGS="-I${LOCALBASE}/include"
+ --with-shared=1 --with-cc=${CC} --with-fc=${FC} \
+ --CPPFLAGS="-I${LOCALBASE}/include" --LDFLAGS=${PTHREAD_LIBS}
ALL_TARGET= all
MAKEFILE= makefile
MAKE_ENV= PETSC_DIR=${WRKSRC}
@@ -258,6 +258,14 @@ pre-configure:
${REINPLACE_CMD} -e "s|/bin/ksh|${LOCALBASE}/bin/ksh|" \
${WRKSRC}/bin/popup
@${RM} ${WRKSRC}/bin/popup.bak
+.if defined (WITH_MPI)
+. for ps in ml.py MPE.py
+ ${REINPLACE_CMD} -e "s|-lpmpich|-lmpl|" \
+ ${WRKSRC}/python/PETSc/packages/${ps}
+. endfor
+ ${REINPLACE_CMD} -e "s|libpmpich|libmpl|" \
+ ${WRKSRC}/python/BuildSystem/config/packages/MPI.py
+.endif
.if defined(PACKAGE_BUILDING)
${REINPLACE_CMD} -e "s|%%PACKAGE%%exit 1; ||" \
-e "s|%%PACKAGE%%sys.exit(3)||" \