aboutsummaryrefslogtreecommitdiff
path: root/math/petsc
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-07-23 08:38:59 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-07-23 08:38:59 +0000
commit84927f9fcc27f3a58935f5764a2be45bb171db7b (patch)
treef3e232d24aaf7ad04610ca9fb82cbdaca03fa601 /math/petsc
parent221f0f729559dfa0c3a7f0422f90f9130d240230 (diff)
downloadports-84927f9fcc27f3a58935f5764a2be45bb171db7b.tar.gz
ports-84927f9fcc27f3a58935f5764a2be45bb171db7b.zip
Notes
Diffstat (limited to 'math/petsc')
-rw-r--r--math/petsc/Makefile32
-rw-r--r--math/petsc/distinfo6
-rw-r--r--math/petsc/files/patch-python_PETSc_packages_BlasLapack.py23
3 files changed, 45 insertions, 16 deletions
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index f3170e8802ae..da382471f617 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -6,21 +6,16 @@
#
PORTNAME= petsc
-PORTVERSION= 2.3.1
-PORTREVISION= 1
+DISTVERSION= 2.3.1-p16
+PORTEPOCH= 1
CATEGORIES= math parallel
MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/petsc/release-snapshots/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-p${PATCHLEVEL}
MAINTAINER= ports@FreeBSD.org
COMMENT= Portable, Extensible Toolkit for Scientific computation
-BROKEN= fails to configure
-
RUN_DEPENDS= ksh93:${PORTSDIR}/shells/ksh93
-PATCHLEVEL= 14
-
HAS_CONFIGURE= yes
USE_PYTHON= yes
CONFIGURE_SCRIPT= config/configure.py
@@ -64,7 +59,7 @@ PORTDOCS= *
LIBSCALAPACK= ${LOCALBASE}/lib/libscalapack.a
LIBBLACS= ${LOCALBASE}/lib/libblacs.a
-MPIDIR= ${LOCALBASE}/mpich
+MPIDIR= ${LOCALBASE}/mpich2
.include <bsd.port.pre.mk>
@@ -72,7 +67,7 @@ MPIDIR= ${LOCALBASE}/mpich
WITHOUT_SUPERLU= yes
.endif
-.if exists(${MPIDIR}/bin/mpiCC) && !defined(WITHOUT_MPI)
+.if exists(${MPIDIR}/bin/mpicc) && !defined(WITHOUT_MPI)
WITH_MPI= yes
.endif
.if defined(WITH_MPI)
@@ -80,9 +75,9 @@ WITH_MPI= yes
BROKEN= Cannot build with mpich when lam7 is installed - set WITHOUT_MPI or deinstall lam7
. endif
PKGNAMESUFFIX+= -mpich
-BUILD_DEPENDS+= ${MPIDIR}/bin/mpiCC:${PORTSDIR}/net/mpich
-RUN_DEPENDS+= ${MPIDIR}/bin/mpirun:${PORTSDIR}/net/mpich
-CONFIGURE_ARGS+= --with-mpi-dir=${LOCALBASE}/mpich
+BUILD_DEPENDS+= ${MPIDIR}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${MPIDIR}/bin/mpirun:${PORTSDIR}/net/mpich2
+CONFIGURE_ARGS+= --with-mpi-dir=${LOCALBASE}/mpich2
CONFLICTS= petsc-2*
PLIST_SUB+= MPIUNI="@comment "
.else
@@ -249,9 +244,20 @@ post-install:
@${ECHO_MSG}
.if defined(MAINTAINER_MODE)
-regression-test: build
+regression-test:
+. if defined (WITH_MPI)
+. if !exists(${HOME}/.mpd.conf)
+ @${ECHO_CMD} "MPD_SECRETWORD=change_on_install" > ${HOME}/.mpd.conf
+ ${CHMOD} go-r ${HOME}/.mpd.conf
+ @${ECHO_MSG} "${HOME}/.mpd.conf has been generated - please change the secret word!"
+. endif
+ ${LOCALBASE}/mpich2/bin/mpd &
+. endif
@(cd ${BUILD_WRKSRC}; \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test)
+. if defined (WITH_MPI)
+ ${LOCALBASE}/mpich2/bin/mpdallexit
+. endif
.endif
.include <bsd.port.post.mk>
diff --git a/math/petsc/distinfo b/math/petsc/distinfo
index e38e9fb1a79f..47481c1039b8 100644
--- a/math/petsc/distinfo
+++ b/math/petsc/distinfo
@@ -1,3 +1,3 @@
-MD5 (petsc-2.3.1-p14.tar.gz) = 4fe53540e6321c8866e5dd91b506728a
-SHA256 (petsc-2.3.1-p14.tar.gz) = 3e20543b5f7accbab1f1351ac1e0a346db4dd57a466dacadb18556a7f197f2d3
-SIZE (petsc-2.3.1-p14.tar.gz) = 10282297
+MD5 (petsc-2.3.1-p16.tar.gz) = 643d8f429a074e19156f00d7f0e4e5dc
+SHA256 (petsc-2.3.1-p16.tar.gz) = 98dd93df32788e33d2cee381fb3af4dc20f90dc84308c0d3c84e2eb57093c6ee
+SIZE (petsc-2.3.1-p16.tar.gz) = 10266456
diff --git a/math/petsc/files/patch-python_PETSc_packages_BlasLapack.py b/math/petsc/files/patch-python_PETSc_packages_BlasLapack.py
new file mode 100644
index 000000000000..0f18156cfebe
--- /dev/null
+++ b/math/petsc/files/patch-python_PETSc_packages_BlasLapack.py
@@ -0,0 +1,23 @@
+--- python/PETSc/packages/BlasLapack.py.orig Fri Jul 21 04:44:48 2006
++++ python/PETSc/packages/BlasLapack.py Sat Jul 22 13:57:25 2006
+@@ -117,14 +117,13 @@
+ foundBlas = self.checkBlas(blasLibrary, self.getOtherLibs(foundBlas, blasLibrary), mangleFunc)
+ if foundBlas:
+ foundLapack = self.checkLapack(lapackLibrary, self.getOtherLibs(foundBlas, blasLibrary), mangleFunc)
+- elif not hasattr(self.compilers, 'FC'):
+- self.framework.logPrint('Checking cblaslapack')
+- foundcBlasLapack = self.checkBlas(blasLibrary, self.getOtherLibs(foundBlas, blasLibrary), 0, 'f2cblaslapack_id_')
+- if foundcBlasLapack:
+- foundBlas = self.checkBlas(blasLibrary, self.getOtherLibs(foundBlas, blasLibrary), 0, 'ddot_')
++ else:
++ self.framework.logPrint('Checking cblaslapack name-mangling')
++ foundBlas = self.checkBlas(blasLibrary, self.getOtherLibs(foundBlas, blasLibrary), 0, 'ddot_')
++ if foundBlas:
++ self.framework.logPrint('Found cblaslapack')
+ foundLapack = self.checkLapack(lapackLibrary, self.getOtherLibs(foundBlas, blasLibrary), 0, ['dgetrs_', 'dgeev_'])
+- if foundBlas and foundLapack:
+- self.framework.logPrint('Found cblaslapack')
++ if foundLapack:
+ self.f2c = 1
+ return (foundBlas, foundLapack)
+