aboutsummaryrefslogtreecommitdiff
path: root/math/php4-gmp
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-04-19 10:43:42 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-04-19 10:43:42 +0000
commitbf330a57d40cb5c6f57f61de4d24c0dcbf14dbee (patch)
treefbc3a0515acb659ae86ec22a706ac4607711c903 /math/php4-gmp
parent7db76e2b98b1517c19aa3a79957ac3b37bf853ae (diff)
Notes
Diffstat (limited to 'math/php4-gmp')
-rw-r--r--math/php4-gmp/Makefile1
-rw-r--r--math/php4-gmp/files/patch-gmp.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/math/php4-gmp/Makefile b/math/php4-gmp/Makefile
index 1e1ce1033267..867d7e8fdd12 100644
--- a/math/php4-gmp/Makefile
+++ b/math/php4-gmp/Makefile
@@ -5,6 +5,7 @@
# $FreeBSD$
#
+PORTREVISION= 3
CATEGORIES= math
MASTERDIR= ${.CURDIR}/../../lang/php4
diff --git a/math/php4-gmp/files/patch-gmp.c b/math/php4-gmp/files/patch-gmp.c
new file mode 100644
index 000000000000..816d0f9b0f92
--- /dev/null
+++ b/math/php4-gmp/files/patch-gmp.c
@@ -0,0 +1,11 @@
+--- gmp.c.orig 2010-04-13 14:04:55.000000000 +0200
++++ gmp.c 2010-04-13 14:05:23.000000000 +0200
+@@ -1159,7 +1159,7 @@
+
+ GMPG(rand_initialized) = 1;
+ }
+- mpz_urandomb(*gmpnum_result, GMPG(rand_state), GMP_ABS (limiter) * __GMP_BITS_PER_MP_LIMB);
++ mpz_urandomb(*gmpnum_result, GMPG(rand_state), GMP_ABS (limiter) * GMP_LIMB_BITS);
+
+ ZEND_REGISTER_RESOURCE(return_value, gmpnum_result, le_gmp);
+ }