aboutsummaryrefslogtreecommitdiff
path: root/math/physcalc/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-08-27 23:32:03 +0000
committerWill Andrews <will@FreeBSD.org>2000-08-27 23:32:03 +0000
commit76a432dd93757fc8826bc04bf00ea7b0155a6779 (patch)
tree0f8c8f15cf26e4dee59bd62cec0cb688a5ba90d3 /math/physcalc/Makefile
parenta36c404a5914f1cb2671d87fc8d71c073607381f (diff)
Add physcalc (unversioned), an extremely old (apparently first written
in 1990), but still quite useful and flexible calculator. Basically it's units(1) on steroids. Also added patches to make physcalc secure (who knows, someone might make a cgi interface to it); also allowed it to actually read its *.phy files in another directory. Submitted/Requested by: gsutter gets() -> fgets() code: eivind SHAREDIR code: Marius Bendiksen <mbendiks@eunet.no>
Notes
Notes: svn path=/head/; revision=32044
Diffstat (limited to 'math/physcalc/Makefile')
-rw-r--r--math/physcalc/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/math/physcalc/Makefile b/math/physcalc/Makefile
new file mode 100644
index 000000000000..d2cab5eaf119
--- /dev/null
+++ b/math/physcalc/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: physcalc
+# Date created: Sun 27 Aug 2000
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= physcalc
+PORTVERSION= 1.0
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.lightlink.com/pub/vulcan/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .zip
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+
+pre-patch:
+.for FILE in compiler.h physcalc.h physconv.c physdecl.h physmain.c physmlib.c \
+ physnode.c physoper.c physsolv.c
+ @${MV} ${WRKSRC}/${FILE} ${WRKSRC}/${FILE}.sed
+ ${SED} -e 's, ,,g' ${WRKSRC}/${FILE}.sed > ${WRKSRC}/${FILE} ; ${RM} ${WRKSRC}/${FILE}.sed
+.endfor
+
+pre-build:
+ ${PERL} -pi -e "s@void main@int main@g" ${WRKSRC}/physmain.c
+ ${RM} -f ${WRKSRC}/physcalc
+
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -DSHAREDIR="\"${PREFIX}/share/physcalc/\"" -lm \
+ physmain.c physconv.c physmlib.c physnode.c physoper.c physsolv.c -o physcalc)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/physcalc ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/physcalc
+ ${INSTALL_DATA} ${WRKSRC}/*.phy ${PREFIX}/share/physcalc
+
+.include <bsd.port.mk>