aboutsummaryrefslogtreecommitdiff
path: root/math/ploticus/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 18:31:24 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 18:31:24 +0000
commit57e7b9fc213a41722e3f7812d88bd40401cdbb99 (patch)
treea88592b5d71c85e1044518ff00ac34ec493a8a88 /math/ploticus/Makefile
parent76bab1d188c260f4f21a95d180338d32241ca7fd (diff)
downloadports-57e7b9fc213a41722e3f7812d88bd40401cdbb99.tar.gz
ports-57e7b9fc213a41722e3f7812d88bd40401cdbb99.zip
Notes
Diffstat (limited to 'math/ploticus/Makefile')
-rw-r--r--math/ploticus/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/math/ploticus/Makefile b/math/ploticus/Makefile
index 18dc72c74f1e..866bdcaffe33 100644
--- a/math/ploticus/Makefile
+++ b/math/ploticus/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= ploticus
-PORTVERSION= 2.04
+PORTVERSION= 2.10
CATEGORIES= math
MASTER_SITES= http://ploticus.sourceforge.net/download/
DISTNAME= plsrc${PORTVERSION:S/.//}
@@ -15,29 +15,25 @@ DISTNAME= plsrc${PORTVERSION:S/.//}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
- png:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg \
- freetype:${PORTSDIR}/print/freetype2
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ freetype.9:${PORTSDIR}/print/freetype2
-USE_XLIB= yes
-USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-ALL_TARGET= # empty
-MAKE_ENV= LIBS="-L${LOCALBASE}/lib"
-MAN1= pl.1
+USE_XLIB= yes
+ALL_TARGET= ${PORTNAME}
-post-patch:
- @${REINPLACE_CMD} -e "s,^CC,#CC,g" ${WRKSRC}/Makefile
+MAN1= pl.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pl ${PREFIX}/bin
@${MKDIR} ${DATADIR}
- ${CP} ${WRKSRC}/../prefabs/* ${DATADIR}
- ${INSTALL_MAN} ${WRKSRC}/../man/man1/${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/../prefabs/* ${DATADIR}
+ ${INSTALL_MAN} ${WRKSRC}/../man/man1/${MAN1} ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/../doc/* ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../doc/* ${DOCSDIR}
.endif
.include <bsd.port.mk>