aboutsummaryrefslogtreecommitdiff
path: root/math/plplot/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-10-06 08:18:49 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-10-06 08:18:49 +0000
commit59effd03fb3834cd97d7930f551c07e0ec408755 (patch)
tree3100c50ad9887c67ab29c52eea1c13e1f496eb03 /math/plplot/Makefile
parentafcf895e49c7a68883ff927f88d58e7db1cbce1f (diff)
Notes
Diffstat (limited to 'math/plplot/Makefile')
-rw-r--r--math/plplot/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
new file mode 100644
index 000000000000..654b51ca0c8b
--- /dev/null
+++ b/math/plplot/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: plplot
+# Version required: 4p99j
+# Date created: 03 Oct 1997
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= plplot4p99j
+PKGNAME= plplot-4.99j
+CATEGORIES= math
+MASTER_SITES= ftp://dino.ph.utexas.edu/plplot/distrib/alpha/
+
+MAINTAINER= tg@FreeBSD.ORG
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-gcc=yes --with-double=yes
+
+post-patch:
+ @perl -pi.bak -e "s|/usr/local/plplot/lib|${PREFIX}/lib/plplot|g;" \
+ ${WRKSRC}/src/plctrl.c
+
+.include <bsd.port.mk>