aboutsummaryrefslogtreecommitdiff
path: root/math/plplot/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-08-11 11:07:14 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-08-11 11:07:14 +0000
commit78e011891c3d60d76482f7a7c0995fe8b1a6437f (patch)
tree64c7d0cf1da548541afe27272c764ab599ecf938 /math/plplot/Makefile
parent68fbf0ddf1e05833319c6d92334701090a116b4b (diff)
Notes
Diffstat (limited to 'math/plplot/Makefile')
-rw-r--r--math/plplot/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 4da0a9d4373f..d9ccf253f096 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= plplot
-PORTVERSION= 5.3.0
+PORTVERSION= 5.3.1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -46,6 +46,14 @@ PLIST_SUB+= X11=""
CONFIGURE_ARGS+= --with-pthreads
.endif
+.if defined(WITH_SVGALIB)
+LIB_DEPENDS+= vga:${PORTSDIR}/graphics/svgalib
+PLIST_SUB+= SVGALIB=""
+.else
+CONFIGURE_ARGS+= --disable-linuxvga
+PLIST_SUB+= SVGALIB="@comment "
+.endif
+
.if defined(WITH_PYTHON)
USE_PYTHON= yes
PLIST_SUB+= PYTHON=""
@@ -81,6 +89,7 @@ pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} " WITHOUT_X11=yes Turns off X11 support"
@${ECHO_MSG} " WITHOUT_PTHREAD=yes Turns off pthread support"
+ @${ECHO_MSG} " WITH_SVGALIB=yes Turns on SVGAlib support"
@${ECHO_MSG} " WITH_PYTHON=yes Turns on Python support"
@${ECHO_MSG} " WITH_TCLTK=yes Turns on Tcl/Tk support"
@${ECHO_MSG} ""