aboutsummaryrefslogtreecommitdiff
path: root/math/plplot
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-12-30 22:50:25 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-12-30 22:50:25 +0000
commit81a619599ce6bb6ebffd94e416996da24e8b0c20 (patch)
treed5b32c0cee581b3996383166a119c7aa87552ffa /math/plplot
parentee98532506f0233da538cc368bd7a50a975587cd (diff)
downloadports-81a619599ce6bb6ebffd94e416996da24e8b0c20.tar.gz
ports-81a619599ce6bb6ebffd94e416996da24e8b0c20.zip
Notes
Diffstat (limited to 'math/plplot')
-rw-r--r--math/plplot/Makefile2
-rw-r--r--math/plplot/files/patch-cmake_modules_csiro.cmake13
2 files changed, 14 insertions, 1 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 17c959c706aa..3da63eb4fe6f 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -58,7 +58,7 @@ USE_FORTRAN= yes
CONFIGURE_ENV+= CMAKE_Fortran_COMPILER=${FC}
PLIST_SUB+= FORTRAN=""
.else
-CMAKE_ARGS+= -DENABLE_f95:BOOL=OFF
+CMAKE_ARGS+= -DENABLE_f95:BOOL=OFF -DENABLE_f77:BOOL=OFF
PLIST_SUB+= FORTRAN="@comment "
.endif
diff --git a/math/plplot/files/patch-cmake_modules_csiro.cmake b/math/plplot/files/patch-cmake_modules_csiro.cmake
new file mode 100644
index 000000000000..ab1d76d810a6
--- /dev/null
+++ b/math/plplot/files/patch-cmake_modules_csiro.cmake
@@ -0,0 +1,13 @@
+--- cmake/modules/csiro.cmake.orig 2009-09-06 21:04:43.000000000 +0200
++++ cmake/modules/csiro.cmake 2009-12-30 21:10:58.000000000 +0100
+@@ -36,6 +36,10 @@
+ else(CMAKE_C_COMPILER MATCHES "gcc")
+ set(NAN_CFLAGS "${NAN_CFLAGS} -ieee")
+ endif(CMAKE_C_COMPILER MATCHES "gcc")
++ else(CMAKE_SYSTEM_PROCESSOR MATCHES "alpha.*")
++ if(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64")
++ set(NAN_CFLAGS "${NAN_CFLAGS} -mieee-fp")
++ endif(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64")
+ endif(CMAKE_SYSTEM_PROCESSOR MATCHES "alpha.*")
+ endif(CMAKE_SYSTEM_PROCESSOR MATCHES "i[0-9]86")
+ if(NOT DEFINED NaNAwareCCompiler)