aboutsummaryrefslogtreecommitdiff
path: root/math/polymake
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-10 01:16:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-10 01:16:26 +0000
commita9d2baca78dfe21c6567e438763d36aa2c96a91e (patch)
treeb9779c6e8691507304c3ac2cc5f4bd8b369d9c1c /math/polymake
parent91ada3514c4b9b5f6cd0bb75c9992f5e9bab0e93 (diff)
downloadports-a9d2baca78dfe21c6567e438763d36aa2c96a91e.tar.gz
ports-a9d2baca78dfe21c6567e438763d36aa2c96a91e.zip
Notes
Diffstat (limited to 'math/polymake')
-rw-r--r--math/polymake/Makefile25
-rw-r--r--math/polymake/distinfo4
-rw-r--r--math/polymake/pkg-descr5
-rw-r--r--math/polymake/pkg-plist22
4 files changed, 43 insertions, 13 deletions
diff --git a/math/polymake/Makefile b/math/polymake/Makefile
index a3f9bae89af9..3203ccac9060 100644
--- a/math/polymake/Makefile
+++ b/math/polymake/Makefile
@@ -7,14 +7,19 @@
PORTNAME= polymake
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ftp://ftp.math.tu-berlin.de/pub/combi/polymake/
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-p1.diff.bz2 ${PORTNAME}-${PORTVERSION}-p2.diff.bz2
+
MAINTAINER= gawrilow@math.tu-berlin.de
COMMENT= A framework for experimental discrete mathematics
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_PERL5= yes
@@ -23,8 +28,6 @@ HAS_CONFIGURE= yes
INSTALL_TARGET= install install-devel
NO_INSTALL_MANPAGES= yes
-PLIST_SUB= PERL=${PERL}
-
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
@@ -33,6 +36,7 @@ BROKEN= does not configure with perl 5.0
do-configure:
cd ${WRKSRC}; \
+ rm -f build*/conf.make; \
{ echo CC='${CC}'; \
echo CXX='${CXX}'; \
echo Cflags='${CFLAGS} -I${PREFIX}/include'; \
@@ -45,7 +49,22 @@ do-configure:
echo PerlExe='${PERL}'; \
} | gmake configure
+pre-install:
+ rm -f `find ${WRKSRC} -name '*.orig'`
+
post-install:
- ${PERL} -i -p -e 'print "PREFIX=${PREFIX}\n" if /InstallTop=/;' ${PREFIX}/libexec/polymake/Makefile
+ ${AWK} '/InstallTop=/ { print "PREFIX=${PREFIX}" } { print }' \
+ ${PREFIX}/libexec/polymake/Makefile >${PREFIX}/libexec/polymake/Makefile.devel
+ cp -p ${PREFIX}/libexec/polymake/Makefile.devel ${PREFIX}/libexec/polymake/Makefile
+ rm ${PREFIX}/bin/polymake
+ ${SED} -e '/^use lib/ s|"[^"]*/perlx"|"${PREFIX}/libexec/polymake/perlx"|' \
+ ${PREFIX}/share/polymake/perl/polymake >${PREFIX}/bin/polymake
+ chmod 755 ${PREFIX}/bin/polymake
+ mkdir ${PREFIX}/libexec/polymake/perlx
+ eval `${PERL} -V:archname`; \
+ mv ${PREFIX}/share/polymake/perlx/$$archname ${PREFIX}/libexec/polymake/perlx/${PERL_ARCH}; \
+ ${REINPLACE_CMD} -e "s|/share/polymake/perlx/$$archname/|/libexec/polymake/perlx/${PERL_ARCH}/|g" ${PREFIX}/libexec/polymake/perlx/${PERL_ARCH}/auto/Poly/Ext/.packlist
+ rm -f ${PREFIX}/libexec/polymake/perlx/${PERL_ARCH}/auto/Poly/Ext/.packlist.bak
+ rmdir ${PREFIX}/share/polymake/perlx
.include <bsd.port.post.mk>
diff --git a/math/polymake/distinfo b/math/polymake/distinfo
index 898b0a066980..d25a1ce96b25 100644
--- a/math/polymake/distinfo
+++ b/math/polymake/distinfo
@@ -1,2 +1,6 @@
MD5 (polymake-2.1.0.tar.bz2) = 76857a92faccc0b5371becad44f3724a
SIZE (polymake-2.1.0.tar.bz2) = 2883560
+MD5 (polymake-2.1.0-p1.diff.bz2) = 1de60e375b5d7abbacdfe3bd249b0134
+SIZE (polymake-2.1.0-p1.diff.bz2) = 9411
+MD5 (polymake-2.1.0-p2.diff.bz2) = a761bdbb2189722f27524c9f3e1f4330
+SIZE (polymake-2.1.0-p2.diff.bz2) = 8072
diff --git a/math/polymake/pkg-descr b/math/polymake/pkg-descr
index 4256fa0e45dd..0a608973a967 100644
--- a/math/polymake/pkg-descr
+++ b/math/polymake/pkg-descr
@@ -1,5 +1,6 @@
-Polymake is a versatile tool for the algorithmic treatment of
-polytopes and polyhedra, and finite simplicial complexes.
+Polymake is a versatile framework for experimental discrete mathematics.
+The standard distribution contains tool collections for the algorithmic
+treatment of polytopes and polyhedra, and finite simplicial complexes.
It offers an unified interface to a wide variety of algorithms
and free software packages from the computational geometry field,
such as convex hull computation or visualization tools.
diff --git a/math/polymake/pkg-plist b/math/polymake/pkg-plist
index e5520d3cd1ed..137e3d6d4cdc 100644
--- a/math/polymake/pkg-plist
+++ b/math/polymake/pkg-plist
@@ -1,8 +1,10 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Poly/Ext/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Poly/Ext/Ext.bs
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Poly/Ext/Ext.so
-libexec/polymake/Makefile
-@exec %%PERL%% -i -p -e 's:PREFIX=.*:PREFIX=%D:' %D/%F
+libexec/polymake/perlx/%%PERL_ARCH%%/auto/Poly/Ext/.packlist
+libexec/polymake/perlx/%%PERL_ARCH%%/auto/Poly/Ext/Ext.bs
+libexec/polymake/perlx/%%PERL_ARCH%%/auto/Poly/Ext/Ext.so
+libexec/polymake/Makefile.devel
+@exec sed -e 's:PREFIX=.*:PREFIX=%D:' %D/%F >%B/Makefile
+@unexec rm -f %B/Makefile
+@exec [ -e %D/bin ] || mkdir %D/bin
libexec/polymake/apps/polytope/bin/2-face-sizes-simple
@exec ln -s %D/%F %D/bin
@unexec rm -f %D/bin/%f
@@ -633,6 +635,7 @@ libexec/polymake/modules/graph/bin/triangle_free
%%DOCSDIR%%/index.html
%%DOCSDIR%%/install-bin.html
%%DOCSDIR%%/install-full.html
+%%DOCSDIR%%/install-port.html
%%DOCSDIR%%/install-rpm.html
%%DOCSDIR%%/lib/AVL.html
%%DOCSDIR%%/lib/Array.html
@@ -966,7 +969,7 @@ share/polymake/perl/Struct.pm
share/polymake/perl/Switches.pm
share/polymake/perl/namespaces.pm
share/polymake/perl/polymake
-@exec ln -s %D/%F %D/bin; %%PERL%% -i -p -e 's|(\$InstallTop\s*=\s*).*|$1"%D/share/polymake";|' %D/%F
+@exec sed -e '/\$InstallTop *=/ s|".*"|"%D/share/polymake"|' -e '/^use lib/ s|"[^"]*/perlx"|"%D/libexec/polymake/perlx"|' %D/%F >%D/bin/%f; chmod 755 %D/bin/%f
@unexec rm -f %D/bin/%f
share/polymake/povray/polymake-scene.pov
share/polymake/scripts/grow_complex
@@ -1049,6 +1052,9 @@ share/polymake/support/java.make
@dirrm libexec/polymake/apps/polytope/bin
@dirrm libexec/polymake/apps/polytope
@dirrm libexec/polymake/apps
+@dirrm libexec/polymake/perlx/%%PERL_ARCH%%/auto/Poly/Ext
+@dirrm libexec/polymake/perlx/%%PERL_ARCH%%/auto/Poly
+@dirrm libexec/polymake/perlx/%%PERL_ARCH%%/auto
+@dirrm libexec/polymake/perlx/%%PERL_ARCH%%
+@dirrm libexec/polymake/perlx
@dirrm libexec/polymake
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Poly/Ext
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Poly