aboutsummaryrefslogtreecommitdiff
path: root/math/primesieve
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-08 05:50:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-08 05:50:41 +0000
commit829fd3baa939c92a6e884a0a0e5599591400b7b2 (patch)
tree252e23f33d5103ff061b077f1eec1ea08166fffb /math/primesieve
parent68197f1a2f1efa571bfb265f475b84b7d0b098f9 (diff)
Notes
Diffstat (limited to 'math/primesieve')
-rw-r--r--math/primesieve/Makefile28
-rw-r--r--math/primesieve/distinfo3
-rw-r--r--math/primesieve/pkg-descr6
-rw-r--r--math/primesieve/pkg-plist16
4 files changed, 53 insertions, 0 deletions
diff --git a/math/primesieve/Makefile b/math/primesieve/Makefile
new file mode 100644
index 000000000000..a7a7b536b5f2
--- /dev/null
+++ b/math/primesieve/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= primesieve
+DISTVERSIONPREFIX= v
+DISTVERSION= 7.4-26
+DISTVERSIONSUFFIX= -g5b757b77
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast prime number generator
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cmake compiler:c++11-lang
+USE_GITHUB= yes
+GH_ACCOUNT= kimwalisch
+USE_LDCONFIG= yes
+
+CMAKE_OFF= BUILD_STATIC_LIBS
+
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTS:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>
diff --git a/math/primesieve/distinfo b/math/primesieve/distinfo
new file mode 100644
index 000000000000..a9033767072e
--- /dev/null
+++ b/math/primesieve/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1557293982
+SHA256 (kimwalisch-primesieve-v7.4-26-g5b757b77_GH0.tar.gz) = df450b205e4a03f297d0dacb256e810357277c0aacf185bd2c40239cfae36655
+SIZE (kimwalisch-primesieve-v7.4-26-g5b757b77_GH0.tar.gz) = 170496
diff --git a/math/primesieve/pkg-descr b/math/primesieve/pkg-descr
new file mode 100644
index 000000000000..194990a8122e
--- /dev/null
+++ b/math/primesieve/pkg-descr
@@ -0,0 +1,6 @@
+primesieve is a program and C/C++ library that generates primes using a highly
+optimized sieve of Eratosthenes implementation. It counts the primes below 10^10
+in just 0.4 seconds on an Intel Core i7-6700 CPU (4 x 3.4 GHz). primesieve can
+generate primes and prime k-tuplets up to 2^64.
+
+WWW: https://github.com/kimwalisch/primesieve
diff --git a/math/primesieve/pkg-plist b/math/primesieve/pkg-plist
new file mode 100644
index 000000000000..10ee0c32e0b0
--- /dev/null
+++ b/math/primesieve/pkg-plist
@@ -0,0 +1,16 @@
+bin/primesieve
+include/primesieve.h
+include/primesieve.hpp
+include/primesieve/StorePrimes.hpp
+include/primesieve/iterator.h
+include/primesieve/iterator.hpp
+include/primesieve/primesieve_error.hpp
+lib/cmake/primesieve/primesieveConfig.cmake
+lib/cmake/primesieve/primesieveConfigVersion.cmake
+lib/cmake/primesieve/primesieveShared-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/primesieve/primesieveShared.cmake
+lib/libprimesieve.so
+lib/libprimesieve.so.9
+lib/libprimesieve.so.9.5.0
+libdata/pkgconfig/primesieve.pc
+man/man1/primesieve.1.gz