aboutsummaryrefslogtreecommitdiff
path: root/math/prng/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:29:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:29:17 +0000
commit1428d6519b158771de764f146d75c2127308711d (patch)
tree9f2a2c68e7096b69b55703a2020b5a0d69f5e0d6 /math/prng/Makefile
parent5e5c2a70c78a43df44ae9deffc1f773c4dd0134e (diff)
Notes
Diffstat (limited to 'math/prng/Makefile')
-rw-r--r--math/prng/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/math/prng/Makefile b/math/prng/Makefile
new file mode 100644
index 000000000000..5102db1732d4
--- /dev/null
+++ b/math/prng/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: prng
+# Date created: 16 Feb. 2010
+# Whom: bf <bf1783@gmail.com>
+# $FreeBSD$
+
+PORTNAME= prng
+DISTVERSION= 3.0.2
+CATEGORIES= math
+MASTER_SITES= http://statistik.wu-wien.ac.at/software/prng/
+
+MAINTAINER= bf1783@gmail.com
+COMMENT= Portable, high-performance ANSI-C pseudorandom number generators
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+INFO= prng
+PLIST_FILES= include/prng.h lib/libprng.a
+PORTDOCS= prng.dvi prng.pdf prng.ps prng.txt
+PORTEXAMPLES= Makefile pairs.c tuples.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for _d in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${_d} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+.for _e in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${_e} ${EXAMPLESDIR}
+.endfor
+.endif
+
+test: build
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+
+.include <bsd.port.mk>