aboutsummaryrefslogtreecommitdiff
path: root/math/prng
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:29:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:29:17 +0000
commit1428d6519b158771de764f146d75c2127308711d (patch)
tree9f2a2c68e7096b69b55703a2020b5a0d69f5e0d6 /math/prng
parent5e5c2a70c78a43df44ae9deffc1f773c4dd0134e (diff)
downloadports-1428d6519b158771de764f146d75c2127308711d.tar.gz
ports-1428d6519b158771de764f146d75c2127308711d.zip
Notes
Diffstat (limited to 'math/prng')
-rw-r--r--math/prng/Makefile39
-rw-r--r--math/prng/distinfo3
-rw-r--r--math/prng/pkg-descr6
3 files changed, 48 insertions, 0 deletions
diff --git a/math/prng/Makefile b/math/prng/Makefile
new file mode 100644
index 000000000000..5102db1732d4
--- /dev/null
+++ b/math/prng/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: prng
+# Date created: 16 Feb. 2010
+# Whom: bf <bf1783@gmail.com>
+# $FreeBSD$
+
+PORTNAME= prng
+DISTVERSION= 3.0.2
+CATEGORIES= math
+MASTER_SITES= http://statistik.wu-wien.ac.at/software/prng/
+
+MAINTAINER= bf1783@gmail.com
+COMMENT= Portable, high-performance ANSI-C pseudorandom number generators
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+INFO= prng
+PLIST_FILES= include/prng.h lib/libprng.a
+PORTDOCS= prng.dvi prng.pdf prng.ps prng.txt
+PORTEXAMPLES= Makefile pairs.c tuples.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for _d in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${_d} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+.for _e in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${_e} ${EXAMPLESDIR}
+.endfor
+.endif
+
+test: build
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+
+.include <bsd.port.mk>
diff --git a/math/prng/distinfo b/math/prng/distinfo
new file mode 100644
index 000000000000..cd195bca190d
--- /dev/null
+++ b/math/prng/distinfo
@@ -0,0 +1,3 @@
+MD5 (prng-3.0.2.tar.gz) = 80cb0870f2d18618bd2772f9e1dc1a70
+SHA256 (prng-3.0.2.tar.gz) = 8299182b97c24b7891d74590a8a8438641a6c681ce34d6c3f7bc98a0649da48b
+SIZE (prng-3.0.2.tar.gz) = 497047
diff --git a/math/prng/pkg-descr b/math/prng/pkg-descr
new file mode 100644
index 000000000000..9c5ca3315057
--- /dev/null
+++ b/math/prng/pkg-descr
@@ -0,0 +1,6 @@
+PRNG is a collection of portable, high-performance ANSI-C implementations of
+pseudorandom number generators such as linear congruential, inversive
+congruential, and explicit inversive congruential random number generators (LCG,
+ICG and EICG, respectively) created by Otmar Lendl and and Josef Leydold.
+
+WWW: http://statistik.wu-wien.ac.at/software/prng/index.html