aboutsummaryrefslogtreecommitdiff
path: root/math/proofgeneral/Makefile
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-04-19 22:38:31 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-04-19 22:38:31 +0000
commit77a5fc6b3f0f3719dd7b2e6a855fa826b381a7c7 (patch)
tree5c3742fa4cc6747da32740e01ceb856d3dbed9d1 /math/proofgeneral/Makefile
parent159c5f868149665a5c15f908a680f12346f93368 (diff)
downloadports-77a5fc6b3f0f3719dd7b2e6a855fa826b381a7c7.tar.gz
ports-77a5fc6b3f0f3719dd7b2e6a855fa826b381a7c7.zip
Notes
Diffstat (limited to 'math/proofgeneral/Makefile')
-rw-r--r--math/proofgeneral/Makefile59
1 files changed, 27 insertions, 32 deletions
diff --git a/math/proofgeneral/Makefile b/math/proofgeneral/Makefile
index de72df0da0b0..8c048bff9b93 100644
--- a/math/proofgeneral/Makefile
+++ b/math/proofgeneral/Makefile
@@ -6,52 +6,44 @@
#
PORTNAME= proofgeneral
-PORTVERSION= 3.7.1
-PORTREVISION= 5
+PORTVERSION= 4.1
CATEGORIES= math elisp
MASTER_SITES= http://proofgeneral.inf.ed.ac.uk/releases/
-DISTNAME= ProofGeneral-3.7.1
+PKGNAMESUFFIX= -${EMACS_NAME}
+DISTNAME= ProofGeneral-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= beyert@cs.ucr.edu
COMMENT= A generic interface for proof assistants
-PKGNAMESUFFIX+= -${EMACS_NAME}
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
-RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
-
-#
-# Unless EMACS_PORT_NAME is overriden by the user,
-# use any installed version of [X]Emacs.
-#
-# If there is none installed, use xemacs21-mule.
-#
-.if !defined(EMACS_PORT_NAME)
-.if !exists(${LOCALBASE}/bin/emacs)
-EMACS_PORT_NAME=xemacs21-mule
-BUILD_DEPENDS+= ${LOCALBASE}/bin/xemacs:${PORTSDIR}/editors/${EMACS_PORT_NAME}
-RUN_DEPENDS+= ${LOCALBASE}/bin/xemacs:${PORTSDIR}/editors/${EMACS_PORT_NAME}
-
-# xemacs21-mule does not depend on xemacs-packages, so add a dependency here
-BUILD_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/lisp/xlib/xlib-xlib.el:${PORTSDIR}/editors/xemacs-packages
-RUN_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/lisp/xlib/xlib-xlib.el:${PORTSDIR}/editors/xemacs-packages
-.else
-EMACS_PORT_NAME=emacs
-BUILD_DEPENDS+= ${LOCALBASE}/bin/emacs:${PORTSDIR}/editors/${EMACS_PORT_NAME}
-RUN_DEPENDS+= ${LOCALBASE}/bin/emacs:${PORTSDIR}/editors/${EMACS_PORT_NAME}
-.endif
-.endif
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
USE_EMACS= yes
USE_GMAKE= yes
-USE_GNOME= gnomehier
INSTALLS_ICONS= yes
USE_PERL5= yes
.include <bsd.port.pre.mk>
-MAKE_ARGS+= EMACS_NAME=${EMACS_NAME} EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
+.ifdef (PACKAGE_BUILDING)
+PLIST_SUB+= PACKAGE_BUILDING="@comment "
+.else
+PLIST_SUB+= PACKAGE_BUILDING=""
+.endif
+
+MAKE_ARGS+= PREFIX="${LOCALBASE}" DEST_PREFIX="${PREFIX}" MAKE="${GMAKE}" \
+ DOCDIR="${DOCSDIR}" MANDIR="${PREFIX}/man/man1" INFODIR="${PREFIX}/info" \
+ BINDIR="${PREFIX}/bin" DESKTOP="${PREFIX}/share" \
+ ELISPP="${EMACS_SITE_LISPDIR}/ProofGeneral" \
+ ELISP="${PREFIX}/${EMACS_SITE_LISPDIR}/ProofGeneral" \
+ ELISP_START="${PREFIX}/${EMACS_SITE_LISPDIR}/site-start.d" \
+ EMACS="${EMACS_NAME}" EMACS_NAME="${EMACS_NAME}" \
+ DEST_ELISP="${PREFIX}/${EMACS_SITE_LISPDIR}/ProofGeneral" \
+ EMACS_SITE_LISPDIR="${EMACS_SITE_LISPDIR}"
SUB_FILES= pkg-message
SUB_LIST= EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
@@ -62,10 +54,13 @@ INFO= PG-adapting ProofGeneral
.if !defined(NOPORTDOCS)
MAKE_ARGS+= DOCSDIR=${DOCSDIR} INSTALLDOC=install-doc
-BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX-base \
- texi2pdf:${PORTSDIR}/print/texinfo
+BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
.endif
+PORTDOCS= AUTHORS BUGS CHANGES COMPATIBILITY COPYING INSTALL \
+ PG-adapting ProofGeneral README REGISTER acl2 hol98 isar lclam lego \
+ pgshell phox plastic twelf
+
post-patch:
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
${WRKSRC}/etc/desktop/proofgeneral.desktop