aboutsummaryrefslogtreecommitdiff
path: root/math/proofgeneral/Makefile
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-08-31 10:36:36 +0000
committerSimon Barner <barner@FreeBSD.org>2005-08-31 10:36:36 +0000
commitf6925bfda8fa5d2210b99b27e56627b190c0cca9 (patch)
treeca3da9d2b0641bd54a5bb5829c60a043ecb64387 /math/proofgeneral/Makefile
parent67a6d6e2b98bd8a48f3ca7a8db183cac1e414aca (diff)
downloadports-f6925bfda8fa5d2210b99b27e56627b190c0cca9.tar.gz
ports-f6925bfda8fa5d2210b99b27e56627b190c0cca9.zip
Notes
Diffstat (limited to 'math/proofgeneral/Makefile')
-rw-r--r--math/proofgeneral/Makefile76
1 files changed, 76 insertions, 0 deletions
diff --git a/math/proofgeneral/Makefile b/math/proofgeneral/Makefile
new file mode 100644
index 000000000000..89dd1e6fe31a
--- /dev/null
+++ b/math/proofgeneral/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: proofgeneral
+# Date created: 11 August 2005
+# Whom: Timothy Bourke <timbob@bigpond.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= proofgeneral
+PORTVERSION= 3.5
+CATEGORIES= math elisp
+MASTER_SITES= http://proofgeneral.inf.ed.ac.uk/releases/ \
+ http://www.cl.cam.ac.uk/Research/HVG/Isabelle/dist/contrib/ \
+ http://isabelle.in.tum.de/dist/contrib/ \
+ http://mirror.cse.unsw.edu.au/pub/isabelle/contrib/
+DISTNAME= ProofGeneral-3.5
+
+MAINTAINER= timbob@bigpond.com
+COMMENT= A generic interface for proof assistants
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ ${EMACS_NAME}:${EMACS_PORTSDIR}
+
+.if exists(${LOCALBASE}/bin/xemacs)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages:${PORTSDIR}/editors/xemacs-packages
+RUN_DEPENDS+= ${LOCALBASE}/share/applications/.keep_me:${PORTSDIR}/misc/kdehier
+.endif
+
+.if exists(${LOCALBASE}/bin/xemacs) || !exists(${LOCALBASE}/bin/emacs)
+EMACS_PORT_NAME=xemacs21-mule
+.else
+EMACS_PORT_NAME=emacs21
+.endif
+
+MAKE_ARGS+= EMACS_NAME=${EMACS_NAME} EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_REINPLACE= yes
+
+SUB_FILES= pkg-message
+SUB_LIST= EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
+
+MAN1= proofgeneral.1
+MANCOMPRESSED= no
+INFO= PG-adapting ProofGeneral
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= PG-adapting_*.html ProofGeneral_*.html \
+ ProofGeneral.pdf PG-adapting.pdf
+MAKE_ARGS+= INSTALL_DOC=doc.pdf
+BUILD_DEPENDS+= ${LOCALBASE}/bin/texi2pdf:${PORTSDIR}/print/teTeX-base
+.endif
+
+post-patch:
+ @${TOUCH} -m -r ${WRKSRC}/generic/proof-menu.el.orig \
+ ${WRKSRC}/generic/proof-menu.el
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
+ ${WRKSRC}/etc/desktop/proofgeneral.desktop
+
+pre-build:
+.if defined(BYTE_COMPILE)
+ @${ECHO_CMD} "************************************************************"
+ @${ECHO_CMD} "* Byte compilation may not work properly for all files... *"
+ @${ECHO_CMD} "************************************************************"
+ @${RM} ${WRKSRC}/.byte-compile
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>