aboutsummaryrefslogtreecommitdiff
path: root/math/proofgeneral/Makefile
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2007-02-06 22:55:25 +0000
committerAndrey Slusar <anray@FreeBSD.org>2007-02-06 22:55:25 +0000
commitb32b35935a13a8c3d97850df623c17c33db5420b (patch)
tree501c0d66b8da83b1b7492fedb0932db142c08961 /math/proofgeneral/Makefile
parentd69baa11c2bf22090919ae8cfbeadb04cccd91d5 (diff)
downloadports-b32b35935a13a8c3d97850df623c17c33db5420b.tar.gz
ports-b32b35935a13a8c3d97850df623c17c33db5420b.zip
Notes
Diffstat (limited to 'math/proofgeneral/Makefile')
-rw-r--r--math/proofgeneral/Makefile53
1 files changed, 22 insertions, 31 deletions
diff --git a/math/proofgeneral/Makefile b/math/proofgeneral/Makefile
index 6e947ecedb1a..1503d124d84e 100644
--- a/math/proofgeneral/Makefile
+++ b/math/proofgeneral/Makefile
@@ -7,10 +7,10 @@
PORTNAME= proofgeneral
PORTVERSION= 3.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math elisp
MASTER_SITES= http://proofgeneral.inf.ed.ac.uk/releases/
-DISTNAME= ProofGeneral-3.6pre051004
+DISTNAME= ProofGeneral-3.6pre061107
MAINTAINER= timbob@bigpond.com
COMMENT= A generic interface for proof assistants
@@ -18,17 +18,7 @@ COMMENT= A generic interface for proof assistants
PKGNAMESUFFIX+= -${EMACS_NAME}
BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash
-RUN_DEPENDS+= ${LOCALBASE}/share/applications/.keep_me:${PORTSDIR}/misc/kdehier
-
-BROKEN= Incomplete pkg-plist
-DEPRECATED= Needs to be rewritten to not include bsd.emacs.mk
-EXPIRATION_DATE=2007-02-07
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN="Does not build on amd64"
-.endif
+RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
#
# Unless EMACS_PORT_NAME is overriden by the user,
@@ -39,24 +29,33 @@ BROKEN="Does not build on amd64"
.if !defined(EMACS_PORT_NAME)
.if !exists(${LOCALBASE}/bin/emacs)
EMACS_PORT_NAME=xemacs21-mule
+BUILD_DEPENDS+= ${LOCALBASE}/bin/xemacs:${PORTSDIR}/editors/${EMACS_PORT_NAME}
+RUN_DEPENDS+= ${LOCALBASE}/bin/xemacs:${PORTSDIR}/editors/${EMACS_PORT_NAME}
# xemacs21-mule does not depend on xemacs-packages, so add a dependency here
BUILD_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/lisp/xlib/xlib-xlib.el:${PORTSDIR}/editors/xemacs-packages
RUN_DEPENDS+= ${LOCALBASE}/lib/xemacs/xemacs-packages/lisp/xlib/xlib-xlib.el:${PORTSDIR}/editors/xemacs-packages
.else
-EMACS_PORT_NAME=emacs21
+EMACS_PORT_NAME=emacs
+BUILD_DEPENDS+= ${LOCALBASE}/bin/emacs:${PORTSDIR}/editors/${EMACS_PORT_NAME}
+RUN_DEPENDS+= ${LOCALBASE}/bin/emacs:${PORTSDIR}/editors/${EMACS_PORT_NAME}
.endif
.endif
-# Needed for proper build- and run-time [x]xemacs dependencies,
-# and the definition of EMACS_NAME and EMACS_SITE_LISPDIR
-.include "${PORTSDIR}/Mk/bsd.emacs.mk"
-
-MAKE_ARGS+= EMACS_NAME=${EMACS_NAME} EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
USE_EMACS= yes
USE_GMAKE= yes
+USE_GNOME= gnomehier
+INSTALLS_ICONS= yes
USE_PERL5= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN="Does not build on amd64"
+.endif
+
+MAKE_ARGS+= EMACS_NAME=${EMACS_NAME} EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
+
SUB_FILES= pkg-message
SUB_LIST= EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
@@ -65,9 +64,7 @@ MANCOMPRESSED= no
INFO= PG-adapting ProofGeneral
.if !defined(NOPORTDOCS)
-PORTDOCS= PG-adapting_*.html ProofGeneral_*.html \
- ProofGeneral.pdf PG-adapting.pdf
-MAKE_ARGS+= INSTALL_DOC=doc.pdf
+MAKE_ARGS+= DOCSDIR=${DOCSDIR} INSTALLDOC=install-doc
BUILD_DEPENDS+= ${LOCALBASE}/bin/texi2pdf:${PORTSDIR}/print/teTeX-base
.endif
@@ -77,17 +74,11 @@ post-patch:
${TOUCH} ${WRKSRC}/.byte-compile
pre-build:
-.if defined(BYTE_COMPILE)
- @${RM} ${WRKSRC}/.byte-compile
-.endif
+#.if defined(BYTE_COMPILE)
+ @${RM} ${WRKSRC}/.byte-compile || ${TRUE}
+#.endif
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
-.endfor
-.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>