aboutsummaryrefslogtreecommitdiff
path: root/math/pure-mpfr
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2013-11-06 22:50:21 +0000
committerXin LI <delphij@FreeBSD.org>2013-11-06 22:50:21 +0000
commitbc0d646198e21b9653ddde161dcdd059533a7d9a (patch)
treef4ca39f0f94b1fc725562cca278474e325706ee3 /math/pure-mpfr
parentae3e5e966b6d57cfc253af140717fe2208286c6b (diff)
downloadports-bc0d646198e21b9653ddde161dcdd059533a7d9a.tar.gz
ports-bc0d646198e21b9653ddde161dcdd059533a7d9a.zip
Notes
Diffstat (limited to 'math/pure-mpfr')
-rw-r--r--math/pure-mpfr/Makefile32
-rw-r--r--math/pure-mpfr/pkg-descr2
2 files changed, 28 insertions, 6 deletions
diff --git a/math/pure-mpfr/Makefile b/math/pure-mpfr/Makefile
index 51cb50b3ce2b..45bdd2c55cb6 100644
--- a/math/pure-mpfr/Makefile
+++ b/math/pure-mpfr/Makefile
@@ -3,19 +3,41 @@
PORTNAME= pure-mpfr
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= math
+MASTER_SITES= https://cdn.bitbucket.org/purelang/pure-lang/downloads/
+DIST_SUBDIR= pure
MAINTAINER= lichray@gmail.com
COMMENT= Multiprecision floats for Pure
-USE_PURE= yes
-USES= pkgconfig
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= dual
+
+MAKE_ARGS+= libdir="${PREFIX}/lib"
+
+USES= pkgconfig pure
PLIST_FILES= lib/pure/mpfr.pure \
lib/pure/mpfr.so
-MAKE_ARGS+= libdir="${PREFIX}/lib"
-
NO_STAGE= yes
-.include "${.CURDIR}/../../lang/pure/bsd.pure.mk"
+
+PORTDOCS= README
+
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
+.endif
+
.include <bsd.port.mk>
diff --git a/math/pure-mpfr/pkg-descr b/math/pure-mpfr/pkg-descr
index ba226da0803b..fc6974abaf24 100644
--- a/math/pure-mpfr/pkg-descr
+++ b/math/pure-mpfr/pkg-descr
@@ -2,4 +2,4 @@ pure-mpfr makes the MPFR multiprecision floats (henceforth referred to as
mpfr numbers or values) available in Pure, so that they work with the other
types of Pure numbers in an almost seamless fashion.
-WWW: http://docs.pure-lang.googlecode.com/hg/pure-mpfr.html
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-mpfr.html